Some special characters disturb 'dolphin' and ls when logged as user root.


I use this character ( and some other ) in folders name :

Character: ¬ U+00AC
Annotations and Cross References
Alias names:
angled dash (in typography)
See also:
General Character Properties
Block: Latin-1 Supplement
Unicode category: Symbol, Math
Various Useful Representations
UTF-8: 0xC2 0xAC
UTF-16: 0x00AC
C octal escaped UTF-8: \302\254
XML decimal entity: ¬

There is no problems when logged as normal user even when using dolphin or konsole in super user mode with password.

The problem arise when logged directly as user root. with the following configuration :

sysconfig editor/system/environment/language/root_uses_lang=yes
folder name showed like this : **��**000_COMMON**����**ICONS_WALLPAPERS_THEMES

Changing to

sysconfig editor/system/environment/language/root_uses_lang=ctype
Give the right name : folder name showed like this : **¬**000_COMMON**¬¬**ICONS_WALLPAPERS_THEMES

sysconfig editor/system/environment/language/rc_lc_type is empty.

Any help is welcome.


The problem arise when logged directly as user root.

The solution seems simple. Don’t directly login as root.

When ruining things as root you are using config in the /root not your home these may be set to different values then your home

That’s sweeping the dirt under the carpet.

Concerning kate and dolphin, root and all users have the same preferencies.
The only difference is that root use Adobe times fonts.

Not really, learn up on the command line tools, or user permissions and groups to move files around… else raise a bug report upstream about the issue.

Compare ~/.i18n for root and normal user.

Ok I will.

Referring to kde (for root and normal user) ‘system settings’ :
‘system settings’ / Regional settings / Format / Region = United State
‘system settings’ / Regional settings / Format / Numbers = France; …; Mesurement = France; Collation and sorting = United State

I want all messages text in English (because of the forum) and Numbers = France; …; Mesurement = France.

Do my preferences settings have interference?