Some sites hang regardless of browser used - new 12.1 installation

I just switched from Ubuntu to openSuse 12.1. Now some websites, like drudgereport.com or amd.com, won’t load. If I turn off Javascript, they both mostly load - drudge leaves a few images unloaded while amd loads completely but their support/drivers page won’t load at all. I tried replacing the openJDK with Sun’s Java with no change.

This happens with Firefox, Opera, and Chrome, so I expect it’s a network setting?

I am using NetworkManager, and a Verizon Droid phone tethered by USB.

Any help would be greatly appreciated.

I have not replaced openJDK in my openSUSE 12.1 install and both sites work just fine. I have fully upgraded my copy and wonder if you have done so yourself?

So, I normally suggest in KDE that you start YaST / Software / Software Management (You must enter your password to start YaST).

Then, in Software Management I do a:

  1. Options / Allow Vendor Change (Place an X there)
  2. Package / All Packages / Update if Newer Version Available (Agree if there are several Packages to update)
  3. You will then be presented with your choices to remove the conflict if one exists.

I normally make the following suggestions to all that have such problems:

To avoid package problems, the most important thing to do is to: NEVER ignore a dependency, even if YaST/zypper/updater gives you such an option! In general, never switch to an >inferior< architecture and the solution is most often to just switch Vendor to the >Packman< repository. So changing the vendor is OK, but >ignoring< dependencies is never a very good idea!

I might ask for you to tell about your video and desktop as you did not mention that in your message.

Thank You,

Thanks for answering.

I re-installed the entire OS after replacing openJDK, so I’m back to it by default. I am running Gnome. Video is ATI Radeon 4250 built into the motherboard. Since I couldn’t get the AMD support site to load, I updated the video driver by downloading to my phone and copying it over. It was the only way to get the sound to work through HDMI and adjust the screen size to fill the monitor.

After your response I found the Online Update icon in YaST. It found 76 updates but installing and rebooting did not help. I always accept the the default dependencies when I load or update. I added the Pacman repository after updating, but no new updates were found.

I don’t think this is a factor, but have you turned off IPv6 in Yast? Ubuntu does not have it on by default but Fedora and openSUSE defaults to having it on and I’ve had a lot of trouble with browsing until I turned it off.

Yast > Networking > accept that Network Manager is handling it, and then look for a checkbox. Sorry I am not in front of my openSUSE box right now to give better description and/or screenshots.

This is the answer to the problem. Many providers don’t support ipv6 even though they say so. The result is that the domainname does not resolve or times out. Switch it off in Yast - Network - Networksettings, then reboot (required)

On 01/31/2012 02:46 PM, Knurpht wrote:
>
> dragonbite;2436017 Wrote:
>> I don’t think this is a factor, but have you turned off IPv6 in Yast?
>> Ubuntu does not have it on by default but Fedora and openSUSE defaults
>> to having it on and I’ve had a lot of trouble with browsing until I
>> turned it off.
>>
>> Yast> Networking> accept that Network Manager is handling it, and
>> then look for a checkbox. Sorry I am not in front of my openSUSE box
>> right now to give better description and/or screenshots.
>
> This is the answer to the problem. Many providers don’t support ipv6
> even though they say so. The result is that the domainname does not
> resolve or times out. Switch it off in Yast - Network - Networksettings,
> then reboot (required)

Rather than switch it off, add a good IPv6-ready name server to
/etc/resolv.conf. I use 8.8.8.8 and 8.8.4.4.

I’m confused by the dual configuration. When I open Network Settings in YaST, I get the popup warning that changes must be made with Network Manager, but there are still options not grayed out. Is it just the settings in the Overview tab that are exclusively set in Network Manager? Do the options set under the other tabs, like “Global Options” or “Hostname/DNS” still matter if I am using NM?

I disabled IPv6 in Yast / Network Settings. I also checked the “Require IPv4” box under that connection inside Network Manager but it had no effect on the websites that I couldn’t load. (Yes I rebooted).

I would like to try the new name servers but the etc/resolv.conf file has a warning about manual edits. Where are name servers set? Under YaST / Network Settings / Hostname DNS/ the Name Server and Domain Search list is grayed out. I’ll do it manually if necessary but thought it would be good to know where it is set under a GUI.

(Thanks to everyone helping)

I’m confused by the dual configuration. When I open Network Settings in YaST, I get the popup warning that changes must be made with Network Manager, but there are still options not grayed out. Is it just the settings in the Overview tab that are exclusively set in Network Manager? Do the options set under the other tabs, like “Global Options” or “Hostname/DNS” still matter if I am using NM?

I disabled IPv6 in Yast / Network Settings. I also checked the “Require IPv4” box under that connection inside Network Manager but it had no effect on the websites that I couldn’t load. (Yes I rebooted).

I would like to try the new name servers but the etc/resolv.conf file has a warning about manual edits. Where are hostnames set? Under YaST / Network Settings / Hostname DNS/ the Name Server and Domain Search list is grayed out. I’ll do it manually if necessary but thought it would be good to know where it is set under a GUI.

(Thanks to everyone helping)

As a gnome user, you can use the following command: press Alt-F2 and then enter: gnomesu gedit resolv.conf

Then add the following info and save the file:

nameserver 8.8.8.8
nameserver 8.8.4.4

You need to restart for this information to be used.

Thank You,

OK. I edited my /etc/resolv.conf file with the new nameserver lines, then restarted. When I right clicked on Network Manager and checked connection info, the DNS was still the original 192.168.42.129. I googled that IP address and it’s all people using their smart phones for internet access. So I would have to assume that address was assigned by Verizon, possibly to spy on user data. Anyway, I rechecked the resolv.conf file and it is still 8.8.8.8 and 8.8.4.4. Therefore I assume that file is not used by Network Manager and changed it back to the original.

I did find a place to set DNS in NM, but only if I change the “Method” setting from “Automatic (DHCP)” under the IPv4 tab. So I changed it to “Automatic (DHCP) addresses only” and set the DNS server and search domains to 8.8.8.8 and reconnected. The DNS had changed but the “default route” was still the old 192.168.42.129. It didn’t help load drudge and my own page’s java stopped working (a google checkout button). So I switched everything back to automatic and I’m right back where I started.

I’m starting to blame Verizon. I can try another network connection this weekend and see what happens. I’ll keep researching on my own until then.

Thanks for everyone’s help.

On 2012-02-01 00:46, jdmcdaniel3 wrote:
> You need to restart for this information to be used.

No, you don’t. resolv changes are immediate.


Cheers / Saludos,

Carlos E. R.
(from 11.4 x86_64 “Celadon” at Telcontar)

On 2012-02-01 01:46, tomthehitmanhart wrote:

> resolv.conf file and it is still 8.8.8.8 and 8.8.4.4. Therefore I assume
> that file is not used by Network Manager.

Don’t worry, the system uses your settings.

You don’t believe me? Run in a terminal “host -v google.es”. in the several
lines of output there will be one or more similar to this:


Received 338 bytes from 192.168.1.14#53 in 0 ms

which specifies which DNS server was used for the query.

> domains to 8.8.8.8. I reconnected. The DNS had changed but the “default
> route” was still the old 192.168.42.129.

You can not change the default route and expect it to work.


Cheers / Saludos,

Carlos E. R.
(from 11.4 x86_64 “Celadon” at Telcontar)

You are on a private network, behind a router (your phone), so you will see a private IP address. You seem to have a problem with your settings. You might want to try using Network manager to set everything up for you, and see how that works. You can use the code below at command line to see the settings being used by Network manager.

#> nm-tool     ### to view cards configuration in KNetworkManager

If you wish to see your external IP address, go here and it will be displayed:

https://www.grc.com/x/ne.dll?bh0bkyd2

My network is so fast it’ll blister you, and my gateway and DNS are set to the same private IP address (192.168.1.X).

A quick update. I ran Ubuntu off a CD today to double check that those sites still worked - and they did not. When I used Ubuntu in the past, I also used klink to tether instead of the official Verizon app. When I couldn’t get klink to work under Suse, I paid Verizon to use their official support, which seems to be the problem, at least the way I have it configured. I may go back to trying to get klink to run under Suse, or at least re-install Ubuntu with klink in a dual boot to confirm. Again, thanks to all who have contributed.

Another update. Under Ubuntu, Drudge still works with klink tethering but not official Verizon tethering. So my problem has to be in whatever the difference is between klink’s settings and official Verizon settings. I know the DNS settings at a minimum were different. If I figure it out, I will post the solution.