Some issues with ATI 5xxx HD

Hi folks, I have some graphic problem, Using Asus ATI 5850HD with the latest driver from Index of /repositories/graphics/openSUSE_11.4. KDE composite working fine with good performance but in videos picture will tear for a little and in some games like Supertuxkarte textures is not shown correctly and GTK based applications like Opera have a poor performance, Please see screen shot.

ok, … I’ll bite and admit my ignorance. What driver did you get from that site? 

I don’t see any relevant driver there for an AMD Radeon 5850 HD. Please point out to me the driver (as I am always keen to learn new things).

Did you try the AMD Catalyst proprietary graphic driver ? And no it is not on that site.

Thanks for reply. Driver version is 8.812-110104a-111995C-ATI and yes I try ATI Catalyst from AMD website and 3D driver is disabled after reboot. Here’s my xorg.conf:

Section “ServerLayout”
Identifier “aticonfig Layout”
Screen 0 “aticonfig-Screen[0]-0” 0 0

Section “Module”
Load “GLcore”
Load “glx”
Load “dri”

Section “Monitor”
Identifier “aticonfig-Monitor[0]-0”
Option “VendorName” “ATI Proprietary Driver”
Option “ModelName” “Generic Autodetecting Monitor”
Option “DPMS” “true”

Section “Device”
Identifier “aticonfig-Device[0]-0”
Driver “fglrx”
VendorName “ATI Technologies Inc”
BoardName “ATI Radeon HD 5850”
Option “AccelMethod” “EXA”
Option “RenderAccel” “on”
Option “DMAForXv” “on”
Option “ScalerWidth” “2048”
BusID “PCI:1:0:0”
Option “DynamicClocks” “on”

Section “Screen”
Identifier “aticonfig-Screen[0]-0”
Device “aticonfig-Device[0]-0”
Monitor “aticonfig-Monitor[0]-0”
DefaultDepth 24
SubSection “Display”
Viewport 0 0
Depth 24

Section “DRI”
Mode 0666

I’m not knowledgeable enough in configuring X to comment on the quality of an xorg custom made for the fglrx Catalyst driver.

I do not use the repository method for installing graphic drivers, so nor can I comment whether the 8.812-110104a-111995C-ATI is the latest proprietary driver. Are you saying THAT driver was on the web site you quoted? I’m still stumped over your reference to that web site. I have no idea what it was supposed to mean to me, and if it was a ‘hint’ as to how I can help you, its 20,000 ft over my head as I can not fathom its relevance. Sorry.

Anyway, did you try running your openSUSE withOUT the /etc/X11/xorg.conf file ? ie backup it up somewhere, and then remove the file. And then reboot.

Theoretically, openSUSE does not need such a xorg.conf config file most of the time.

Also, I note there is a NEW AMD driver released today (Catalyst 11.6): ATI Catalyst™ Proprietary Display Driver but one would need to install the manual method until a repository version is available. And as noted I can not help with a repository version as I always use the manual method to install.

Install Catalyst from AMD have any special method or configuration?

They don’t have to. On my Dell Studio 1537 with a much more basic HD3450 using the proprietary catalyst driver I do not need an xorg.conf file for it to boot.

Although having stated that, if you want a custom xorg.conf , then one way to build such a file (and this may be what you used) is to backup your existing xorg.conf and then run when in run level 3:

aticonfig --initial

If my memory serves me correctly, that will create an xorg.conf for one’s AMD graphic device.

I also note that today the new Catalyst-11.6 GNU/Linux video driver was released by AMD.

Remove old driver and reboot then install ATI driver from AMD website but no 3D acceleration is available.

Did you check the /var/log/Xorg.0.log file ? … ?

How about opening the file with a text editor, and pasting its contents on SUSE Paste and posting here the website URL/address so some of our more graphic knowledgeable users can look at it and make an assessment. Simply saying no 3D acceleration after an ATI driver from AMD install does not provide much to go on. I can’t even tell from that if the AMD driver install was successful. Nor can I tell if your PC is Gnome or KDE (if posted its not repeated to be clear that I can easily notice)

My PC : Removed old driver and rebooted to run level 3 and installed AMD Catalyst 11.6 driver from AMD website. PC has AMD Radeon HD3450 running on 64-bit openSUSE-11.3 KDE-4.4.4. 3d acceleration works. Very nice. Check of /var/log/Xorg.0.log file confirmed ‘fglrx’ driver loaded.

Solved, Just set Catalyst A.I. back to standard and everything fixed.

Glad to read you sorted that, presumeably using the ATI Catalyst Control Center:](
[click on above image for larger view]

Out of curiousity, did the /var/log/Xorg.0.log file give you any hints as to what was happening wrt 3D, or did you simply stumble across the solution via trail and error ?

How about your tearing ? Did you fix that ? I presume you tried playing with these settings in the Catalyst Control Center (see pix):](
[click on above image for larger view]