Some issues switchig tp wolfi's plasma 5 repo

I was using Kde:Frameworks5 repo with plasma 5.5, I wanted to switch to wolfi’s plasma 5 repo but I have some hickups
what I did is I added wofi’s repo

zypper ar -f

did a dup to the oss and update repo to get my system back to official status, then did a dup to wolfi’s repo to get his plasma 5, this is my output

# zypper lr -d
#  | Alias                                  | Name                                                                | Enabled | GPG Check | Refresh | Priority | Type   | URI                                                                                                      | Service
 1 | KDE_Applications                       | KDE:Applications (openSUSE_Leap_42.1)                               | Yes     | (r ) Yes  | Yes     |   99     | rpm-md |                          |        
 2 | KDE_Extra                              | Additional packages maintained by the KDE team (openSUSE_Leap_42.1) | Yes     | (r ) Yes  | Yes     |   99     | rpm-md |                                 |        
 3 | KDE_Frameworks5                        | KDE Frameworks 5 development repository (openSUSE_Leap_42.1)        | Yes     | (r ) Yes  | Yes     |   99     | rpm-md |                           |        
 4 | KDE_KDE3                               | KDE 3.5.10 and associated software (openSUSE_Leap_42.1)             | Yes     | (r ) Yes  | No      |   99     | rpm-md |                                  |        
 5 | X11_LXQt                               | X11:LXQt (openSUSE_42.1)                                            | Yes     | (r ) Yes  | Yes     |   99     | rpm-md |                                       |        
 6 | X11_QtDesktop                          | QtDesktop (openSUSE_Leap_42.1)                                      | Yes     | (r ) Yes  | Yes     |   99     | rpm-md |                             |        
 7 |               | nVidia Graphics Drivers                                             | Yes     | (r ) Yes  | Yes     |   99     | rpm-md |                                                            |        
 8 | home_Alexx2000                         | Double Commander (openSUSE_13.2)                                    | Yes     | (r ) Yes  | Yes     |   99     | rpm-md |                                 |        
 9 | home_wolfi323_branches_KDE_Frameworks5 | Branch project for KDE:Frameworks5 (openSUSE_Leap_42.1)             | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | |        
10 | openSUSE-leap/42.1-0                   | openSUSE-leap/42.1-0                                                | Yes     | (r ) Yes  | Yes     |   95     | yast2  |                                            |        
11 | openSUSE_Leap_42.1_NonFree_Update      | Online updates for openSUSE Leap 42.1 NonFree (standard)            | Yes     | (r ) Yes  | Yes     |   15     | rpm-md |                                                   |        
12 | openSUSE_Leap_42.1_Update              | Online updates for openSUSE Leap:42.1 (standard)                    | Yes     | (r ) Yes  | Yes     |   15     | rpm-md |                                                       |        
13 |                  | Packman Repository                                                  | Yes     | (r ) Yes  | Yes     |   10     | rpm-md |                                       |        
14 | repo-debug                             | openSUSE-leap/42.1-Debug                                            | No      | ----      | Yes     |   99     | NONE   |                                      |        
15 | repo-non-oss                           | openSUSE-leap/42.1-Non-Oss                                          | Yes     | (r ) Yes  | Yes     |   99     | yast2  |                                        |        

 # zypper dup --from 9 --from 13 --from 3
Loading repository data...
Reading installed packages...
Computing distribution upgrade...
5 Problems:
Problem: nothing provides needed by libpoppler-qt4-4-0.39.0-170.1.x86_64
Problem: dolphin4-15.12.0-7.2.x86_64 requires kdebase4-libkonq = 15.12.0, but this requirement cannot be provided
Problem: akonadi-server-15.12.0-6.1.x86_64 requires libKF5AkonadiPrivate5 = 15.12.0, but this requirement cannot be provided
Problem: libkgeomap-15.12.0-6.2.x86_64 requires libKF5KGeoMap10_0_0 = 15.12.0, but this requirement cannot be provided
Problem: marble-kde-15.12.0-6.1.x86_64 requires marble = 15.12.0, but this requirement cannot be provided

Problem: nothing provides needed by libpoppler-qt4-4-0.39.0-170.1.x86_64
 Solution 1: Following actions will be done:
  keep obsolete kfilemetadata-4.14.3-3.3.x86_64
  keep obsolete libpoppler-qt4-4-0.24.4-5.2.x86_64
 Solution 2: Following actions will be done:
  deinstallation of kfilemetadata-4.14.3-3.3.x86_64
  deinstallation of libpoppler-qt4-4-0.24.4-5.2.x86_64
  deinstallation of qpdfview-0.4.15-3.3.x86_64
  deinstallation of okular-15.12.0-6.1.x86_64
  deinstallation of qpdfview-lang-0.4.15-3.3.noarch
 Solution 3: keep obsolete libpoppler-qt4-4-0.24.4-5.2.x86_64
 Solution 4: break libpoppler-qt4-4-0.39.0-170.1.x86_64 by ignoring some of its dependencies

Choose from above solutions by number or skip, retry or cancel [1/2/3/4/s/r/c] (c): 

the missing dependencies are from KDE:/Unstable:/Frameworks/
as I do have the stable KDE:/Frameworks5 do I need the unstable repo? or should I remove the conflicting packages?

No, you shouldn’t, unless you don’t need them.

But the main problem seems to be a conflict regarding poppler.
I will have a look.

Oh, and as I mentioned in another thread, remove dolphin4, it conflicts with my dolphin (which is the KDE4 version anyway). You should also remove kate4-part and konsole4-part if it’s not done automatically, again my kate and konsole packages do contain the KDE4 version.

And you don’t really need KDE:Applications, my repo contains most stuff, except for the KDE4 applications that are still included. But you get those as official updates for Leap anyway (in the update repo).

okular is a general conflict, some other packages (I know of calligra-extras-okular) you have installed are built against an older version and require that.
Not specific to Leap, and unrelated to my repo.
Those packages would need to be recompiled against the latest okular version.

I think the problem might be from X11:QtDesktop I was using qpdfview from their repo and they build it against Qt4 (they provide razorqt and that is a qt4 desktop) but I did a dup to the OSS repo and I should have gotten the official qpdview build with Qt5, I’ll remove those packages and then readd them and see what happens.

Well, I do provide a newer poppler, because the one in Leap 42.1 doesn’t include poppler-qt5 so kfilemetadata5 (used for file indexing and Dolphin’s metadata display) could not be built with PDF support. This has been fixed recently though and an update is on the way, so I should be able to remove it soon.

Still, both poppler versions should be co-installable (the libraries at least). Do you maybe have poppler-devel installed as well?
What happens if you try to install libpoppler58 alone? (this is reported as being unavailable, but it is in my repo, so there’s likely some conflict)

And I noticed that I forgot to add the KDE4 based libkipi to my repo, this might cause at least some problems. Fixed now, but it takes a while to rebuild everything.

You should also replace the “official” akonadi-server with my akonadi5-server.
Maybe I should add some Provides/Obsoletes so that would be replaced automatically…

From your output there seems to be a problem with libkgeomap too. I’ll have to look at this yet.

I did replace akonadi5-server but t still got the missing issue I didn’t add KDE:/Unstable:/Frameworks I just installed the shared object, I think one of your newer packages requires this so and it’s not available in KDE:/Frameworks5

Ok, I found the problem.

I forgot to enable publishing for poppler itself (i.e. libpoppler58), it was only enabled for poppler-qt4 and poppler-qt5 by mistake.
Sorry for that, should be fixed in some moments…

And thanks for reporting! lol!

Sigh. For some reason the package is still not in the repo, even though I did enable publishing over an hour ago (and the repo is shown as fully published in the OBS web interface).

I triggered a rebuild now and hope that helps.

Hm, even after the rebuild it didn’t show up in the repo…:’(
No idea what’s wrong there, seems to be a bug in OBS.

I’ll continue trying to fix/workaround that somehow tomorrow.

PS: it should be fixed now. I had a look at the raw metadata for my poppler package, and this contained an “enable” and a “disable” for publishing at the same time. The web interface showed it as “enabled”, but OBS itself apparently regarded it as “disabled”.
Should really be fixed now, after removing that stray line manually, the package is in the repo now… :slight_smile:

Good night.