Some games are not working

For example Ecksdee:
Traceback (most recent call last):
File “”, line 17, in <module>
File “/usr/share/games/ecksdee/data/scripts/”, line 49, in pathInit
File “/usr/share/games/ecksdee/data/scripts/”, line 53, in addPath
root, dirs, files = os.walk(os.path.normpath(path)).next()

Also Jammer the Gardener
Anonymous [text] Paste - tGTiiGbW -

Blood Frontier is working, but only after some tweaking, because by default it picked resolution the same as monitor, 1280x1024, then monitor was “out of range”. After manually editing init.cfg file, made it 640x480 resolution, then it started.

Hello algyzas,

Sad to hear that those games don’t work for you.:frowning:
I tried to recreate the bug with ecksdee. That didn’t work.
After some searching I found this irc-log.
It means that the paths to the CrystalSpace and CEL libraries are wrong.
Can you show me the file and tell me wich version of openSUSE you have.

I know jammer-the-gardener also uses CrystalSpace and CEL.
So maybe it’s the same problem?

And now to the “out of range” error. It can be that you set the resolution to high.
Or the refreshing rate is to high.

Best of luck!:wink:

Here you are


export CRYSTAL=/usr/share/games/ecksdee/cs
export CEL=/usr/share/games/ecksdee/cel
export PYTHONPATH=$CRYSTAL:$CEL:/usr/share/crystalspace-1.2/bindings/python:/usr/share/games/ecksdee/data/scripts
cd /usr/share/games/ecksdee

use -relight to avoid error messages: Couldn’t load cached lighting for X object(s). Use -relight to calculate …

python -relight

Opensuse is 11.2

Hello algyzas,

Thanks for the information. I updated my version of CrystalSpace(1.2.0 -> 1.4.0).
After that I had the same error message as you.
When I looked at your file I saw that the libraries are located in /usr/share/games/ecksdee/cs.
Looking in that directory I found four symlinks pointing at wrong directories.
They were pointing at the 1.2.0 version.

So open a filebrowser as root. Go to the directory “/usr/share/games/ecksdee/cs/”.
You’ll see 4 items(*.cfg, data, *.so, *.xml);
Right click on a item and change “/usr/share/crystalspace-1.2/” to “/usr/share/crystalspace-1.4/”.
Do the same with “/usr/share/games/ecksdee/cel/”.

This solved the current problem for me. But I received a new error message.
You can still try this. I’ll inform you when I have more information.

Good luck!:wink: