Some applications wont let me print text in landscape correctly


My setup:
openSUSE 11.4.
Acer Extensa 5635ZG
Epson Stylus Photo PX710W, connected with WiFi

I have just discovered that I can’t print text from libreoffice writer/calc if the layout is set to landscape. The letters seems to have been stretched and printed over each other. If I print the same document in kword/kspread everything is printed as it should be.

I have generated a pdf of the document and printed from okular/acroread, even then it’s not printed correctly. Although it looks ok in okular/acroread.

What else that can be seen is that when it’s wrongly printed the printout is printed in the opposite direction compared to when it’s printed correctly. I.e. the tail comes first on the paper so to say.

Any thoughts of this? Where should I begin to search for faults?


since both look ok on the screen, i think it must be a printer driver
problem…and, therefore, the first thing i would do is make sure you
have the correct driver installed…

is the system correctly identifying your printer?

[openSUSE 11.3 + KDE4.5.5 + Thunderbird3.1.8 via NNTP]
HACK Everything →

As the printer is on the(wireless) network I can’t say that the system has detected anything really. I have installed the drivers from Linux Driver | AVASYS CORPORATION and manually selected the correct model when adding the printer in cups:
Epson Stylus Photo PX710W - CUPS+Gutenprint v5.2.6.

Unfortunately I can’t remember if I ever printed anything in landscape when using openSUSE 11.3…


As LibreOffice does not appear to have any options to print in landscape in Calc, I don’t think it is possible anyway. It appears to print in landscape to PDF and Postscript from Writer quite happily.

AFAIK there are still some bugs in Okular relating to landscape printing. I have installed KPDF for the occasions when I need landscape printing and have had no problems with it.

But I can set the page layout to landscape, then it tries to print in landscape. The generated pdf looks ok, but not when printed.

How do you install kpdf to kde4?


Search for kdegraphics3-pdf in Download openSUSE 11.4

No luck with kpdf:
"A print error occurred. Error message received from system:

cupsdoprint -P ‘Epson’ -J ‘2011-04-28_1.pdf’ -H ‘/var/run/cups/cups.sock:631’ -U ‘therese’ -o ’ StpiShrinkOutput=Crop copies=1 orientation-requested=3’ ‘/tmp/kde-therese/’ : execution failed with message:
/bin/bash: cupsdoprint: kommandot finns inte "

Which means that cupsdoprint can’t be found. I can’t find it either.


How did you install kpdf? I have /opt/kde3/bin/cupsdoprint installed; this is the normal location for KDE3 files. It suggests that not all the KPDF dependencies were installed on your system.

I did as you suggested. Found this repo:
Index of /repositories/KDE:/KDE3/openSUSE_11.4

I did a reinstall and now it finds cupsdoprint. But the printout is bad anyway.

I created a pdf with the same text and in landscape from kword. This pdf is printed correctly, even with:
lpr -P Epson </path/to/pdf/file>



I have found the problem.

When I installed the printer drivers the ppd for the printer was not made visible to CUPS, so the correct driver could not be selected when adding the printer in CUPS. Only gutenprint version.

I have now copied the ppd for the printer to the CUPS ppd folder. Everyting seems to work now.


I am encountering the same problem. What driver did you end up using? Where did you get the file from?

Is this a bug in 11.4?

My problem was different; I had the “correct” driver, but the resolution was set incorrectly to 1200x600 (instead of 600x600). I modified this in the program (LibreOffice) that I was trying to print from and now it works. For some reason, this only affected landscape printing and not portrait.


I took the driver from avasys site. The solution that worked for me was to not choose the driver from the dropdown for model in Cups. Instead I looked it up where it is installed and put that in “Or Provide a PPD File:”.

Don’t know if it’s a bug in 11.4, haven’t had possibility to try in 11.3.