[SOLVED] Tokodon starts with blank window

I just wanted to post here if anyone else is having this issue. I wanted to checkout Mastodon with Tokodon, so I installed it using Discover.

When I launched the application, a window with nothing in it opened. I troubledshoot by running it from terminal. I found out it was missing ‘kirigami’ libraries. So I headed over to Yast Software and searched for kirigami and found Kirigami2 package was installed by there is also "kirigami’ package with was not installed. So I installed ‘kirigami’ and ‘kirigami-addons’. Then I tried Tokodon and it shows the content inside its window.

Hope this helps someone.

1 Like

Good you posted this, I can reproduce the problem on Tumbleweed:

$ sudo zypper in tokodon
$ tokodon
Loading any accounts from settings.
QQmlComponent: Component is not ready
file:///usr/lib64/qt5/qml/org/kde/kirigami.2/PageRow.qml:916: Error: Error while loading page: qrc:/content/ui/LoginPage.qml:10 module “org.kde.kirigamiaddons.labs.mobileform” is not installed

But after a successful “sudo zypper in kirigami kirigami-lang” I trigger exactly the same problem.

No problem for me, I am for now happy viewing Mastodon via Firefox.

If the solution is installing an extra package the better solution is to update the package dependencies so that next time zypper/rpm will itself that package is also needed.

1 Like