[Solved] Nvidia driver issue

I’m playing with openSUSE 11 KDE 4.1 beta 2, with latest kernel now, for a week or so and I like this distro very much; it does the job better than Kubuntu 8.04 imho …
YaST2 is a great package manager. Unfortunately I’m not able to install the x11-video-nvidiaG01 - nvidia GL drivers and kernel modules properly until now. I tried the one-click, zypper and YaST2 installs without any success. My GeForce 6200 (AGP) card doesn’t work, X-server isn’t detected. Sax2 aborts the job and I’m stuck in the terminal and the only way out is to uninstall the G01 stuff with YaST2 in console modus.
Is this a temporarily issue? I read about more people having trouble …
Any clues I didn’t see yet?

Try installing the drivers manually, follow the advice in this post by james.

  1. Make sure you have all the right build tools, to allow you to build a Kernel module. (Open Yast’s Software management, choose the patterns option and select Base Development, C/C++, and Kernel Development options).

  2. Download the latest NVIDIA Driver (NVIDIA-Linux-x86-173.14.05-pkg1.run) is the latest at the time of writing.


wget http://us.download.nvidia.com/XFree86/Linux-x86/173.14.05/NVIDIA-Linux-x86-173.14.05-pkg1.run

  1. Press Ctrl + Alt + F3 to switch to terminal running on run-level 3.

  2. Login as root.

  3. Stop any X servers

init 3

  1. At this point, press enter if there is no login prompt. Login once again as root.

  2. Now run the NVIDIA installer.

sh NVIDIA-Linux-x86-173.14.05-pkg1.run

  1. Follow the instructions, and everything should build

  2. Reboot, and see if you can enable desktop effects in Yast. If not, then as root check the /etc/X11/xorg.conf

Under devices make sure it looks something like:

Section “Device”
BoardName “GeForce 7600 GT”
BusID “1:0:0”
Driver “nvidia”
Identifier “Device[0]”
VendorName “NVidia”

Note it’s the driver part that is important, if yours says NV or nv, change it to nvidia. Everything else will be similar, albeit specific to your board.

Hope I’ve got everything there, any problems compiling let me know. Before this driver was out, I had to patch the old driver’s code for the kernel.

Oh one last thing, you can either re-boot to get graphics running or type:


init 5



at this point, startx will login to KDE as root user.

Hope this helps

Ok, I installed the 64-bit driver, desktop effect aren’t enabled, though xorg.config looks good

Section "Device"
  BoardName    "GeForce 6200 (0x0221)"
  Driver       "nvidia"
  Identifier   "Device[0]"
  Screen       0
  VendorName   "NVidia"

But this part puzzles me
Section “Extensions”

Option       "Composite" "off"

I’ll try that one with “on”
Tnx for the input so far!

How can I mark this thread as solved? :slight_smile:

Thread moved to Pre-Release/Beta

Just the way you did works fine. :slight_smile: