Solved: kf5-mediainfo context menu service for mediainfo-gui

I’ve used mediainfo for years and really liked when there was a right click context menu option for it in dolphin/konqueror, as was the case in the KDE 4 world. My switch to Plasma 5 brought an unfortunate end to that (the latter). However, I noticed a while back that there was a kf5-mediainfo package available. I installed that and … nothing … still no context menu entry in dolphin. Noticed an update to it on the weekend, rechecked on whether it was now working … still nothing.

This finally bugged me enough that I got motivated and devoted some time to look into it yesterday and discovered:


Then a google search revealed this thread: which provided the final pieces to the puzzle.

Note: I first installed the kde4-mediainfo package and logged out of and then back into Plasma, thinking the (kf5-mediainfo) mediainfo-gui.desktop link would suffice to result in an option in Dolphin > Settings > Configure Dolphin > Services . Wrong. (And, really, I’m not sure why it didn’t, but it lead to unnecessary folly as shall be told in a bit). So taking that pclinuxos thread into account, I renamed the (kf5-mediainfo) mediainfo-gui.desktop link and (just) copied the (kde4-mediainfo) mediainfo-gui.desktop file into the /usr/share/kservices5/ServiceMenus/ directory and logged out of and back into Plasma. Success! Only, because I had left a copy in kde4 directory (/usr/share/kde4/services/ServiceMenus/) and had simply renamed the link in the other directory, I now had two mediainfo enteries in the context menu. Why it (the linked copy) decided to work now and not (as I’d said) on the prior attempt, I’m not sure … correcting this duplication was simple enough, though a further nuisance to a problem that really should never existed in the first place if this had been done right to begin with! Grrr. >:(

Hopefully this may be of assistance to someone.