SOLVED: Kernel update in Tumbleweed killed VirtualBox

Hi I have Tumbleweed based on openSUSE 11.4 with KDE standard.

I just updated to the latest kernel in the factory Tumbleweed repo, straightforward.

I also have VirtualBox from Sun/Oracle download VirtualBox-4.0-4.0.4_70112_openSUSE114-1.x86_64

Vbox now won’t start, urging me to run “/etc/init.d/vboxdrv setup” which was expected and I did that. But it won’t work. I get this error response:

tumbleweed114:/home/john # /etc/init.d/vboxdrv setup
Stopping VirtualBox kernel modules                                                                                                                           
Uninstalling old VirtualBox DKMS kernel modules                                                                                                              
Trying to register the VirtualBox kernel modules using DKMS                                                                                                  
  (Failed, trying without DKMS)
Recompiling VirtualBox kernel modules                                                                                                             done
Starting VirtualBox kernel modules                                                                                                                failed
  (modprobe vboxnetflt failed. Please use 'dmesg' to find out why)

So I run dmesg and find this:

warning: `VirtualBox' uses 32-bit capabilities (legacy support in use)

and a bunch of lines like this

  521.089025] SFW2-INext-DROP-DEFLT IN=eth0 OUT= MAC=00:1a:a0:58:c8:d6:00:24:01:e2:8a:33:08:00 SRC= DST= LEN=48 TOS=0x00 PREC=0x00 TTL=101 ID=23839 DF PROTO=TCP SPT=59674 DPT=6881 WINDOW=8192 RES=0x00 SYN URGP=0 OPT (020405AC01010402) 

and these

  614.817908] vboxdrv: Found 2 processor cores.
  614.818961] vboxdrv: fAsync=0 offMin=0x276 offMax=0xa9e
  614.820297] vboxdrv: TSC mode is 'synchronous', kernel timer mode is 'normal'.
  614.820301] vboxdrv: Successfully loaded version 4.0.4 (interface 0x00160000).
  615.172385] vboxguest: exports duplicate symbol RTMemFreeEx (owned by vboxdrv)

Which tells me nothing (because I can’t understand it).

But I have independently wondered about this:
Is something conflicting in relation to virtualbox-guest-kmp-desktop which is also installed but it’s this vintage:

  • virtualbox-guest-kmp-desktop-4.0.4_k2.6.38.0_18-1.2.x86_64

whereas the kernel is now

  • kernel-desktop-

Solved: add the Tumbleweed Virtualization repository. Ref:HowTo: upgrade openSUSE 11.4 to Tumbleweed

I think that is a firewall entry that is not relevant.

Thats of interest.

Reading here: Portal:Tumbleweed - openSUSE I think issues such as this need to be reported to the mailing list.

Reference virtualbox-guest-kmp-desktop-4.0.4_k2.6.38.0_18-1.2.x86_64 - that would be my guess as to the likely cause. The kernel version does not match your kernel.

I don’t know where the src file for that package is kept, so I don’t know if it is possible to rebuild it. I looked here and did not see it: Index of /repositories/openSUSE:/Tumbleweed/standard/src

vboxnetflt is the bridged betwork - I always get this error no matter what, but Virtualbox runs fine otherwise - have you tried to run it?

I also un-installed virtualbox-guest-kmp when I upped my Kernel (running kernel:stable), seemed the appropriate thing to do as it appears to be kernel specific

there’s a thread in the VirtualBox forums on this suggesting installing the Packman dkms rpm, but that didn’t help me Starting VirtualBox kernel modules failed (modprobe vbox (View topic) •

Thanks for the replies. Both were very relevant. I got my virtual machines to boot but only by turning off virtual networking, particularly eth0, which of course made VBox for me still useless as I use it every day in my work.

So then your advices lead me to a Tumbleweed factory packager’s home repo (user Grieff, using rpm search at where I found a version of virtualbox-guest-kmp-desktop that matched my current kernel It’s not in the general Tumbleweed repo yet so I downloaded a copy, installed it.

And then the problem disappeared and my bridged networking came back.

Thanks again.

Thanks Zaitor – adding that repo fixes the problem