SOLVED (it appears) "Getting hostname to router" networkmanager knetworkmanager 11.3 laptop

I recently upgraded my HPDV7 laptop to 11.3 (Very smooth!).

I have been using knetworkmanager for a while as it seems to be a more friendly interface for adding and managing new wireless connections while on the road.

When at home, I sometimes use wired (eth0), sometime wireless (802.11n), sometimes both.

I have been frustrated since starting to use knetworkmanager (back at 11.0?) that a Hostname did not appear at my router (a Linksys310 running DD-WRT). My other linux boxes (1 SuSE, 1 Debian) run under ifup with static addressing, so I did not have a good frame of reference.
After reviewing several references on-line and numerous dead-end forum items on the topic, I have found this works:

((Replace ‘HPDV7-Linux’ with your host name)

Modify file /etc/dhclient.conf

#cjm adds based on search of various forums
send host-name "HPDV7-Linux";
supersede host-name "HPDV7-Linux";

Modify file /etc/NetworkManager/nm-system-settings.conf

#cjm add per discussion
hostname = HPDV7-Linux

As a test, I disabled wireless networking in KNetworkManager, removed the RJ11 cable, then went to the DD-WRT STATUS-LAN window and deleted the DHCP leases that had been established for both interfaces.
On replugging the RJ11, a new Lease appeared for the eth0 interface, with the hostname properly showing.
When wireless was re-enabled, a new Lease for the wireless link appeared, it shows with the desired hostname, and the eth0 interface goes to “*” as it’s hostname.
After disabling the wireless connection again, then cycling the RJ11 cable out then back in, the existing lease for eth0 once again had the desired hostname.
I am not sure if it is NetworkManager or DD-WRT that ensures only one instance of the hostname in the router table.

This seems to be rather low-level messing about; is there a better way to achieve this?

NetworkManager - ArchWiki

Opensuse 11.0 + NetworkManager + hostname

KNetworkManager - Gentoo Linux Wiki

In openSUSE 11.4 the bug is still there. For workaround, it seems that it suffices to add

send host-name “clientname”;

to the /etc/dhclient.conf file.

Vote for to get it fixed.

Thanks. I have just tested the workaround, and it does fine.

In my case, it is only cosmetic. I am not depending on the router knowing the hostname. But it makes the router logs a bit easier to follow if it does have the hostname.