[SOLVED]install suse linux dual boot on toshiba C660-13Q (bootmgr is missing problem)

I faced some problem installing opensuse 12.1 dual booted with windows 7 on this laptop, I solved the problems, and this is to share the solution and to say to developers that opensuse has this “strange” behaviour.

I restored windows 7 to factory using the 2 dvd I created before, the result was a three partitioned hard disk
/dev/sda1 ntfs SYSTEM
/dev/sda2 ntfs WINDOWS
/dev/sda3 ntfs data

I used Gparted in systemrescuecd to modify partitions in this way,
/dev/sda1 ntfs SYSTEM
/dev/sda2 ntfs WINDOWS
/dev/sda4 extended
/dev/sda5 ext3 SUSE
/dev/sda6 ext3 home
/dev/sda7 swap
/dev/sda8 ext3 dati
/dev/sda3 ntfs data

I rebooted and windows starts ok after a verification process,

I installed opensuse 12.1 and everything went well,
at reboot linux boots well.
at boot grub shows two windows entry, windows1 and windows2, both gives an error, the windows1 gives this:

rootnoverify (hd0,1)
chainloader +1

bootmgr is missing
ctrl+alt+del to restart

I discovered that grub fail to recognize that in this case windows boot from /dev/sda1 and not from /dev/sda2 or /dev/sda3,
so to solve the problem you have to boot in linux,
go to yast>system>bootloader, select windows1 entry, click on edit, on “other system” choose /dev/sda1, click ok and approve the install of grub,
or edit /boot/grub/menu.lst file changing this in windows1 section:

###Don’t change this comment - YaST2 identifier: Original name: windows 1###
title windows 1
rootnoverify (hd0,0)>>>>>>>>>>>>>>>>>>>>>>>>>>>> change this in (hd0,0)
chainloader +1

save and reboot, windows should boot now :slight_smile:

If You want to report something to developers You need to use bugzilla.

Best regards,