[SOLVED] Cannot login after update to Kde 4.6.1 on openSuSE 11.4

If someone, like me, updated the shipped kde 4.6 to 4.6.1. using the repo KDE46/11.4 only to find himself stuck at the login screen, try this:
From the “type of session” choose “Kde plasma workspace (failsafe session)” and try to login.
Once logged in, logout, then choose “Kde plasma workspace” type of session and login again.
This has solved the problem on three machine updated from that repo.
Hope this helps someone.

it most definitely helped me! Thanks for your suggestion… I was giving myself a headache trying to figure out what was wrong, as the error message(s) that I was getting weren’t really telling me much. Sometimes the answer to the problem is a simple one…

I had very similar issues at nearly the same timeframe today
Problems with kde 4.6.1 on new 11.4 install

Followed this suggestion - Solved here as well

Thanks for the post

On 03/16/2011 01:06 AM, cmcgrath5035 wrote:
>
> Followed this suggestion - Solved here as well

sure hope one (or all of you) logged a bug so that the problem can be
fixed…i mean, this work around should not be required, right?

here: http://en.opensuse.org/Submitting_Bug_Reports

and, reference this thread in the bug report:

http://forums.opensuse.org/showthread.php?t=455856

and, when you have a bug number post it here so those who find this
thread via search will be able to check on the bug’s progress…and
add any new info that might help the devs solve the problem (like
maybe your hardware, graphics chip, etc etc etc which might be different)


DenverD
CAVEAT: http://is.gd/bpoMD
[NNTP posted w/openSUSE 11.3, KDE4.5.5, Thunderbird3.1.8, nVidia
173.14.28 3D, Athlon 64 3000+]
“It is far easier to read, understand and follow the instructions than
to undo the problems caused by not.” DD 23 Jan 11

Going to fill a bugreport.

I experienced this problem after updating to 4.6.1 also. The method for logging in described here worked for me, but choosing the default option from the sessions menu still won’t work.

Solved the problem here - thanks :slight_smile:

This issue is covered in https://bugzilla.novell.com/show_bug.cgi?id=681114.

The default login will work again if one edits /etc/sysconfig/windowmanager.

On 03/25/2011 02:36 AM, pilotgi wrote:
>
> This issue is covered in
> https://bugzilla.novell.com/show_bug.cgi?id=681114.

THANKS for posting that!!
all with this bug should add any info which might help the devs find
and kill the bug!


DenverD
CAVEAT: http://is.gd/bpoMD
[NNTP posted w/openSUSE 11.3, KDE4.5.5, Thunderbird3.1.8, nVidia
173.14.28 3D, Athlon 64 3000+]
“It is far easier to read, understand and follow the instructions than
to undo the problems caused by not.” DD 23 Jan 11

I accidently found that “rechoosing” in the kdm login manager Session Type -> KDE is enough to login. Like here: openSUSE starter: EXPERIMENTAL AREA - for experts only](openSUSE starter: EXPERIMENTAL AREA - for experts only)