Solutions to Intel video problems?

What is it with Intel onboard graphics and recent Linux distros? I have an elderly laptop with Intel i830 video which was working perfectly well dual-booting XP and Ubuntu 8.04 until I decided to get rid of XP and take the opportunity for a fresh install of Ubuntu 9.04. It worked, but no 3D acceleration and all kinds of problems with attaching a second monitor, plus strange visual artefacts.So I decided to give OpenSUSE 11.1 a try - it is after all my main desktop distro - and it fared even worse, the installation ending at the final stage with an endless loop of screen garbage. Managed to boot into failsafe but despite all my best efforts with Sax2 and hand-crafted xorg.conf, no luck beyond an off-centre 800x600 resolution.
Will just have to go back to Ubuntu Hardy I suppose…

Do Ubuntu follow the same philosophy as other distributions in terms of the xorg.conf file content? If they do, then you probably could take the content from the Ubuntu Hardy xorg.conf and apply it to openSUSE’s xorg.conf file (assuming of course, that that same graphic driver is being used).

I think the driver is the problem, not xorg.conf. If the driver had remained unchanged, the problems would hardly have arisen.
It’s just odd that the two most popular Linux distros didn’t spot the issues with one of the most popular onboard graphics chipsets (by a company with a reputation for being Linux-friendly) before releasing recent versions.

If you used to use the i810 as far as I can see this is still available as an option. Perhaps try reverting to that driver over the intel one.

Not quite sure what you mean. How would I do that?

I can’t give specific advise as I don’t use intel…

But if you run modprobe -l you should notice the old i810 module. As for how I guess either swapping out intel and replacing it with i810 in xorg.conf or using sax2 to reconfigure guessing 0=i810.

i810 is Intel. I’ve given up on OpenSUSE and Ubuntu 9.04 for that laptop, clearly neither works with the Intel chip (though Ubuntu does a lot better than SUSE). Have reverted to Ubuntu Hardy, the alternative was XP but that would be too much of a relapse…

Some days I don’t why I bother replying to people. When you try to help, because they are stuck, they suddenly then know better.

Seeming as you need pretty pictures…

So seeming as you know best good luck…

No need to be so grumpy. A forum doesn’t work by telepathy, it’s only after your last post that it’s clear what you were suggesting. But I needed the laptop working, so I reverted to the distro (and version) known to have no issues. Not sure what that has to do with needing pretty pictures…


Intel drivers are a big problem today. I have the same problem here. I have
tried both openSUSE 11.0 and 11.1 in my laptop that has a new hardware
configuration with a Intel GM 965 graphics adapter. My video worked just
wonderful in openSUSE 11.0, but unfortunately, the wireless and some functions
of the keyboard did not work. With openSUSE 11.1, almost every thing works,
but the video is just a mess. The problems with 11.1 I have noted until today are:
I cannot play Assualt Cube, cannot use Real Player when XVideo is enabled
(disabling XVideo I get I really bad video in full screen), MPlyer works fine
but the screen mess is fast movie scenes, and I could never make suspend
(for both RAM and disk) work because the graphics lock up when trying suspend.

Searching on Google, you can find many people using many different distributions
of Linux that have thousand of bugs using Intel graphics cards.
The good news are that (I want believe) new drivers for Intel video cards
were released in April 15, and are believed to fix most of these bugs
(Intel Linux Graphics) . I think we have to
wait for these drivers be available in Xorg. I hope this happens soon.
Until there I will be disappointed with my graphics card. I wish I had bought
a laptop with a graphics card that just works with Linux.

Well man, we need good luck.:shame:

Depends on what you mean by “just works with Linux”. On my desktop, I have an NVIDIA which is fine in every respect except NVIDIA doesn’t support RandR, so I can’t have dual monitors with one rotated and 3D acceleration at the same time. It’s one or the other…