Solution to black screen problem in opensuse11.2


Yesterday I had to re-install openSUSE11.2 but I kept having either black screen or mouse cursor freeze. Using sax2 to change video driver didn’t work whether “ati”, “radeon” or “vesa” was selected. I finally came across a solution:

  1. Log in at run level 3 with acpi=off, no apic,F3=vesa, then become root

  2. YAST -> Miscellaneous -> Live Installer, etc.

  3. Reboot

  4. If black screen, force a reboot and repeat step1

  5. Autoconfig restart? Yes

  6. When installation is finished, reboot

  7. Boot option: 3 acpi=off noapic F3(vesa)

  8. Login as normal user then become root

  9. #YAST > Online Update
    10> #YAST > Edit Bootloader

  10. Edit Grub menu: Add the following to the end of the kernel line (under heading: kernel options…):

vga=792 acpi=off noapic

Note that vga=792 is from a LILO config file example, which has the side note:“vga=792 #you need to do this so it boots up in a sane state”. I came across this from “Framebuffer HOWTO: Using framebuffer devices on Intel platforms”

Your Grub menu may also show vga=0x317 but this is because you might have selected 1024x768 screen resolution;it has nothing to do with vga=792. Vga=792 is what essentially solves the black screen problem.

I hope this is helpful.


What a journey :open_mouth: – glad it’s working :slight_smile:

Interesting … I note for the Milestone-4 pre-release version of openSUSE-11.3 that our old Fujitsu-Siemens laptop will not boot the liveCD, even in safe settings (tried all F4 compbinations) nor with vesa selected. I documented that here: openSUSE Forums - View Single Post - 11.3 Milestone 4 - Results and raised a bug report here:

Tonight when I get home, I’ll try the boot code:

vga=792 acpi=off noapic

11.1 runs fine on this old PC. 11.2 had some problems (and hence was not installed). 11.3 does not look good … but the jury is still out there for 11.3 :slight_smile:

Hello oldcpu,

Let me know how this works out for you.

Hello everyone,

Today upon starting openSUSE at runlevel 5 (default kernel) with vga=792 acpi=off noapic, I immediately got a blank screen. The solution I found is to edit /boot/grub/menu/lst of the default kernel boot line by adding “nomodeset”. Thus:

vga=792 acpi=off noapic **nomodeset**

Let me know if this works for you.

It turns out, that did not work. The laptop would not boot 11.3 M4.

Interesting … since I am testing from a liveCD, I’ll have to try that in the liveCD options boot line next time I can access that laptop PC that did not work for me (as posted above).

oldcpu said:

Interesting … since I am testing from a liveCD, I’ll have to try that in the liveCD options boot line next time I can access that laptop PC that did not work for me (as posted above)

Did you try “nomodeset” in the live CD options boot line when you ran 11.3 M5 on that old laptop? And if so, did it work for you?I am referring to the recent post you made in the Beta/pre-release sub-forum today.

As for me, today when I turned on my old Celeron M, Radeon video-equipped laptop to run 11.2, I got a blank screen. Booting into debug kernel, screen text suggests I should run with “pnpbios=off” because “pnpbios caused a fatal error”, etc. I then added “pnpbios=off” into the default kernel boot line, rebooted as usual and no problem. I then experimented with taking “pnpbios=off” out before rebooting. Default kernel again booted fine. So I don’t know what really caused the black screen today, or rather blank screen with a momentary blinking hyphen in the top left corner. It appears that the current kernel does not work well with ATI Radeon Xpress 200M video chipset driver. Note that I have no “pnpbios” error message when booting into Fedora Core 11 or Ubuntu 10.04 on this same laptop.[QUOTE][/QUOTE]

I have not yet tried this. My wife keeps this laptop where she works, and because she works shiftwork, we share different hours away from the office. Add to that the complexity that we do not own a car but rather she gets around by bicycle and I walk everywhere … (the tram bus does not go in our direction to the office). We both have other things we carry when going to/from work, so carrying this laptop in addition is not something she relishes. So its not easy for me to get access to this laptop. My next opportunity to do so may only around the time of M6 or M7.

The ATI Radeon Xpress 200M give a lot of 11.2 users heartburn (from what I recall). Is history about to repeat itself?