Solution: "Networking disabled" / "Netwerkverwaltung deaktiviert"

Most people suffer from problems with Networkmanager after a crash or after not being able to return from sleep/hybernate mode.

Neither reinstalling Networkmanager nor changing to ifup and then switching back to networkmanager solves this problem, because it is located in a config file which is not being overwriten during reinstall or configuration by yast.

So how do we solve this? Open a console:

Get superuser-rights:


Now open this file with an editor such as vi:

vi /var/lib/NetworkManager/NetworkManager.state

You should see a line such as:


Change this to:


and save the document.

Now if your current networkstate in yast is ifup, simply switch to Networkmanager. The yast configuration for NetworkManager should now work without problems.

If your current state is NetworkManager you have to restart your network:

rcnetwork restart

If you don’t have any icon in the Taskbar yet, you must also start knetworkmanager:


Hope this helps! Very annoying problem. I whish Yast would set the status in NetworkManager.state by itself.

(Making this sticky, could avoid further question-flaming :wink: )

Greetz Mario


Hope this helps! Very annoying problem. I whish Yast would set the status in NetworkManager.state by itself.

I understand that you think that is either a bug or a whish for YaST.
Then please go to openSUSE:Submitting bug reports - openSUSE and/or to in addition to your thread here.

Wow - thanks… This solution solved my problem I had with networkmanager today…

When I put my laptop to sleep (i.e. Suspend to RAM) - it somehow didn’t go into sleep properly and I had to power off my laptop manually… Next time after reboot I got the exact same issue with networkmanager as you’ve mentioned…

WORKS FOR ME. You’ve nailed the problem.

This file should be reset after each reboot.

I have the same problem when trying to connect to wifi LAN. However when I follow the suggestions listed above, NetworkManager still fails to connect and resets NetworkManager.state, line 4, to WirelessEnabled: false. D-Bus is enabled.

An icon appears in the tray but the tag says “NetworkManager disabled”.

I am going to find a cable and reinstall NWM. Maybe that will help.

I believe it could be related to suspend or sleep mode.

I have a similar issue when suspending and resuming with my broadcom BCM 43225. In my case it seems to boil down to a problem with knetworkmanager. Briefly connecting to a wired network restores wireless access.
The solution without resorting to a cable is to kill and restart knetworkmanager

killall knetworkmanager

I can add some info to my previous post.

There certainly appears to be a problem with “suspend to disk” and NetworkManager but in my case it is fixed. The computer concerned is a Dell laptop and it has no physical wifi switch. However a look at demesg revealed the “kill switch is on” and it must be off for wireless to work. The control is Fn-F2 which toggles the virtual kill-swich state. After 15 minutes of work by my Linux guru (my son), everything was working again.

I also take great care not to suspend to disk.

Hope this helps someone because I struggled for days . . . . . .

Another issue with kNetworkmanager:
OpenSuSE 11.3, knetworkmanager, and I use a few different wireless connections (one at home, one at work, for example). After switching on the laptop, knetworkmanager is disabled for at least 10 minutes. . .and only then finds the proper network connection. Is it possible to make it faster?

Yes. I find the network manager plasmoid to be much faster. Try to install it and it will uninstall knetwrok manager (don’t worry about this in case of problems the reverse procedure is to install knetwrokmanager and it will uninstall the plasmoid). Your profiles will be retained of course. After the installation make sure that You right click on system tray and check the box to show the network manager plasmoid. No other actions should be necessary but just in case You could try network service restart :

sudo /etc/init.d/network restart

Best regards,

I found the change between wifi and 3G modem can be triggered if I suspend to RAM (sleep) and “wake up” the machine again. This also solves the other temporary problems mentioned above.

Thanks, Greg, I’ve changed know to the network manager plasmoid and it works better. I installed it tru yast and then I had to put it onto the panel after reboot. Thanks again!
A. :slight_smile:

Thanks for reporting back. I’m glad You like it better.

Best regards,

Well, I got home yesterday and then I came today back to work, and. . .it is not as fast as I experienced yesterday. :expressionless: But, anyway, it works better than knetworkmanager.

Since I read your talk about the plasmoid version I have been trying to install it. Where can I find instructions? I serached the forums but they only lead back here.

Running this from terminal should do the trick :

sudo zypper in plasmoid-networkmanagement

After that be sure to modify system tray settings so that it is shown. You do this by right clicking on the system tray :slight_smile: I’m sure You will find it.

Other useful reference :

Best regards,

Thanks Greg. I checked out the above thread and used Knurpht’s approach. I didn’t need the terminal. Once I searched in Yast for “networkmanagement” it was dead easy. The plasmoid version is working fine with wifi. I’ll try my 3G modem later.

Thanks for the feedback. Installing with YAST is a great approach as well. Use whatever works and what You feel more comfortable with :slight_smile:

Best regards,

Although the plasmoid version of NetworkManager is working fine, it reports:
– 2 identical connections to the same wifi router
– 2 identical messages "No such interface 'org.kde.networkmanageme… [remainder hidden]
I used top to check for multiple versions but none visible. I have rebooted but no change.
Just curious.

Could You provide a screen shot ?

Which KDE version are You using ?

Best regards,


SUSE 11.3 32-bit, KDE 4.4.4 release 3