Solution/How To For intel 3945 a/b/g wireless conn. issues

I posted this solution in the wifi forum; however, I think more people will find it helpful here.

I have noticed that alot of people have been commenting that their wifi has been running extremely slow with the latest version of opensuse (11). It appears that the default driver for the intel 3945 a/b/g card iwlwifi that is installed by default is not supported in kernels 2.6.24 and up. In my case, I am running, and I assume this is the case for many of you out there as well. You will need to install the compat-wireless drivers instead.

In order to determine your kernel version, run the following command as root in the terminal:

uname -a

If you are running above 2.6.24, this is what I did to get my connection working again:

  1. download the compat-wireless and and extract the files.

  2. before compiling, you need to ensure that you have the following packages installed on your system

kernel source
kernel headers

  1. after you have installed the above packages, you can go ahead and run the following commands as root within the directory you extracted the source to:

#compile the drivers


# install the drivers 

make install

#load the drivers/unload the old drivers from the system

make load

It is important that you do not uninstall the old drivers before the installing the new wireless drivers, as doing so may cause the new drivers not to be loaded correctly.

I hope this helps people out.


Omg… thanks for the tips ! :slight_smile:

mine just worked straight away on suse 11 which is really weird if it’s not for you guys. 10.3 was more of a pain, using the ipw3945 drivers, knetworkmanager refused to connect, so used wifi-radar instead.

I have seen several posts regarding this issue on the forums. as I mentioned above, intel says that the iwl drivers that are shipping with the kernel released with opensuse 11 will not work. It seems odd they are working for you.

Where can I find the working ones then? compat-wireless didn’t work for me. Intel 3945

The link is not working…could you please fix it?
THanks =)

sorry, mate. The tarball changes with the date.

Index of /download/compat-wireless-2.6/

My D820 (iwl3945) was working right out of the box with 11.0…

Connecting to AP with WPA

I tried this because my wireless was really buggy and now it doesn’t work at all! I’m dual-booting Vista with opensuse and under vista the wireless is just fine. Opensuse would randomly kick me off and also only work half the time. So I followed all the steps and now my wireless just flat out doesn’t even work. It can’t find my network even when I’m right in front of the router.
I check online all over the place for answers and I even disabled the power management under vista because that seemed to give some problems. Still nothing. I have no idea how to even go about this, any suggestions?

I would love to help you out with this, however, this is not the section to be asking questions (if you do, a moderator will likely move this thread). I would suggest opening up a new thread in the wireless section under the hardware forum. we can certainly help you out there!