Solution for .rmvb files not playing well on Kaffeine

Hi all.

Well, no exactly a help question, but after a forum search I only found one similar thread, but seemingly the issue was not totally solved. I just would like to suggest a solution (well, most likely a workaround) for .rmvb Real Player movies which don’t work well on Kaffeine, without need to install other players or applications.

I first saw many people had similar problems as me: Real Player movies just played sound but not video, or viceversa. I first tried installing w32 codecs, but this seems to be the good solution for 32 bit users, I use 11.3 x64 and didn’t work for me. After some Google search I came to this page:
Index of /pool/non-free/w/w64codecs/

Seems to be a Medibuntu repository, and I looked for a .tar file, since I was looking for a “w64” version of the codecs. I downloaded the latest .tar.gz file found on the page, the 20071007 one and uncompressed it. It has some codec files and a Readme which tells where to put the files. After that done, without rebooting Suse, I tried again to play the movie, and Kaffeine finally played it well, although now it pops a message saying Kaffeine closed unproperly whenever I close it after having played a .rmvb movie. I think that can be solved by updating Kaffeine, but haven’t tried that yet.

Hope this helps. Thanks.

I use smplayer and never have trouble. VLC will do it to of course.
Are you using kaffeine from Packman?

VLC played the movie very laggy for me, so I don’t consider it a solution. I use the Kaffeine by default included in openSUSE, I don’t remember if it’s from Packman… don’t need to install anything else, and that’s the point I like.

Make sure it is form Packman
rpm -qi kaffeine

Use the radio switch to toggle if necessary: like this principle
ImageBam - Fast, Free Image Hosting and Photo Sharing

I took a look in the exact same window and same tabs and options as the k3b example. Details for Kaffeine selected radio options in the Versions tab read:
0.9+1.0pre3-6.2-x86_64 from vendor openSUSE (installed)
0.9+1.0pre3-6.2-x86_64 from openSUSE-11.3 11.3-1.82 with priority 99 and vendor openSUSE

So guess they’re not from Packman. Neither Kaffeine is highlighted in blue (no need for update).
Although there are some highlighted in blue which are named libavcodec52, libavformat52 and libavutil50.

So is Packman version of Kaffeine better than openSUSE default one? Or what is it for? And what are libavcodec52, libavformat52 and libavutil50? Some Kaffeine codecs? Thanks.

Have you done this?

OK, updated Kaffeine to Packman version 1.1.1. Still the same issue whenever I play a .rmvb movie and then close Kaffeine. This is the only info I have about the error:
Application: Kaffeine (kaffeine-xbu) PID: 6334 Signal: 11 (Segmentation fault).
Can this be a KDE error or bug? Should I just report it?

If you are sure you ave multi-media set up correctly and for example all other video plays normally. Then sure, it’s worth a bug report, at kde

Maybe too at Packman

Well, I haven’t get into multimedia config, so everything should be default. And other non-rmvb videos play well. Now I want to report the bug, because another problem happens when I “forward” or “rewind” the rmvb movie, i.e. when I tweak in the search bar (the time bar, if it’s simpler). Sound and video get out of sync.

I have already read here: Development/Tutorials/Debugging/How to create useful crash reports - KDE TechBase, and even installed kaffeine-debuginfo from Yast, but I can’t get the Backtrace thing from KDE Crash Dialog. I don’t even know how to get that. Do I really need to install GNU Debugger (GDB) or Valgrind?
Perhaps I should remark I’m on openSUSE 11.3 x64 and needed to do the workaround described in my first post in this thread here in order to make .rmvb movies play on Kaffeine without installing anything else…

Help, please. Thanks.

The thing is kaffeine is a open source application FAQ | Kaffeine - KDE Media Player
Real Media files are not, so playing them is by means of extra packages (w32codec-all)
So a bug report might be pointless.

If you have all the necessary multi-media packages and it still doesn’t work, thinking about it, I’m still not sure it’s a kaffeine issue, but it is perhaps one you could report to packman, because it’s the packman version of kaffeine you will be using.

Well, according to my first message in the thread, I didn’t make exactly a package installation. I copied some files (codec files, I presume) in the /usr/local/lib/codecs directory, and those files came from a third-party source. If it still doesn’t matter, how do I report to Packman?

Is the general contact