[Solution] Creative Audigy 1/2 + 11.0 + KDE/GNOME + ALSA

I’ve gotten a lot of questions at #suse as of late due to “No sound with Audigy” cards and openSUSE 11.0 and the culprit partially for these issues has been the new PulseAudio / ALSA system that defaults to outputting to Optical / SPDIF Passthrough instead of Analog which a lot of folks use.

To fix THIS issue with GNOME + Audigy 1/2 + PulseAudio, please take the guided tour:

First click on Computer and More Application, then type Volume into the Filter and choose Volume Control under System, presented on the bottom right in this picture:

If you have more than one device (like I do) choose Audigy from the File / Change Device:

Finally, if you are not using SPDIF / Optical Passthrough, uncheck this:


First right click on the Mixer button on the bottom right corner of the KDE3 taskbar, if you do not have a mixer button there, you can press ALT+F2 and run kmix.

If you have more than one audio device in your computer, choose Audigy from the dropdown menu:

Finally navigate to Switches and click on Audigy Analog / Digital Out


Left click on the Mixer icon on your taskbar, like this and if you have more than one audio device, choose Audigy:

Digital Output button is not normally shown, so navigate to Settings / Configure Channels.

Scroll down until you find Audigy Analog/Digital Output Jack:

The button will now appear in the mixer and you can use it to toggle / enable the SPDIF / Digital/Analog output:

Have a lot of fun.

< Shameless self bump in case people don’t know how to use search :stuck_out_tongue: >

Yes I’ll have to upgrade this and perhaps add SE+A4/XFi guide+issues to it someday.

Hi , i have the same problem with creative audigy soundcard .
I use kde, but in Kmix , output i don’t have that field to chose the sound card and nowere is displayed the audigy card. Seem like it’s not even recognised by the system.
What can i do in this case?

Please, only one thread on a problem. Please, users, reply to user pindordan’s post on the linked post below:
Problem installing creative audigy soundcard - openSUSE Forums

I finally solved sound problem :
even that still adudigy was no where listed in the mixers
analog / digital outputs , i just had to apply (by trying dif. vol. panels) volume to ‘Analog front’ vol panel and sound was on. The problem was simple as that… lol!

Alrighty, I’ve got a problem too.

I’ve got a SB Audigy SE with Logitech X-530 5.1 Surround Sound speakers. I only get sound out of the front left speaker and the subwoofer. I did the troubleshooting thing and got the latest ALSA stuff and nothing’s changed. I went through this thread but it doesn’t seem to help. In my KMix mixer I don’t have the option to select my card and I don’t have a configure channels option in my menu.

I’m using KDE 3.5.9 (or is that 3.9.5).

I have noticed something odd though. When I go to the sound setup in YaST it says I have a SB Audigy LS but I have an SB Audigy SE.

The SE isn’t in the list of cards to add. Could this be the problem?

These may be helpful:



tsalsa.txt - nopaste.com (beta)

Could I be missing a codec?

Actually, I should add one more thing.

I just installed my openSUSE 11.0 yesterday and I keep getting this little red triangle saying I have automitc updates. So I click on it and it says:

New software for your system is available

38 security updates are available

[x] install 42 recommended updates additionally
] Don’t install updates that require a restart

[Details] Install] [x Close]

I check the first box and hit install. It asks for the root pass and I give it and then two seconds later it says I need updates again; and gives me the exact same window. Over and over and over.

Should I worry about this before messing more with the audio?

First, it is really best you start a new thread when you have a problem like this. This thread is a helpful guide to mixer settings, and your problem is different, and it clouds the good advice in the thread.

Exactly, which means this thread is not related to your problems, and by posting on this thread, you are making it difficult for others who have problems related to this thread.

I believe that configure channels is typically for KDE4 users using pulse audio.

Typically one can tell their KDE version by typing “kded -v”. Since there is no 3.9.5 version of KDE, and since 3.5.9 comes with openSUSE-11.0, then I assume you are using 3.5.9.

Are you trying to setup 5.1 surround sound? 2.1 sound ?

Since your sound works, but you are simply trying to sort the sound going to various speakers, I recommend you get real time help off of IRC from a chat channel where a number of sound guru’s hang out. Install xchat, and then run xchat and go to “freenode”, and then to IRC channel #alsa. Ask there for guidance (you may need to create a custom .asoundrc file).

You may need to ask for help a number of different times on that channel, as the users who help are located all around the world, and it may take time before you log on at the same time as one of the sound guru’s who provide volunteer help.

I sorry I`m in wrong place

Necroposting ftw!

Note that this thread is “slightly” out of date.:’(

I think this is one of my problems because in windows I have to check a box in my sound properties that says digital output only, but i see in this picture that where it says Audigy [sb0090] mine says [unknown] how can i fix this? I have configured my card and plenty more.