Software Updates shows network disconnected

The Software Updates icon under the Status and Notifications shows the message “Network is offline” even though I am connected through the WiFi. It does not give me any options to check for updates in this case.

This topic comes up from time to time (for those that actually use the desktop software updater). I assume that you’re using NetworkManager to manage your network connection. This behaviour can happen when the wifi connection is started after the updater attempts to check for updates. One workaround is to modify the connection so that behaves as a ‘system connection’, starting at boot. You can do that by selecting ‘All users may connect to this network’ in the connection editor.

When using the Graphical method, I much prefer to go into Yast=>Online Update to update my machines.

I have not been using that method for awhile, now, though, because I like using the command line method for updating.

I do not know why, perhaps a sense of power? lol!

If you want to try that, in Leap you open a terminal window, type:

su -

and enter the root password when prompted.
Then, you are logged in as root, so issue:

zypper up

and watch the fun!

***PLEASE NOTE: ** For anyone using Tumbleweed, or for anyone testing the exciting 15.0 Beta, you must instead initiate a Distribution Upgrade:

zypper dup

and in that case, make certain you only have the main repos and Packman enabled, or you might wind up making your system argue endlessly with itself while you sit there whimpering!:’(

Yes, I think most seasoned users prefer using zypper and the flexibility that it offers. :slight_smile:

Yes, I’ve also noticed this with Leap 42.3, KDE Plasma 5 and Network Manager on a WiFi Laptop.

  • BTW, it’s an "Only to confuse the user
    " message – the WiFi connection is up and running …

The only sensible way out that I’ve found is, either to remove/insert the battery charger cable to force a search for patches and/or updates or, from a user CLI session in a user’s Terminal Window, call “pkcon refresh”.
[HR][/HR]BTW, my Laptops only have the Ethernet port configured as being a “system connection” …

This worked like a charm!
Just one further question though, when I tried this through the command line, it listed a bunch of packages with the message as follows:

The following 23 package updates will NOT be installed 

Is this something that is expected?

Yes. Those are often updates to packages in another repo, most likely those are the package versions in openSUSE that you have switched to Packman.

They will not overwrite the Packman versions, unless you intentionally switch them back from Packman.

Others that will not be installed are locked or tabooed packages.