Software Updates shows install error

Today I had some problems with software updates (235 updates from toolbar), which just indicated install error. How can I find out, where is the problem? In repositories I had only openSuseTumbleweed sys + non.
(I also tried to use Yast software update, but it only takes me to Software Management, There I run the update of all installed packages, which, I hope, it’s working).

I do not know what you mean by “from toolbar”, but the correct way to update Tumbleweed is (as root)

zypper dup --no-allow-vendor-change

I meant the KDE Software Updates in Task Manager . Normally it works fine. I got my updates with Yast. The question is: If I get error messages in Software Updates, how can I find out what’s the problem?

br Simo

That thing works whith Packagemanager and tries to do the equivaent of

zypper up

As said, that is NOT the way to keep Tumbleweed up-to-date. IMHO that applet is useless on a Tumbleweed installation.

My advice (but you may think different of course) is to do the statement I offered above (and I did not invent it, itis copied from many, many other threads here in the forums). And when you get errors with the zypper up, you can come back here so we can start serious to try to solve that.

After that, when you still want to see what that applet does, check it if the error is still there.

OK. Thanks Henk. :slight_smile:


yes… at best its annoying and at worst misleading. IMHO It should be disabled on all TW installs - maybe a factory suggestion?
[it appears (so far) that it can be disabled from the radio button on ‘system tray settings’ (right click on tray)]

I too had issues in Tumbleweed with this and I now typically run updates in the command line only. Seems that the applet can be a little fickle so I just don’t use it so often. I think it’d be nice if were more reliable but I seem to have better reliability with it in Leap, so long as you don’t have too many funny repos.

Tho I haven’t tested this suposition it seems like there are only issues with the applet when there is some kind of huge jump in version. For instance, most of the time you will see with

sudo zypper up

a list of packages upgraded, deleted and added. If there are packages that are getting deleted or added, the applet will not let you proceed. I could be wrong but that seems to be the case with my limited expeirence.


I can not help much with what the applet can and can’t because I do not use it (on Leap that is, on TW it has no use).

On installation I adapt a few tnings on the offered packages installation and two of those are: do not install the applet and do not install Packagekit.

Without the applet, how do you get notifications of pending updates in Tumbleweed? I use your suggested update command, but I only know when to execute the update command when I see the applet notification that an update is ready. Thank you for your time!

Truthfully, just run updates once a week and you will probably be fine. You could set up a CRON job but I like to watch the updates happen.

I run about once a week, maybe twice, myself and do a reboot following the updates (if required) or logout / login. Once a week feels like a good interval to me. Something to do either on a Friday before the weekend or first thing Monday. I prefer a Friday at the end of the workday and do a shut down. I don’t tend to do much on the computer Friday nights.

For what it’s worth, I did get notification with the update applet in KDE and wanted to see if the updates would go thru. All 98 of them did without any issue. I do have several additional repositories too, 18 in total. So, I still wouldn’t recommend the applet but it does seem to work part-time.


I installed tumbleweed on a clean computer from a snapshot but it still dragged packagekit in. If packagekit is not advisable for tumbleweed, why pack it in on a clean install? Even if I remove it, it still gets pulled in with zypper dup. Maybe it could be removed from the tumbleweed repositories altogether? This to avoid confusion.

twice you have recommended zypper up. This is NOT the way to update tumbleweed nor is the applet. As mentioned previously in the thread, the correct way is sudo zypper dup --no-allow-vendor-change

I will try to give you a direct answer, not ignoring the answers already given above. Some of those who answer there work along the same lines as I do.

First, as the above post stresses, zypper up is not the correct way to update Tumbleweed, so indeed do not repeat again and again that that is to be done.

Then, I do not run Tumbleweed myself, thus what follows are my practices using the “normal” openSUSE version for years.

I, and most of you, are talking about “when I do”, when I see", “I …”, etc.
Of course we then mean a human person that is loosely the owner of the system. But the system does not know such (or any) human person. It only knows users (identified by userids and connected user names).

When I use the word “I” here connected to doing things with my system(s), I mean “I” as system manager (administrator), identified by the system as user root, not “I” as end-user. I see the end-users (including “I” using another user name) as customers.

LIke another already explained above, mostly once a week I start YaST > Software > Online Update and check what it offers. A short glance is often enough. Important is e.g. if there is a kernel patch because I want to reboot the system then asap and thus the system should be free to to so.

As I have also Packman, which does not provide patches but updates, I then use the Repositories View to look at Packman. Normally I then use from the packages list: Right-clicl, Update all in this list if a newer version is available. The same for other repos if there are any.

A manager of Tumbleweed will most probably do the zypper dup --no-allow-vendor-change instead of the two steps above.

I removed that applet for several reason:

  • I do not need it in my update policy as explained above;
  • It allows end-users to install updates, which is not something I (as system manager) will allow them to do;
  • You could block the usage of applet by e.g. removing Packagekit (which I do also), or by changing the PolicyKit to remove the update allowance, but that would still leave the applet on the desktop. Users having applets that they can not (and are not allowed to) use is not something I will offer my customers, who will possibly try to find out what it is and come to me with frustrated questions.

BTW to avoid “automatic” installation of packages you do not want, you can always “taboo” them. You can also from YaST Software Management > Options check Ignore Recommended Packages (or similar worded).

I hope I at least touched all questions above. It is partly a personal view on update management (no automatics, no surprises, at least a quick check before installing, system manager responsible) and how to implement that.

Despite of what others wrote, PackageKit (and zypper up) should work fine most of the time.
But yes, there are cases in Tumbleweed it cannot handle well, and the recommended procedure nowadays is to use “zypper dup --no-allow-vendor-change”.

But, the applet would still be a way to at least get notified of updates, and PackageKit can also be used for other things like installing packages.

In any case, there is work going on to make PackageKit updates “compatible” with Tumbleweed, see .

If you do want to uninstall it, you can lock it to avoid it being reinstalled automatically.

New TW snapshots are announced on the “factory” mailing list.

This is the most recent:

Many, many thanks @wolfi for the really helpful and competent comment! Highly appreciated, I never really understood the TW update voodoo! Can you give a simple example when the Packagekit /zypper up might mess up TW? Just to better understand what’s going on in my machine :slight_smile:

“zypper up” (and PackageKit currently) only update packages. If a package is actually downgraded, i.e. gets a lower version number, it will just be ignored.

This happened to the xorg-x11-server package some weeks ago, the version was changed from 7.6_1.18.3 to 1.9.0. I.e. the 7.6 prefix was removed, because it is actually incorrect and misleading. (years ago, Xorg was shipped as one large package, and that’s where this version number comes from, it was kept upto now to prevent update and dependency problems)

“zypper up”/PackageKit will keep the older version installed in such a case, which may also block other updates, or even worse may cause an incompatible mixture of different versions.
“zypper dup” OTOH tries to “map” your system to the configured repos. It also happily downgrades packages when there only are lower versions in the configured repos (as it is not guaranteed that newer distributions really have higher package versions in every case).

Also, “zypper dup” tries harder to resolve conflicts automatically (allowing to downgrade packages helps here too).
And especially conflicts are not handled at all by PackageKit, it just aborts with an error in that case (zypper and YaST ask the user for manual resolution).

Another thing that PackageKit currently doesn’t handle well is when packages get renamed. It just won’t see the newer package as update.
Though this case is actually handled correctly by “zypper up”.

Thank you, Henk, for taking the time to provide a detailed explanation. I understand and will proceed accordingly.

Thanks, Nathan. Once a week sounds about right, as Henk also recommended. I’m still getting used to the “rolling” thing, but liking it so far.

Okie Dokie, thanks Wolfi! that’s clear information