Software update says my network is offline

I just installed Tumbleweed using an ethernet connection because the installer wasn’t finding my wifi router. Once installed, wifi worked fine. However, now every time I select software update it tells me my network is offline, and the “last updated” time corresponds to when I was using ethernet. I assume it’s only looking for ethernet now, even though wifi is available. Does anyone know how I might fix this? I’m new to SUSE so it’s probably something obvious I’m not seeing. Thanks.

Just for now. Lets ignore the software updater

So just make sure you are online, wired or wireless and that you can browser web pages

Now open a Konsole terminal and become admin by doing:

su -

Now type:

zypper up

Does this fetch updates?

If you’re now using WiFi,
Have you switched over to using Network Manager (instead of Wicked)?

If you’re still using Wicked, it doesn’t remember multiple connection settings and you may really be offline, or there may be a bug that the installed Updater (which Desktop are you running? Is this the YAST updater or a Desktop applet like Apper?)
In any case, switch over to NM and your problem may be resolved.

TSU

Thanks for the replies.

@cafe4926 - Yes zypper works. Had too google what zypper was. Neat. I’ve got a lot to learn. So is zypper up the way the cool kids do updates? That seems very easy.

@tsu2 - I seem to be using Network Manager. Not sure where I access it directly, but when I select Network Settings in YaST it informs me that the settings are being handled by Network Manager. Is Connection Editor the same as Network Manager? That’s where I’ve been selecting my network.

Various Desktops use different tools to interface with NM now, particularly in LEAP and probably TW. Life was much simpler up to 13.2 when practically the same GUI tool was used in most Desktops. I’ve seen “Connection Editor” in Gnome-based Desktops which also includes LXDE and XFCE.

On lighter Desktops (or no Desktop), no auto updating tool like Apper is installed, so you generally need to update manually by invoking zypper. YAST also has an updating tool, but AFAIK it’s not configured by default, always.

TSU

Hi,

I am using Network Manager by default - and Software Updates states i am offline, yet obviously not, since i am typing this message.

I used the “zypper up” ommand which worked, and used YaST previously.

Any ideas on how to get the GUI Software Update to function ?.

Thanks and regards,

Shadders.

Switch to Wicked or setup the internet connection as “system connection” (“Allow other users to connect”) in NetworkManager. It will then be established during boot already, long before you actually login and the software updater is started.

Hi Wolfi323,

Thanks for the reply. Not sure how to do this - so will use the manual approach with YaST.

I did examine the control centre, but could not locate how to set up the connection s internet connection.

As an aside, this version boots very fast, and the GUI theme is so much better.

Regards.

Shadders.

You need to open the connection editor by clicking on the settings button in plasma-nm.

Apparently the problem might be fixed in Plasma 5.5.4 though:
https://bugzilla.opensuse.org/show_bug.cgi?id=959227

Hi Wolfi323,

Thanks - will examine the plasma-nm,

Just downloaded updates - new kernel 4.1.15 seems to have fixed another issue with pasting directories in Dolphin - if that was the location of the bug.

Regards,

Shadders.

No idea what problem you mean exactly, but I doubt it was a bug in the kernel…