Software Update: patch:openSUSE-2021-479-1.noarch conflicts with libbox2d2.x86_64

Hi All

I am getting the above Update Error when using the Software Update tool in 15.2.

BTW I am using the Factory repos for LibreOffice & have switched system packages to this repo. So this might be the problem?

Clearly it’s trying to update LO with an openSUSE package but I do not know what with (tried Googling the patch).

Can anyone please advise what to do?

Many thanks,


What do you mean with “the Software Update Tool”?

One normally uses either

zypper up

(and when that is the case, please show the complete command and output as it is on your terminal),
or YaST > Software > Software Management.

Please always explain what you are doing and do not assume that your way of doing it is so obvious that we all will understand without explanation. In most cases this isn’t true and there are more ways to achieve results then you may think of.

Also when you have extra repos, please show what you have, No body can inspect your list on errors/problems when you keep it secret:

zypper lr -d

I’m guessing that he means the desktop update applet.

And, yes, he should instead try

zypper up

from the root command line. That might avoid the conflict, be he won’t know until he tries.

As the OP suggests, using some packages from the factory repo is the likely cause of the conflict.

Hi hcvv, nrickert

Apologies for the delayed response.

Thanks for your replies.
Yes. Its the desktop applet that I was referring to with Software Update tool.

I’ll also include the complete repo information the next time as well, as suggested.

FYI: I used to use zypper previously but found the applet useful as it nags me to update when I login/restart a session.
The downside is that I run two KDE sessions at the same time on my laptop (work, home) to keep them separate.
The Software Update daemon appears to check for updates on both sessions at the same time (one after the other) rather than only on the home one. I have tried to set the work one to check only every month but it appears to ignore that setting!
So its extra overhead I could do without (my system has been running quite slow since I upgraded to 15.2). I often see the HDD being worked overtime so suspect that my laptop needs more memory (reports 5.7 GB).
Money is tight atm…

WRT the problem at hand, I did the following:

  • sudo zypper refresh
  • sudo zypper up

Fairly extensive list of updates.

Went through the update okay I think (need to reboot).
No reported conflicts etc. from zypper.

Thanks again,


Either use the applet to let it warn you, but then use zypper to update.
Or remove the applet completely from your system (which has the advantage that it does not show in all the desktop sessions all your different users may use, after all, what has a normal user to do with this?).
And organize yourself in your role as system manager (yes, the only one that knows the root password) and take a fixed time window e.g. once a week where you check for patches/updates, decide which ones to add, and update. Such a time window should be known to your users, so they will not complain when they have to log out e.g. for a reboot when a kernel update is involved (and even a Firefox update can give problems to existing running Firefox processes).

BTW, you do not need to do that zypper ref all the time. At least when you have auto-refresh on in your repo definitions. The zypper up (and other zypper commands) will check how long ago a refresh was done and then do it when needed.

Hi Henk

Thanks for your quick reply.

Actually the applet automatically refreshes the repo info without me needing a root password for either user (home, work) I have activated on the system.
I used to have to add the root group to the admin user (me) in past installs of KDE to give these privileges.
I have to use the root password for all other root activities (sudo, YaST, etc.).
So it’s a bit odd that the applet circumvents it. Don’t recall giving the option to save the root password to this applet?

I will probably delete the applet, thanks. Looks like it’s plasma5-pk-updates.
I’m the only person on this laptop so other software/repo things are a little simpler.

Will also add in the auto-refresh option in the repos. Good idea, thanks.

Enjoy your evening.

Thanks again,


The fact that it runs for a normal user and does not ask for the root password is the main reason I have removed it (in fact I do not install it at all). This is a main breach of security IMO.
The fact that it should not be there to even show to a normal user that there might be something to do for the system manager (what should he do, tell him?) is the next reason.

That is something I do not understand. It is in any case not how openSUSE ships and not the security policy of openSUSE. openSUSE does not know such a thing as a “admin user”, but it is up to you to do as you like.

It does not “save the root password”. I know of only two ways to let a root owned process do things directly instigated by a non-root owned process, but I did not check which one the applet, in fact PackageKit, uses.

Yes, that is it. I also haven’t PackageKit, which is the software behind the screen. The native openSUSE zypper and YaST > Software are good enough for me.

Again one of my hobbyhorses. Unix/Linux is a multi-user/multi-session operating system. Not recognizing this with utterances like “I am the only user” only obfuscates how Unix/Linux functions.

I do not quite understand. At installation and at most repo additions, the auto-refresh option is “on” by default. Did you switch “off” here?

It is 2021-03-29 14:13 here. But thanks, I will keep that until 18:00 lol!

You are welcome.

Hi Henk

Thanks for your extensive notes.

The new repos I added (KDE/etc. updates, LO updates) did not have automatic refresh set. Now fixed. I’ll keep this in mind in the future.
The original ones after the install (& Packman) were were already set to automatic refresh.

Apologies for the confusion about the admin user. I come from the ancient days & used systems such as VAX/VMS where limited users had system privileges. Also some other networking systems (e.g. Novell) where there was a separate superuser account/superuser privileges.
There is no real admin user as such on my system. I just “put on that hat” when working under my home account to update the system.

Thanks again.


There is an advice, which I support, that using certain repos, specially the so called “home” ones (very personal by people who like it to provide certain software to the community), they better be Disabled (thus not: no auti-refresh) during normal updating sessions. This to avoid pollution with other software that may be on those repos and that you do not want to overwrite your packages. Only from time to time, such a repo can be enabled, checked for newer version of the particular package you have from it and then update that one. Disable again and carry on. BTW it is important to remind this when using the 1-click install method, which will often leave you with a more or less obscure repo added.

But that is different from “no auto-refresh”, which was (is?) IMHO a feature to help people with very slow internet access to avoid refreshing except when they really need it.

Thanks Henk for the hint.