Software Update looking for Qt 5.6

I have been running Leap 42.1 KDE with Plasma 5 from the Frameworks5 repository

Today, there is a large batch up updates to Plasma that are failing dependencies for Qt 5.6.0

I have been pleased with the general improvement and maturation of Plasma5 and Leap 42.1.

Is Qt 5.6 ready for primetime, or should I move back to Leap 42.1 Update repo, which now supports Plasma 5.5 as well?

If so, which Qt repository to go with Frameworks 5?

I’d be interested in this as well.

I decided to experiment and I added one of the repositories with Qt 5.6 but it went terribly wrong. Basically all Plasma 5 software stopped working. I was getting a message similar to this:


kwrite: relocation error: /usr/lib64/libKF5XmlGui.so.5 symbol
_ZN15QGuiApplication35setFallbackSessionManagementEnabledEb, version Qt_5 not defined in file

When I say all software, I mean including the breeze sddm theme. I was getting a blank white screen upon start up. I got around it by replacing the “breeze” theme with “maui” inside /etc/sddm.conf. From sddm I launched IcdWM to get the basic desktop system working. I removed the Qt 5.6 repository, run zypper dup to downgrade everything and now it is (hopefully) working again (we’ll see what happens after reboot, but at least I can run the KDE programs again, wish me luck :)).

Anyway, I’d like to know when this is fixed as I’m really looking forward to Plasma 5.6 (at least one annoying bug should be fixed there).

There are way too many repositories offering up versions of QT 5.6.x for me to plow ahead at the moment.

As a partial check, I added this QT repo: http://download.opensuse.org/repositories/KDE:/Qt5/openSUSE_Leap_42.1/

I then clicked the Switch to files in this repo in YAST to see what dependencies would fail, and only got one (book reader app calibre).

Making this switch right now would install Qt 5.6.0

I did not run the install (I aborted).

Still hoping for some guidance from above…

Well, this is Leap, so I took the Leap.

I added the QT repo http://download.opensuse.org/repositories/KDE:/Qt5/openSUSE_Leap_42.1/

I open Yast, repository view, selected the added Qt repo and Selected Switch to packages in this repository.
QT and some packages from KF5 updated. I had only one dependency complaint (calibre), ignored it.

I killed X (it would not respond to logout), logged in again.
Desktop was in a strange state.

Opened YAST - Software management, Selected update all changed packages for the System.
Another 1.2GB of packages updated.

Rebooted (logout and login still funky).

I am now up and running, K Info center Reports

Plasma 5.5.95
Frameworks Version 5.20.0
Qt version 5.6.0

So far all seems good.

Glad to hear that it worked for you. I might give it another shot later.

I guess you had more luck when picking the repo. I think the one that caused me so much trouble was this one: http://download.opensuse.org/repositories/KDE:/Qt56/ You know, it’s called Qt56 and I needed Qt56 so it seemed like a reasonable choice :smiley:

I almost went there, but realized that had Qt5.6.1.

Good luck

Just tried the update via the specified repos

sddm came up as usual

Plasma 5 opened up with monitors showing unified outputs

single desktop with both monitors setup via systemsettings5 Display and Monitor, with some difficulty,
(setup does not survive a reboot, always back to unified outputs)
graphics unstable in this mode and pc soon locked-up

after reboot with unified mode, all seemed very stable

return to old configuration, via yast, successfully, as single monitor output is not acceptable

observations

  • now doing a system update there are no dependency complaints
  • install recommended packages is not selected in yast

thx for the info

cheers

My successful update was on laptop, single intel monitor.

Have yet to do my dual monitor fglrx system.

I read you comment to say that you are now stable with dual monitor setup AND Qt5.6.0?

Yes, you need KDE:Qt5 if you use KDE:Frameworks5. That’s how it is since ever.
As Leap 42.1 comes with Qt5.5, which was the latest version upto now, you were able to do without. But a few days ago, 5.6 has been released.

KDE:Qt5 always contains the latest stable Qt5 release, and is the devel repo for Factory/Tumbleweed.

KDE:Qt56 on the other hand is an unstable repo, and contains the latest Qt 5.6 development snapshot. IOW, it may break at any time.

And yes, there have been a lot of fixes regarding multi-monitor handling (and dynamic addition/removal of displays) in Qt 5.6.

Thanks for info and confirmation wolfi.

I may give Radeon driver a try on Qt5.6.0 again.
I could not get acceptable setup with Qt 4 or 5, fglrx does work for me now running Qt 5.5.1

Just to be clear: Qt 5.5 had some bugs/limitations in this regard, they should be fixed.

But Qt 5.6 won’t magically fix possible problems/bugs in the radeon driver of course.

hi cmcgrath5035,

With dual monitors and one desktop and Qt5.6.0 the graphics were very unstable!,
could not even select wallpaper for each monitor, lost system tray, lost keyboard input,
needed ctl-alt-F1 terminal to reboot.
With dual monitors with unified outputs, Qt5.6.0 seemed very stable

So re-installed Qt5.5.1

Cheers

You cannot use the latest KF5/Plasma5 packages from KDE:Frameworks5 then though.

And just in case, you should not install Qt 5.6 with the standard KF5/Plasma5 packages (5.5.5/5.19.0) from the standard repos either, as this will likely cause instability/crashes.

I cannot say much about multi-monitor systems though, as I only have one monitor.

But, the KDE:Frameworks5 repo contains Plasma 5.5.95 at the moment, which is a beta version, so this might explain some problems. It has been updated to the final 5.6.0 released already though (released today), which should get published in the next hours.

I frankly have lost the precise difference between Two Monitors and One Desktop, vs. Two monitors with unified outputs.

I ran the update on my dual monitor system, It came up well with Qt 5.6.0 and Plasma 5.5.95.
All seems good so far.
My configuration is two identical 1920x1080 monitors side by side , supporting a 3840x1920 Desktoo Area
Each monitor has it’s own wallpaper and it’s own panel at the bottom of display

I am staying with fglrx at the moment, as I see HERE that a new release of fglrx is coming shortly and addresses some systemd support issues.
Now that wolfi indicates a new Plasma (5.6.0) is also to be released, I’ll consume those before considering radeon.

My only issue is intermittent failure to enter S3 (suspend to ram), which frankly has almost become a non-issue.
When S3 does work, it takes my desktop perhaps 10-15 seconds to get fully restored.
I find that I can boot up to KDE desktop in about 30 seconds on my current hardware plus Leap 42.1.
I have / on a large, fast SSD.

FYI, it has been published already meanwhile…

So I tried it, getting this from Yast

#### YaST2 conflicts list - generated 2016-03-22 12:16:43 ####

nothing provides plasma5-desktop >= 5.6.0 needed by plasma5-desktop-branding-openSUSE-13.3-119.1.x86_64

     ] do not install plasma5-desktop-branding-openSUSE-13.3-119.1.x86_64

     ] break plasma5-desktop-branding-openSUSE-13.3-119.1.x86_64 by ignoring some of its dependencies



nothing provides plasma5-desktop >= 5.6.0 needed by plasma5-session-5.6.0-63.1.noarch

     ] do not install plasma5-session-5.6.0-63.1.noarch

     ] break plasma5-session-5.6.0-63.1.noarch by ignoring some of its dependencies




#### YaST2 conflicts list END ###

Looking in the Frameworks5 repository at repo
it appears plasma5-desktop did not build, still at 5.5.95.

It did build, but for some reason publishing is still disabled for plasma5-desktop (only).
I don’t know why, maybe an oversight.
I’ll enable it so it should be available shortly.

Thanks, got the Plasma 5.6.0

2 nuisance issues I have seen thus far

  1. kcalc won’t launch
  2. The show desktop widget crashes the desktop panel if you try to put it there - runs fine from a spot on the desktop.
    That issue appeared a couple weeks ago, probably a widget issue.

I’ll let the dust settle, can always fall back to my slide rule ;).

Yeah, right.
I can reproduce this here, it seems to hang on startup.

And here’s a bug report, with a patch to “fix” it:
https://bugs.kde.org/show_bug.cgi?id=360105
I’ll add this to our kcalc package in KDE:Applications, although it’s just a workaround for an apparent bug in Qt5.

  1. The show desktop widget crashes the desktop panel if you try to put it there - runs fine from a spot on the desktop.
    That issue appeared a couple weeks ago, probably a widget issue.

Yes, I noticed this as well with the Beta version, but I thought it would have been fixed for 5.6.0 final…
Haven’t come round to install/try Plasma 5.6.0 myself yet, so cannot tell really.

But check whether you do have plasma5-addons 5.6.0 installed, not 5.5.95.