Software update apparently replaced Firefox 3.6.4 with 3.5.9

Today the first automatic software update was launched on my newly installed openSUSE 11.2 - and apparently it replaced Firefox 3.6.4 with 3.5.9.

I tried to find out how to install 3.6.4 using YaST2, but adding the following repository didn’t help me any further:

Index of /repositories/mozilla/openSUSE_11.2

What do I need to do to have YaST2 install the latest firefox version?

I found out how to reinstall 3.6, but why the heck does the updater replace newer software versions with older ones?

Maybe because which repos you have active. Or sometimes with “newest” the naming convention can cause the installer confusion.

I think you need to change the vendor of the packages in question.

Reading that you had the current version 3.6.4 before you added the Mozilla-repository I suppose you used a Firefox-package from the Mozilla site and installed it without zypper / YaST knowing it. If that is true, you have two Firefoxes installed, one systemwide and one in your /home.

This also happened to me. I run online update. Then i noticed the firefox version changed to 3.5.9. karx11erx’s how did manage to install 3.6 again?

Use the switcher, like in this example:
(This is showing a kde switch, just do the same with mozilla)
ImageBam - Fast, Free Image Hosting and Photo Sharing

You need the QT UI to do this
Switch Yast Interface to QT

i manage to install it. thanks!

Great. Well done.
It’s always handy you tell us it worked because you followed some advice and what that advice was…