"Software Update" aborts when one of the updates returns with an error

In the last 2 years I have had at least 3 occasions when the “Software Update” aborts with a spurious error message in one of the updates. The problem then is, that Software Updates accumulate and cannot be executed until I go to the trouble of locating the particular update which causes the error and un-tick it. That update will then be posted again until a workaround is found, which is very tedious.

I had this situation last week as described in this post , which I finally fixed after several hundred updates had accumulated.

I had a similar problem with the “golang” package a year ago. I had erroneously installed conflicting versions of “golang” (as suggested by Yast). After that “Software Update” could not fix it and all other updates were blocked for months until I completely uninstalled “golang” and re-installed just the latest version.

I suggest something should be done with the OpenSuse “Software Update” program to not abort all updates, if one of them comes up with an error, for one reason or another. The good updates should go ahead and only the ones with an error should fail. The problem is that if you get a broken update once. you cannot get rid of it easily and all other updates are blocked after that with the current implementation of “Software Update”.

My general advice, in such a case:

As root (or with “sudo”) run from a terminal:

zypper up

That will usually give you a choice (a conflict resolution dialog) that will allow the update.

And yes, I recognize that you are really pointing out a limitation of the update applet. I’m not sure what can be done about that.

This has nothing to do with multimedia (except maybe that the OP stumbled into it with a multimedia related package), ithis will be moved to Install/Boot/Login and is CLOSED for the moment.

Moved from Multimedia and open again.

After reading @nrickerts anwer, I now understand that you are talking about the Updater applet.

Please remind that many of us never use it, often have switched it off, or have removed it from their dektop. Personaly I have desinstalled it, together with the Packagekit software that is the workhorse behind the applet.(well not deinstalled it, did not install them at all at system installation).

Most of us feel that libzypp accessed through zypper and/or YaST is the old trusted way of managing software on openSUSE systems. It was created and is supported by openSUSE.

Packagekit and the interfaces to it from the desktop were created much later by desktop designers who felt a need for an end-user interface to the different software management systems of the different distributions so that the end-user would see no (or almost no) difference in software management on a Ubuntu or Redhat or openSUSE system.

Those here not using it, but sticking to YaST/zypper have several arguments. E.g.

  • Why something new/different where YaST/zypper is the interface I know and understand.
  • The applet is a security risk because it allows end-users to update packages and only root should be allowed to do so.
  • I am not interested having a software management interface that works the same as on Ubuntu, … I use openSUSE and am not interested on how it works on others. And after all, when everything would be the same on all distributions, there would be no different distrubutions anymore and thus no choice.
  • At the start the applet/Packagekit was far from error free and we had to help many people in repairing their system by providing zypper statements to them.
  • The applet/Packagekit still lacks features compaired with the native zypper/YaST (as you found out yourself).

Of course there may be counter arguments to all of the above, but in any case, when you run into problems with the applet/Packagekit, most people here will

  • maybe have problems understanding what you do when you do not explicitly explain that you are using the applet (as you called it “Software Update”, with I tried to translate in my mind to some YaST action like YaST Online Update, being completely wrong);
  • and when they understand, they may not have any experience with the applet/Packagekit and thus will try to teach you how to use YaST/zypper;

Also, when you want to request for a feature to Packagekit (and that is what I think you try to achieve with your thread), the developers of Packagekit are not in the openSUSE team but elsewhere (I personaly have no idea, but I have no doubt they can be found when you want to reach them). And support for your request will be minimal from openSUSE users, because they do not experience the problem when using the openSUSE way of managing software.

Thank you Henk for your detailed and informative answer to my humble suggestion for the applet/PackageKit. I have been a SuSE Linux user since 1994 while working for DEC at Villingen-Schwennigen migrating a large banking software package from Kienzle minicomputers to a DEC Alpha. I learnt to appreciate Perl Vers 4. Previously I had worked with Unix in Australia and also ported the banking software to DEC Unix on the Alpha.

I do not remember if the 94 version of SuSE Linux already had YAST, but I certainly used YAST a lot over the years. Since 2000 I do all my development work on SuSE Linux and since 2010 I also do all my word and spread-sheet work with Libre Office on OpenSuse. Somehow I missed the introduction of zypper and all its features and was not aware that ‘zypper up’ did a full update. I am still not aware of the section in YAST which does an automatic update. This is probably my fault as an old UNIX user - I never bothered to look.

In my retirement I have designed a language and run time system for event driven real-time process control (immediate C), which can be run on any Linux system, but is particularly well suited to the Raspberry Pi with its real I/O and I/O extension cards. I find the Debian/Raspbian ‘apt-get’ command with its update feature particularly easy to use, reliable and quick. (I believe Ubuntu uses the same command, although I have never installed Ubuntu). On the whole zypper is very similar although I traditionally used YAST to install new software out of habit.

When the applet/PackageKit appeared a few (maybe 7 - 10?) years ago in OpenSuse I did not question it and it always seemed to do its job until 2 years ago, and it reminded me to update things, which I never used to do, because my mind was more on developing software. I also appreciated that it did not instigate updates itself like Windows, which often locked up a computer for an hour or more when you really needed to get some work done.

If I read you correctly, your suggestion is to execute ‘zypper up’ regularly (once a month?) and de-install applet/PackageKit. Nevertheless I would dearly love to get in touch with the group who developed and maintain the applet/PackageKit. I would be happy to work with them to change the behaviour if the applet in ways I have described. I strongly believe that would make it a more robust product and would help people like me who appreciate being reminded when a security update or some such is available.

PostScript: I agree with Henk, that the applet/PackageKit should call for the root password when the [Update] button is pressed - just like when starting YAST.

Thanks for your headup.

Re your question: what is recommended.
This is of course very personal. Being an old time Systems manager (and a lot of Unix in there), I, like you, prefer a regular window for system maintenance. I know several other shere do similar (maybe different intervals, different sequence of actions, depending on how many “non-official” repos are on the system, etc).

Once a week I do a YaST > Software > Online Update. I check what is there and have a short view at the details of some of them, but in general I accept all of them for installation. This is equivalent to zypper patch.
It will install newer versions (security and recommended only) of packages installed from the standrad OSS and non-OSS repos when they apear on the respective Update repos (the original repos do NOT change after version release)

Then I use YaST > Software > Software Managment and I go for the Reposirory View. I choose the Packman repo and in the right list of packages I do a RightClick to get a menu were I choose All in this LIst Install a newer Version when available. That will install all updates from Packman. Equivalent zypper up --from <Packman-repo-identification>

When you have other repos, you can repeat this action for them.

But, when you have many repos, this may be tedious. Also you might prefer zypper. Many people here simply do

zypper up

which will then install all newer versions of all enabled repos, including what a zypper patch would have done. So one go for everything. Depnding on if you are more or less interested in what is going to happen.

This all being done in a maintenance window, most users will not be loged in and it will be easy to end your own session and re-login and when needed do a reboot (e.g. by a new kernel). Making system backups might also be a good idea during a maintenance window, but this depends very much on your backup policy.

https://www.freedesktop.org/software/PackageKit/pk-help.html quickly found via https://duckduckgo.com/html?q=packagekit (or even Google). :wink:

just chiming in on how frequent to update your system…

IMO should be as often as you feel comfortable, there is no reason for a security patch to wait as long as a month to install for instance.
And, the longer your interval… The bigger your update will be and could affect your work if it places a heavy load on your your disk sub-system. On LEAP, you can go maybe a week or a little longer before you really <should> update but nowadays on TW with new releases as often as 3 a week, I’d almost recommend every other day unless you don’t mind the massive (ie > 600 Mbyte) updating.


The issue is not with the updater applet, but IMHO with your repo configuration. Please show

zypper lr -d

Ever since 42.1 my kids all have been using the updater applet without issues, i.e. I only upgrade their laptops to the next openSUSE version. AFAICS on my Leap 15 install, it mimics ‘zypper up’ OK. But … it cannot deal with repos containing other versions of packages already available in other repos, if no vendor change has been applied. In the case of my kids’ laptops and my Leap 15 install, problems arise when I don’t perform the vendor change on the Packman repo f.e. If I do, the updater works as one might expect.
FWIW: Personally I only use the applet for testing, my daily tool for package management is zypper.