software.opensuse.org changes and searching for perl modules/packages

I went to software.opensuse.org to search for some software. I noticed the changes. Nice. I was having a problem getting results that I had gotten in the past, so I stepped back and started searching for something basic.

I clicked on the tool icon and checked “Show development…”, “Show unsupport…”, and opensuse 12.1 was already selected.

In my example, I wanted to see all packages that began with perl. Normally I’d get pages and pages. I only got 1 package and that was for the package perl. I noticed 2 things. 1) Quotes were automatically added to the word “perl”, and 2) the search is case sensitive (if inside quotes). I thought, maybe with the changes, globbing or regex could be supported, so I removed the quotes and tried “perl*” (without the quotes). I got all kinds of packages that had nothing to do with perl (i.e, apper, step). I tried perl.* and got nothing.

I searched for perl-cgi. At first I got a page with the message “An internal error happened”, and then the page was refreshed and the perl-cgi package was displayed. It seems “perl-c”, is like “perl-.+” (without the quotes). It did display all kinds of things: perl-c?-? (where ? is a string representing part of the perl package name), but it didn’t display perl-cgi-ajax, and there was no Next page.

  1. How would one display all the perl modules/packages? Sorted by package name would be nice.
  2. Can the search be limited to package name or expanded to description or sub-packages?
    Any tricks for the search field :-)?
  3. Is there an announcement for the changes that might describe some of the features?

Thank you.