Soft Raid 1 Setup / Failure 11.3

Hi Everyone,

I have a software Raid 1 setup and decided to test it the otherday. So I pulled one of the drives (2x250GB samsung SATA) out while the machine was running. Console 10 noted the drive failed other then that the OS did not notify me of any changes. But when I tried to access files that were on the RAID only about half of them would open.

Did I configure the md0 incorrectly?
Is there a way to check the RAID status?

Even after I put the drive back the files were not accessible until I rebooted.

The drives are also plugged into a SYBA PCI Raid controller card with a RAID 1 configured, I think this is one of those Cheap “fake” hardware raid controllers, however it reports the Raid is intact and consistent.

Any help would be appreciated.

Thanks.

Do you have a mdadm service running in monitor mode? That sends out the notifications.

However that’s for true software RAID. I don’t know what kind of setup you have whether it uses the fakeraid at all or you are just ignoring it.

I probably do not have mdadm running, I have not heard of that I will read about it. But my Concern is why was I not able to access all the files on the RAID?

I am going to move this RAID array to a new machine and i must be able to access everything. To me only 50% of the files were accessible almost imitating a RAID5, but I double checked to make sure it was a RAID1.

is there a way to verify the RAID validity?

Very simpy check is just:

cat /proc/mdstat

I am guessing this means everything is ok?


babyuigi:~ # cat /proc/mdstat
Personalities : [raid1]
md0 : active raid1 sdd1[1]
      244195864 blocks super 1.0 [2/1] [_U]
      bitmap: 355/466 pages [1420KB], 256KB chunk

unused devices: <none>

I saw some errors that sdd failed and had unrecoverable blocks in the logs I will post:


Nov 10 08:36:49 babyuigi smartd[3136]: Device: /dev/sdd [SAT], 1 Currently unreadable (pending) sectors
Nov 10 08:36:49 babyuigi smartd[3136]: Device: /dev/sdd [SAT], 1 Offline uncorrectable sectors
Nov 10 09:06:50 babyuigi smartd[3136]: Device: /dev/sdd [SAT], 1 Currently unreadable (pending) sectors
Nov 10 09:06:50 babyuigi smartd[3136]: Device: /dev/sdd [SAT], 1 Offline uncorrectable sectors
Nov 10 09:36:50 babyuigi smartd[3136]: Device: /dev/sdd [SAT], 1 Currently unreadable (pending) sectors
Nov 10 09:36:50 babyuigi smartd[3136]: Device: /dev/sdd [SAT], 1 Offline uncorrectable sectors
Nov 10 10:06:49 babyuigi smartd[3136]: Device: /dev/sdd [SAT], 1 Currently unreadable (pending) sectors
Nov 10 10:06:49 babyuigi smartd[3136]: Device: /dev/sdd [SAT], 1 Offline uncorrectable sectors

No, that very bad…

You have only only device in your raid: sdd1. When everthing is ok, will get something like this:


Personalities : [raid1] [raid0] [raid5] [raid4] [linear] 
md0 : active raid1 sda5[0] sdb5[1]
      75071616 blocks [2/2] [UU]

So you have only one disk in raid - and I’m affraid it’s the bad one, looking at the errors from smartd. Maybe you will find all of your files on the second disk?

Ok thanks very much I will get the drive replaced that failed.