So what about NVIDIA 256.53 and kernel-3.1.0

Hi there.

I’ve been very satisfied with nvidia 256.53 driver on kernel 2.6.x (newer drivers were conflicting with kde, vlc and so on, famous problem). After upgrading to opensuse 12.1 and kernel 3.1.0 I can’t install the nvidia driver, because it shows an error during installation (compilation). And there are no specific errors in nvidia-installer.log.

  1. Does somebody have the same problem? Are they totally incompatible?
  2. Maybe there is some method to get new nvidia drivers work with kde*?

** I’ve noticed very strange behavior: kde loading screen doesn’t just freeze, desktop DOES load (I can see that the cursor changes its appearance in some areas, i.e. there are opened windows), but I still see the loading screen.*

P.S. I have edited nv-linux.h in order to disable kernel version checking, nothing changes.
P.P.S. I’ve tried nouveau driver, it’s awful.

On Wed, 23 Nov 2011 19:16:03 +0530, faisne
<faisne@no-mx.forums.opensuse.org> wrote:

>
> Hi there.
>
> I’ve been very satisfied with nvidia 256.53 driver on kernel 2.6.x
> (newer drivers were conflicting with kde, vlc and so on, famous
> problem). After upgrading to opensuse 12.1 and kernel 3.1.0 I can’t
> install the nvidia driver, because it shows an error during installation
> (compilation). And there are no specific errors in
> nvidia-installer.log.
> 1) Does somebody have the same problem? Are they totally incompatible?
> 2) Maybe there is some method to get new nvidia drivers work with
> kde*?
>
> -* I’ve noticed very strange behavior: kde loading screen doesn’t just
> freeze, desktop DOES load (I can see that the cursor changes its
> appearance in some areas, i.e. there are opened windows), but I still
> see the loading screen.-
>
> P.S. I have edited nv-linux.h in order to disable kernel version
> checking, nothing changes.
> P.P.S. I’ve tried nouveau driver, it’s awful.
>

is there a particular reason you’re sticking with this old nvidia driver,
like hardware compatibility? i just installed nvidia 290.10, wich works
well with openSUSE 12.1 / KDE 4.7.3


phani.

Yes, as I described, I see nothing but the kde loading screen, when one of 260.x-290.x drivers is installed.
I have no clue about what is wrong in my configuration. Does you have compositing enabled?

On Wed, 23 Nov 2011 19:56:03 +0530, faisne
<faisne@no-mx.forums.opensuse.org> wrote:

>
> Yes, as I described, I see nothing but the kde loading screen, when one
> of 260.x-290.x drivers is installed.
> I have no clue about what is wrong in my configuration. Does you have
> compositing enabled?
>

not “compositing,” but KDE desktop effects are on, yes. i’ve read about
problems with compositing somewhere, but if you use KDE, that shouldn’t be
necessary. KWIN takes care of the effects, and in my case it does ok.

my nvidia card is “GeForce 7900 GS”, cheap & old. perhaps there’s a
problem with certain cards, not with others?

if not a hardware issues, i’d try booting with a new user account, and all
effects, compositing & otherwise, disabled for a start. if that boots ok
you could try to enable KDE desktop effects and see what happens.


phani.

O.o it works now. I’ve simply reinstalled nvidia-gfxG02-kmp-pae and x11-video-nvidiaG02 packages (v. 285.05.09). The question is - why didn’t it work earlier? I suspect that removing /etc/X11/xorg.conf (and recreating by nvidia-xconfig) has helped.
Whatever it was, thank you for your concern :wink:

NB! (maybe it would help somebody with similar problem) Before having installed the nvidia driver, I changed compositing type from opengl to xrender. Then, after KDE had started successfully, I tried to change it back to opengl, but it crashed. Then I also unchecked “Enable direct rendering”, and openGL compositing has started working. And even after rebooting all works :wink:

I have recently upgraded two computers to 12.1. With the first, the nvidia drivers went OK. With the second, they didn’t. Followed the advice and removed all the nvidia drivers with Yast2 and the reloaded them (Version 285.x). Now things work OK.