So I blew away my /boot files...

I’m running 12.3 x86_64. I ran out of space on my /boot partition during a kernel update to 3.7.10-1.4, and like a kompleet idiot, I deleted the 3.7.10-1.1 files instead of the 3.7.10-1.4 files and my machine righteously crashed during the subsequent reboot attempt. Trying to be clever, I erased the 3.7.10-1.4 files and tried to grab the 3.7.10-1.1 files from /boot from the openSuse Live DVD. However, there is no initrd-3.7.10-1.1-desktop file present, so I still can’t boot. I located and downloaded the 3.7.10-1.1-desktop kernel RPM and extracted it, but there is no initrd file there either. Is there a way to recover from this without doing a complete install (which would really give me a sad)?

Oh dear :wink:
This should help…?

Malcolm, you are the man; a real life saver. Ok, maybe that’s a bit dramatic, but you definitely saved me many hours trying to rebuild from scratch. If I could, I’d buy you a cold libation and drink to your health.

One question now, though. My original problem still exists in that my /boot partition is only 100MB, and it’s 64% full, which means that when I try to update the kernel, it will fail. Any suggestions for how to handle this? (Like maybe moving the initrd file to a different partition prior to starting the update, or some such Tom Foolery?)

You have several choices:

  1. Change the partitioning scheme for your desk to provide more space for “/boot”, or to stop having a separate “/boot”;
  2. Change “/etc/zypp/zypp.conf” to turn off multi-version kernel support. (Just comment out the line beginning “multiversion”;
  3. Delete plymouth, so that your “initrd” files are smaller.

My choice was to delete plymouth. I posted about this on my blog. It was also discussed in an earlier thread My first tumbleweed mishap

On 05/15/2013 03:06 AM, nrickert wrote:
> You have several choices:

another would be to do the Safe Admin Practices thing of having a
full system backup prior to doing anything as drastic as replacing a

and, then if “Trying to be clever” interferes with reality, a common
restore is all that is required…