So how do i do this.....

Hi there, first impressions of the new forum… hmm not too sure to be honest. Seems a bit “all over the place”.

Anyway my questions.

Im havine a couple of problems with suse10.3.

Problem number 1.
I have configured most things i want configuring now but i am still not able to install updates. The update comes up that is available for me to download but when i type my password in it just doesnt install and it restarts the process again of me having to type my password in to install it and then it does it again and again. So in basic. I cant install updates.

Problem Number 2.
How do i log in as an administrator? How do i set this account up etc?

Problem number 3.
How do i set up a user to be an administrator so they can do absolutely everything to my system.

for example. I have been trying to install Java for Limewire to run properly. I download the correct file from the Java website but when following the installation guide on it i have to create a directory called Java for it to install. It wont let me create this folder as i dont have the permission to do this. I want to be able to do this.

Problem number 4
Im also looking at getting my system to do other neat little tricks such as commpiz fusion? I believe. Is there lots of neat little things you can add to the desktop. for example on Vista there is the side bar. Is there something like this for Linux?

I hope you can help me



Could you open a terminal window, type in zypper sl and post the results here.

Sounds like you might have the update repository enabled twice which is causing issues with updating the system properly.

Cheers mate for the reply unfortunately i wont be able to do this whilst tonight as im currently working :wink: cough

Please do so when you get back - my uneducated guess is that you have the Update there twice, removing one should do the job.

(ps, I’m not a mate :stuck_out_tongue: )

Typically the user “root” is the administrator by an openSUSE PC. This is setup as part of the installation.

The policy is to NEVER log in as root, but rather when logged in as a regular user, one types “su” or "sudo < some command > " in a terminal/xterm/konsole (looks like a DOS window on Windows) and enters the root password, and then can do things with “administrator permissions”.

This is not a good idea. If you wish to open the door for users with my knowledge to have a better possibility to hack into your system, then apply those sorts of permissions to a user. Its simply not safe when there are more advanced Linux users around (and I’m not that advanced).

Also, its not safe for yourself. Newbies can make mistakes as an administrator that cripples their system, causing weird (or even blocking) side affects, that destroys their Linux experience.

Even the most advanced guru’s do not operate with administrator permissions. They have learned over the years that it is not wise.

Please, in case you are new to this, it might be worth your while to brush up on some Linux concepts/philosophy per this openSUSE concepts Link:
Concepts - openSUSE

Welcome to our forum, and I hope you enjoy your openSUSE Linux experience.

Problem nr 1

I yhink yyou are using the applet. Since about one month this is not working properly.

Use YaST > Online Update and you will be fine.

Hi again,

I have installed opensuse 10.3 on a spare work pc and its doing the same as my home PC. This is the results of my work one.

James@linux:~> zypper sl

| Enabled | Refresh | Type | Alias | Name

1 | Yes | Yes | yast2 | 10.3-oss | 10.3-oss
2 | Yes | Yes | yast2 | 10.3-non-oss | 10.3-non-oss
3 | Yes | Yes | rpm-md | openSUSE-10.3-Updates | openSUSE-10.3-Updates

I imagine that if i can fix it on this pc i should be able to sort it out on my home pc. Would you be able to explain to me what this is.

Thanks love :slight_smile:

Nope - no double repository there.

However you can, with root privilges (use su - to switch to root as a normal user in a terminal) issue zypper up and follow the on screen instructions - see if the issue persists.

Thanks i have now managed to update it and im sure that will fix my problem. Is there any reason why it wont update automatically though? Is this not something i will be able to fix?

I told you above what is wrong. See also

i had many problems with the auto-updater when i tried updating suse. i got rid of it shortly, and do all of my updates manually now. you might find this works better, i know for most it does.