So....Gnome 3 works...How ever it failed to start due to graphics?

I have a netbook. Acer one aspire with intel gma 945 built in graphics card (i believe - there is no sure way for me to tell in OpenSUSE that I know of because unlike windows theirs no right click on computer - properties)

When i first installed OpenSuse i got all the gnome affects like wobbly windows and what not. after my upgrade to the official gnome three repo’s apparently it failed to start because my graphics device isn’t supported?


I don’t see an edit button - so sorry for the double post but I wanted to add this:

My acer aspire one with 1 gig of ram, 160 gig hard drive and a intel gma 945 can do the full aero experience and run smoothly in windows 7 ultimate and windows vista ultimate - so why can’t i do gnome…? that makes absolutely no sense. I obviously have enough hardware acceleration for windows 7 and vista ultimate but not for gnome? I think thats ass backwards! and ludicris

On 04/13/2011 02:36 PM, adrienk wrote:
> I think thats ass backwards! and ludicris

Acer shipped your machine with a 3D graphics driver tuned for use with
aero and the graphics set they built into your acer…

of course, that driver only runs in windows software, so i ask: did you
install the 3D graphics driver for Linux provided to you by Acer?

or, the one built for use in Linux by Intel?

or, did you try to install one using the info here:

[NNTP via openSUSE 11.3 + KDE4.5.5 + Thunderbird3.1.8]
Q: Why do you upgrade?
A: Because the Gecko is always greener on the other side!
So said k428 in

No I did not. I did not know (i knew distros shipped with) that there was a seperate graphics driver. When i first installed open suse it just worked out of the box with effects. when i upgraded to gnome 3 thats when **** hit the fan

Oh wait yes I did from this repo: Index of /repositories/X11:/XOrg/openSUSE_11.4

Finally found the edit button >_<

Any ways it still gives me the same results but im trying the link you gave me.

With that repo it still doesnt load properly -ill post back after I try the link you gave me.
By load properly i mean it doesnt work gnome 3 is still broken in the sense that its in fugly fall back mode

and now a problem:

Xorg -configure in run level 3 give me:

fatal server error:

cannot move old log file “/var/log/Xorg.0.log” to"/var/log/xorg.0.log.old"

Fixed that problem by being in su >_<

Ok so I tried changing intelegacy to intel still nothing. I get the crummy fall back for gnome. Ill try the iegd. How ever I believe that gnome 3 cannot run on a intel 945 chip

Has any one got any ideas?

Gnome 3.0 is working fine on my ASUS netbook with the 945 chip. I did a fresh install from the live CD then upgraded to the not ready Gnome 3.0 repository. It’s working fine at the moment.

I did a fresh install from the live cd for open suse. Should I do a fresh install of the gnome three live cd?

What I did was a fresh install from opensuse 11.4 live cd

Added: Gnome 3

installed and upgraded. restarted and I am having issues with its default fall back

I used:

to update my drivers and changed the xorg.conf to intel (iegd crashed the system it wouldnt start) and still nothing

I dont think an acer aspire one netbook can run gnome3

It could be eaiser for the moment since there is some issues to fix with the official repo.

On 04/13/2011 04:06 PM, adrienk wrote:
> fatal server error:

sounds like a GNOME3 problem, and not an openSUSE or Acer problem…

suggest you log a bug…

> Fixed that problem by being in su>_<

please do not log into GNOME as root–that is NOT a fix, it is instead a
very insecure work around, which should not be used…

whatever, do NOT browse the web in that configuration…more on that here:

[NNTP via openSUSE 11.3 + KDE4.5.5 + Thunderbird3.1.8]
Q: Why do you upgrade?
A: Because the Gecko is always greener on the other side!
So said k428 in

If I understand this correctly. I should Download this live image: GNOME 3 - Made of Easy
And install it? like as a whole fresh os install?

Yep, you got it right.

And wait till the repo is completely fixed.

YES :slight_smile: then be patient and wait for the ‘Official’ ok to use the Gnome Stable 3.0 repository, it’s still in flux.

Ok lets test this jazz.

Ill report back on any crashes or fixes…Can I still have my rops like tumbleweed and any others that I add or can that crash the system? using this image?

For now, I suugest you stick with the official repos that comes with it and you should not have problem using Tumbleweed repo if you are used to activate it.

makes sense. when the suse repos come out or become more stable and way more better. will switching from what the live cd installs to suse be as easy as disabling the ones that come on the live cd and enabling the ones that suse gives?

All you need to do is disable the fcrozat repository, add the gnome 3 one then open YaST software management and select the repository view, scroll to the Gnome 3 and select ‘switch installed packages to the ones in this repository’

I wouldn’t run tumbleweed on the Gnome 3 install. Create another install (on a separate partition) from 11.4 and upgrade from that.

um it was the open suse gnome 3 stable repo that broke my system.

So I am running gnome 3 off a live cd where I got it from - that like I showed you guys…

Um…Wheres the install this to harddrive option?

found it