SMplayer termination on playing certain DVD from folder

Hello.
I have SMplayer crashing after starting playback of a certain DVD from folder. Got everything installed according to Restricted Formats Installation Guide, all other media is played properly (including DVDs). Could that be any kind of protection or anything else? The player just closes after choosing “play all” either “play a scene”, but other menus (audio settings e.g.) work right.
I’ve checked the files and they’re not corrupted, everything seems to be fine, but it still just terminates.

Does SMplayer crash only when you play this certain DVD from folder or does it also crash when you play the same DVD from the DVD/CD Drive from your computer?

What does konsole says when you start SMplayer via Konsole in case when it crashes?

rotoglok@rok:~> smplayer
SMPlayer v. 0.6.8 (SVN r3213) запущен в Linux
rotoglok@rok:~>

And after I start any playback, it just terminates leaving no errors.
As I said, everything is played correctly except that certain DVD.

Did you tried to play that certain DVD with a different player like kaffeine? Maybe it is a encrypted DVD forwhat you need a special library.

Kaffeine and xine refuse to play it at all, and VLC has the same problem as SMplayer has, only it just stops without exiting.
Which libraries might I need to read encrypted DVDs?

Its the library for dvd encryption. In my country i am not allowed to post that name of the library because its not really legal here. But you can find it in the guide about restricted formats and dvd encryption.

look in your inbox

is only smplayer crashing or does mplayer itself crash too? What happens when you play the directory with mplayer?

mplayer dvd:// -dvd-device /path/to/folder/VIDEO_TS

rotoglok@rok:~> mplayer dvd:// -dvd-device /***/VIDEO_TS/
MPlayer dev-SVN-r29796-4.4-openSUSE Linux 11.2 (i686)-Packman (C) 2000-2009 MPlayer Team
Can’t open joystick device /dev/input/js0: No such file or directory
Can’t init input joystick
mplayer: could not connect to socket
mplayer: No such file or directory
Failed to open LIRC support. You will not be able to use your remote control.

Playing dvd://.
libdvdread: Using libdvdcss version 1.2.10 for DVD access
libdvdread: Couldn’t find device name.
There are 4 titles on this DVD.
There are 1 angles in this DVD title.
audio stream: 0 format: ac3 (stereo) language: en aid: 128.
number of audio channels on disk: 1.
number of subtitles on disk: 0
MPEG-PS file format detected.
VIDEO: MPEG2 720x480 (aspect 2) 29.970 fps 8500.0 kbps (1062.5 kbyte/s)
[vdpau] Could not open dynamic library libvdpau.so.1

Opening video decoder: [mpegpes] MPEG 1/2 Video passthrough
Could not find matching colorspace - retrying with -vf scale…
Opening video filter: [scale]
The selected video_out device is incompatible with this codec.
Try appending the scale filter to your filter list,
e.g. -vf spp,scale instead of -vf spp.
VDecoder init failed :frowning:
Opening video decoder: [ffmpeg] FFmpeg’s libavcodec codec family
Unsupported PixelFormat -1
Selected video codec: [ffmpeg2] vfm: ffmpeg (FFmpeg MPEG-2)

==========================================================================
Opening audio decoder: [liba52] AC3 decoding with liba52
Using SSE optimized IMDCT transform
Using MMX optimized resampler
AUDIO: 48000 Hz, 2 ch, s16le, 192.0 kbit/12.50% (ratio: 24000->192000)
Selected audio codec: [a52] afm: liba52 (AC3-liba52)

[AO OSS] audio_setup: Can’t open audio device /dev/dsp: Device or resource busy
AO: [alsa] 48000Hz 2ch s16le (2 bytes per sample)
Starting playback…
Movie-Aspect is 1.33:1 - prescaling to correct movie aspect.
VO: [xv] 720x480 => 720x540 Planar YV12
[mpeg2video @ 0x88df2c0]ac-tex damaged at 0 5
[mpeg2video @ 0x88df2c0]Warning MVs not available
[mpeg2video @ 0x88df2c0]concealing 1125 DC, 1125 AC, 1125 MV errors
A: 8.2 V: 8.2 A-V: 0.007 ct: 0.085 242/242 19% 4% 0.9% 9 0

Exiting… (End of file)

So it plays the first file in the directory, then closes. Something tells me that I missed obvious things here, just can’t see which.

yeah you need to pass it the correct DVD title, and you have four of them. If you just specify dvd:// with no title number behind, it’ll always pick the first title which may not be the longest one (usually the movie title). So find the longest and do dvd://2 (if, for example title 2 is the longest)

Playing dvd://3.
libdvdread: Using libdvdcss version 1.2.10 for DVD access
libdvdread: Couldn’t find device name.
There are 4 titles on this DVD.
There are 1 angles in this DVD title.
libdvdread: Invalid title IFO (VTS_03_0.IFO).
Cannot open the IFO file for DVD title 3.
No stream found to handle url dvd://3


Exiting… (End of file)

Playing dvd://4.


Starting playback…
Movie-Aspect is 1.33:1 - prescaling to correct movie aspect.
VO: [xv] 720x480 => 720x540 Planar YV12
[mpeg2video @ 0x88df2c0]ac-tex damaged at 25 1
[mpeg2video @ 0x88df2c0]Warning MVs not available
[mpeg2video @ 0x88df2c0]concealing 1305 DC, 1305 AC, 1305 MV errors
V: 0.2 3/ 3 ??% ??% ??,?% 0 0

Exiting… (End of file)

It plays send title which is not the one with menu, for others mplayer opens player window and closes it immediately.

mplayer, when ran with dvd://, can’t handle DVD menus. for this you need dvdnav:// instead of dvd://

DVDNAV, switched to title: 16 ct: -0.017 238/238 36% 4% 1.0% 0 0
a52: CRC check failed! 0.216 ct: -0.002 5/ 5 ??% ??% ??,?% 0 0
a52: error at resampling
libdvdnav: ifoRead_TITLE_VOBU_ADMAP vtsi failed2 45% 7% 1.9% 0 0
a52: CRC check failed! 0.001 ct: 0.271 393/393 45% 7% 1.9% 0 0
a52: error at resampling
A: 13.6 V: 13.6 A-V: -0.049 ct: 0.260 400/400 45% 7% 1.9% 0 0

Exiting… (End of file)

Then we get this when crashing. Hmmm

is this a decrypted folder, as in stripped from protection? Can you play it without problems with other players such as xine? (I suspect it may be corrupt in some way, but not enough evidence to support that right now)

CRC check failure makes me suspect something, too. But the folder itself is readable and changeable, though none of other players plays it. The thing is - that folder is a digital copy of a DVD I bought, the copy not made by me, but no one among people who downloaded it had any problems with playback.
By the way, my DC++ client marks some files with their *.gltth copy for faster hashing, but as far as I understand it’s usable for NTFS, and I’m using ext4 file system. Could that corrupt something?

So if you have the DVD yourself, why not rip it again? CRC errors can mean two things: either there is a corruption somewhere in the files thus the decoder fails to decode it and throws such errors, or there is still some encryption present somewhere (or leftover), which again leads to the decoder spewing errors as it can’t decode due to this. If none of the players can play it, then there really must be something fishy with it… and how do you know that people who downloaded it had no issues with it? Did they say so?

It’s been downloaded 143 times and no one said there are errors at the torrents forum (could give you a link if u understand Russian). I think it’s no good trying “sudo mplayer” to try giving it access to the folder. So there’s still something wrong, may be I try moving it on another hard disk.

Moved the folder to /home/ directory, still the same - it browses all the menus properly, changes audio settings, but any playback makes it crash - same as SMplayer

I found out that often lots of people just don’t post any comments about the state of the content they’ve downloaded. And 143 people is not a lot and we can’t assume that they have watched it yet

Further, since you can’t play any of the four titles, are you sure that during ripping, the correct titles were selected? I’ve no idea really what’s up with this DVD rip you have, but if none of the other players can play it, then there’s something fishy. Also, can you play the biggest VOBs with mplayer? Just go in the VIDEO_TS directory and see which VOB is the biggest (usually there are multiple big ones which comprise the whole movie and are split in 1GB files for compatibility with HW players)… so just do mplayer /path/to/folder/VIDEO_TS/VTS_01_0.VOB for example

Strangely, it plays those files alone! So, there should be a problem with libdvdnav, am I right?