Smplayer not working Exit code 127

Hi again
Having reinstalled Leap15 then following the sticky Multimedia Guide, I have am having trouble with Smplayer, when I try to play a video it says" Opps something gone wrong"

Mplayer has finished unexpectedly Exit code 127

here is the log

 /usr/bin/mpv --no-config --no-quiet --terminal --no-msg-color --input-file=/dev/stdin --no-fs --hwdec=no --sub-auto=fuzzy --no-input-default-bindings --input-x11-keyboard=no --no-input-cursor --cursor-autohide=no --no-keepaspect --wid=58720275 --monitorpixelaspect=1 --osd-level=1 --osd-scale=1 --sub-ass --embeddedfonts --ass-line-spacing=0 --sub-scale=1 --sub-text-shadow-color=#ff000000 --sub-codepage=ISO-8859-1 --sub-pos=100 --volume=55 --cache=auto --screenshot-template=cap_%F_%p_%02n --screenshot-format=jpg --softvol=yes --softvol-max=110 --term-playing-msg=MPV_VERSION=${=mpv-version:}
INFO_VIDEO_WIDTH=${=width}
INFO_VIDEO_HEIGHT=${=height}
INFO_VIDEO_ASPECT=${=video-aspect}
INFO_VIDEO_FPS=${=container-fps:${=fps}}
INFO_VIDEO_FORMAT=${=video-format}
INFO_VIDEO_CODEC=${=video-codec}
INFO_AUDIO_FORMAT=${=audio-codec-name}
INFO_AUDIO_CODEC=${=audio-codec}
INFO_AUDIO_RATE=${=audio-params/samplerate}
INFO_AUDIO_NCH=${=audio-params/channel-count}
INFO_LENGTH=${=duration:${=length}}
INFO_DEMUXER=${=current-demuxer:${=demuxer}}
INFO_SEEKABLE=${=seekable}
INFO_TITLES=${=disc-titles}
INFO_CHAPTERS=${=chapters}
INFO_TRACKS_COUNT=${=track-list/count}
METADATA_TITLE=${metadata/by-key/title:}
METADATA_ARTIST=${metadata/by-key/artist:}
METADATA_ALBUM=${metadata/by-key/album:}
METADATA_GENRE=${metadata/by-key/genre:}
METADATA_DATE=${metadata/by-key/date:}
METADATA_TRACK=${metadata/by-key/track:}
METADATA_COPYRIGHT=${metadata/by-key/copyright:}
INFO_MEDIA_TITLE=${=media-title:}
INFO_STREAM_PATH=${stream-path}
 --audio-client-name=SMPlayer --term-status-msg=STATUS: ${=time-pos} / ${=duration:${=length:0}} P: ${=pause} B: ${=paused-for-cache} I: ${=core-idle} VB: ${=video-bitrate:0} AB: ${=audio-bitrate:0} 

/usr/bin/mpv: symbol lookup error: /usr/lib64/libvapoursynth-43.so: undefined symbol: vs_cpu_cpuid

here is the list of my repos

#  | Alias                                   | Name                                                | Enabled | GPG Check | Refresh
---+----------------------------------+-----------------------------------------+---------+-----------+--------
 1 | download.nvidia.com-leap              | nVidia Graphics Drivers                        | Yes     | (r ) Yes  | Yes    
 2 | http-opensuse-guide.org-8702b9e7 | libdvdcss repository                              | Yes     | (r ) Yes  | Yes    
 3 | http-packman.inode.at-abdee5d1    | Packman Repository                            | Yes     | (r ) Yes  | Yes    
 4 | libdvdcss                                     | libdvdcss                                             | Yes     | (r ) Yes  | Yes    
 5 | openSUSE-Leap-15.0-1                 | openSUSE-Leap-15.0-1                        | Yes     | (r ) Yes  | No     
 6 | packman                                    | packman                                              | Yes     | (r ) Yes  | Yes    
 7 | repo-debug                                   | openSUSE-Leap-15.0-Debug                | No      | ----      | ----   
 8 | repo-debug-non-oss                      | openSUSE-Leap-15.0-Debug-Non-Oss   | No      | ----      | ----   
 9 | repo-debug-update                        | openSUSE-Leap-15.0-Update-Debug      | No      | ----      | ----   
10 | repo-debug-update-non-oss           | openSUSE-Leap-15.0-Update-Debug-Non-Oss | No      | ----      | ----   
11 | repo-non-oss                               | openSUSE-Leap-15.0-Non-Oss             | Yes     | (r ) Yes  | Yes    
12 | repo-oss                                    | openSUSE-Leap-15.0-Oss                     | Yes     | (r ) Yes  | Yes    
13 | repo-source                                | openSUSE-Leap-15.0-Source                | No      | ----      | ----   
14 | repo-source-non-oss                  | openSUSE-Leap-15.0-Source-Non-Oss    | No      | ----      | ----   
15 | repo-update                              | openSUSE-Leap-15.0-Update                  | Yes     | (r ) Yes  | Yes    
16 | repo-update-non-oss                 | openSUSE-Leap-15.0-Update-Non-Oss     | Yes     | (r ) Yes  | Yes  

The version of Smplayer is 18.2.2-lp150.1.4

Your help is always appreciated, Thank you

Remove nr 6 ( duplicate of nr 3 ) and run


zypper dup --from 3 --allow-vendor-change

and report back if that changes anything.

Thank you Knurpht
Unfortunatley that did not fix the problem.

I have noticed in my list of repos that 2 and 4 are both libdvdcss repos. Should I remove one of them, if so which one would be best
Thanks

Your list does not show the repo URLs, so we cannot tell whether they are really the same.

If they are really the same, then it should not matter which you keep. If it were me, I would delete 2 and keep 4 (simpler name).

It is unlikely that this duplication is related to your problem with “smplayer”.

Post

zypper lr -d

That will show the important thing, the URL.

OK
I did a

zypper lr -d

I discovered that 4 was the one to delete as it referred to opensuse 42

I think I have found something that might help i did

zypper dup

The output was

Leap42:/home/user # zypper dup
Warning: You are about to do a distribution upgrade with all enabled repositories. Make sure these repositories are compatible before you continue. See 'man zypper' for more information about this command.
Loading repository data...
Reading installed packages...
Computing distribution upgrade...
2 Problems:
Problem: problem with installed package libmpeg2-0-0.5.1-6.5.x86_64
Problem: problem with installed package libvapoursynth-43-43-10.5.x86_64

Problem: problem with installed package libmpeg2-0-0.5.1-6.5.x86_64
 Solution 1: install libmpeg2-0-0.5.1-lp150.1.2.x86_64 (with vendor change)
  http://packman.links2linux.de  -->  openSUSE
 Solution 2: keep obsolete libmpeg2-0-0.5.1-6.5.x86_64

Choose from above solutions by number or skip, retry or cancel [1/2/s/r/c] (c): c

I did not do that command because the warning turned me off.
There is a line in the log about libvapoursynth

Hopefully this is helpful
Thanks

Have you check all of your repos to make sure that there is nothing else left over from 42.x?

I think I have found something that might help i did

zypper dup

The output was

2 Problems:
Problem: problem with installed package libmpeg2-0-0.5.1-6.5.x86_64
Problem: problem with installed package libvapoursynth-43-43-10.5.x86_64

Those are very likely left over from 42.x.

The packages for Leap 15.0 all have "-lp150."as part of the version string. So those are not Leap 15.0 packages. And possibly they are causing part of your problem with “smplayer”.

nrickert
Yes I have checked all other repos

I have just reinstalled Leap 15 and I don’t want to have to do it again. I am a little bit worried about the message should i run Zypper dup.Could you suggest a method to fix my problem
Many thanks

I have not seen all of the output that “zypper dup” gave. However, it is usually safe to run “zypper dup” and is often a recommended way of correcting errors after cleaning up the repo list.

If you do run “zypper dup”, then I suggest you follow that with

zypper dup --from packman

to check whether you have the packman version of multimedia apps.

Thank you to everyone who contributed to my problem. It is fixed

zypper dup

That was the solution
Once again thank you

We are glad to hear that. And thanks for reporting back.

I have another problem with my smplayer. I am trying to generate thumbnails, and when I do, I get this message

The following error has occured while creating thumbnail
The file /tmp/smplayer_prieview/00000001.jpg does not exist

What could be causing this problem, as it worked before my reinstall issue as mentioned above

Thank you

New problem: new thread.

The title of this thread does not cover your problem. You haeve said your problem here was solved, thus not many people will take another look at this thread. When you want the maximum of exposure (and thus the best chance of getting help), start a new thread with a good title.