smplayer/2 self-signed certificate

We have an internal development website with a self-signed certificate. If I access this site through firefox on Opensuse 13.2 I expect the warning popup (the first time) and that is what I get.
But if there is a link to a video at the same site then smplayer or smplayer2 does not ask if I wish to grant a security exception it simply fails silently.
Is this to be expected? Any workaround for this?

PS: On my MS Windows 7 machine the MS Video Player asks whether I would like to grant the security exception and the Videos run if I do so.

On Thu, 02 Apr 2015 15:56:01 +0000, helge59 wrote:

> But if there is a link to a video at the same site then smplayer or
> smplayer2 does not ask if I wish to grant a security exception it simply
> fails silently.
> Is this to be expected?

Probably; try running the command from a terminal window and see what the
error message is. That’ll help anyone trying to diagnose the issue see
what the actual issue is.

Jim


Jim Henderson
openSUSE Forums Administrator
Forum Use Terms & Conditions at http://tinyurl.com/openSUSE-T-C

Here is trial from the command line. Nothing that looks (to me) like an error message. Player appears but nothing runs.

helge@HPE-270f:~> smplayer https://xxx.xxx.xxx.xxx/abc/5964777.mpg?ver=2&sid=5F576DC3FFA0E78BAC88F41CD4FBC998&id=5964777&path=/srv/image2/000100/000126/2015/04/02/16-59-32.avi
[1] 13442
[2] 13443
[3] 13444
[2]- Done sid=5F576DC3FFA0E78BAC88F41CD4FBC998
[3]+ Done id=5964777
helge@HPE-270f:~> This is SMPlayer v. 14.9.0 running on Linux

[1]+ Done smplayer https://216.129.114.201/abc/5964777.mpg?ver=2

Since your URI contains ? and other characters, you need to encase the https:// address in “”, otherwise it’ll fail (as it did there)

f.ex.


smplayer "https://cool.site/cool.uri"

I tried with quotes at the console. Outcome now is a single line “This is SMPlayer v. 14.9.0 running on Linux”. Player opens but nothing shows. No error message.
Never says anything about allowing self-signed certificate.

Right now I have to start windows 7 in a VM to test the videos (via links on the web page). Works perfectly there (after clicking through the security warning pop-up) but it’s a pain.
Problem did not exist before enabling https on the server.

Thanks for your help.

What request do you get at the server or errors in the error_log?

I tried https + smplayer on my 13.2 VM fetching an .mp4 from a 13.2 server with nginx+https+php-fpm without issues.

http://i.imgur.com/WQpQL4U.jpg

I know the mplayer from Packman is compiled without https but smplayer should be fine.

Actually, what comes back is a playlist. A file with the extension “.m3u”. This file contains a list of https links. smplayer runs through the list from top to botton at high speed. I can see the url changing rapidly up in the smplayer titlebar but nothing plays.

On the server side (Tomcat), only the https GET for the playlist appears in localhost_access_log2015-04-05.txt. None of the https GETs for the avi files appear at all. It’s as if smplayer never makes the requests. But no problem if not using https.

WIndows media player has no such problems with this and all the .avi file GETs appear in the log and the individual are files returned and played.

I have found this in the smplayer log

[07:20:11:605] MplayerProcess::parseLine: ‘https protocol not found, recompile with openssl or gnutls enabled.’

You should send the Packman guys a mail asking why MPlayer is compiled without SSL support, perhaps there’s a legit reason for it but that’s clearly why you’re having this issue.

FYI: I installed “vlc - Video Lan Client multimedia player” from Packman and this works over https.
Thanks for your responses.

Actually, I find that smplayer plays https UTube videos.

Also, if I pick an address (https) from the playlist file and paste it into a web browser then the browser opens smplayer and it plays the video. But if I paste the same address straight into smplayer (open/url) it does not play.

Mystifying.