Smokin` guns sound issue

I have downloaded Smokin`guns from Smokin’ Guns :: Home , i have unziped the content of the archive and after using chmod +x smokinguns.x86 i have started the game. To my surprise i have no sound .

Can someone tell me how to solve this ?
I run open suse 11.0, 32 bits arhitecture. I will post more info`s if requested.

open yast and make sure you have the following repositories enabled.
suse builds/games
once this is done open software management and do a search for smokin guns and then download. start it and you should have sound unless you have a hardware issue. try this first and then post your findings in hardware…,.

I have the 2 repositories enabled. But i have found a work-around for this issue: a cron job that will execute :
**echo “smokinguns.x86 0 0 direct” > /proc/asound/card0/pcm0p/oss **

echo “smokinguns.x86 0 0 disable” > /proc/asound/card0/pcm0c/oss**

Just like in the sound issues of quake3 . I recommend using ioquake3 because that solve the sound issues with quake3 .