smb protocol unexpectedly stopped

Can’t browse smb schares with konqueror. I have a disk connectted to my router, when i browse with smb://192.x.x.x i see the two folders on my disk but when accessing them i get the message : The process for the protocol smb: / / 192.x.x.x stopped unexpectedly. I get this in suse 11 in 10.3 no problem. I see in other treads this is a common problem for suse 11 but i haven’t found any solution yet. I realy need this to work, everything else is just working fine. Tried downgrading samba but i get an error saying something about an invalid key.
No solution for this ?

Similar issue here. If I try to browse the samba shares in konqueror I get a firewall error, even though samba is allowed in the firewall. When I disable the firewall (which I shouldn’t have to do) it actually shows me the workgroup, but I get a server timeout when I try to browse the workgroup.

The odd thing is, if I type smb://[share ip] I can browse just fine, whether the firewall is on or not.

I upgraded 10.3 to 11 and i have te same problem. I think it its something to do with Kde4. Can’t even mount my drive with the mount command.
This makes me sad…is there nothing to fix this or should i want for some upgrade ?

I’ve just make a fresh install of suse 11 with Kde3 and the problem is still there. So nothing to do with Kde4. No one to help please ?

Guess what? Even I have face the same SMB problem!

I too did not have a problem using 10.2 office network. But now that I have installed openSUSE 11 (KDE4) I’m facing “timeout” issues for my network. Earlier in KDE4 I couldn’t even see my office network through SAMBA, but once I installed KDE 3.5 and I could finally SEE the network and even got access to it once.

But then, whenever I logged-on to the server, I kept getting the dreaded “Timeout on server” message. I still see my network folders, but I can’t use them. I have installed almost every recommended samba file I should (except cifs_mount, which I can’t seem to find)

But to be honest, in openSUSE 10.2, sometimes I would get the message “Timeout on server” which would go away when I restarted. No such luck here.

I only just figured out how to print on openSUSE 11, and I have no problem using the internet, so I can connect to the network,it’s just that I can’t use the data foldes.

I’ve also “unwisely” disabled my firewall (because that’s what I had to do in openSUSE 10.2 to get it to work). But even now there’s no luck.

Would love some help here as well. :slight_smile:


OK, that’s strange. I just wrote the previous post after going through Swerdna’s how-to… which was quite complex and perhaps not all relevant to me, because I could already “SEE” the network and had been able to browse, it’s just that I was “kicked out” by the timeout message.

Anyway, I tried to logging in again, this time changing my login from WORKGROUP/myname and PASSWORD to myname and PASSWORD and guess what, it worked. After putting Swerdna’s how-to in action, I had changed the workgroup to the right name of workgroup so I guess in the SMB login/ password I didn’t need to put the workgroup in.

But I’m not sure whether my problem is solved… because I dread the timeout message popping up again; but if it comes up again or not, I’ll post it here.

I think the command… “rcnmb restart” and “rcsmb restart” as root (“su”) (all these commands without the quotes) may actually help the timeout thing).

Let’s see, let’s see… hopefully there’s either no problem, or an easy fix.

OK, good news (For me). I restarted my computer and my office network is working, even through the bookmark (in the network folder). Yaaa! :slight_smile: (hope it lasts)

To Nayk92, ok thats good news for you !
Only my problem still exists. Tried everything: setting up samba, run levels diabled firewall… nothing helps.I think i do a (again) fresh install, this thime from cd rather than dvd. If i still van’t connect to my nas then i stick to 10.3 :frowning:

No, no, no, no… don’t do that. Don’t install through the CD, because that’s what I did and really struggled. The CD is almost like a economy version (CD) of a luxury car (DVD)… it hardly has anything. I don’t think that would help at all. I would better recommend a fresh openSUSE 11 install through DVD… and ensuring that both KDE4 and KDE3.5 are installed with everything resembling SAMBA… and drivers for your router.

All I can suggest is

  1. if you have all the SAMBA’s installed (according the to Swerdna’s post) then you have everything you need to get started.

  2. I worked only with KDE3.5 (after I had only installed KDE4. Are you working with KDE3.5 as your default desktop manager?

I’m sure that’s everything you need… but perhaps it’s a router driver clash… ok, ok… I’m a beginner… so I admit I have no clue… so I should just stop guessing.

Sorry about your struggles… hope it works out soon for you.

I have almost the same problem: If I try to connect to smb://guest@ I get the error message “The process for the smb:// protocol died unexpectedly”.

What could be causing this? Via the command-line I have no problem connecting provided I use the “echo 0 > /proc/fs/cifs/LinuxExtensionsEnabled” trick.

Zaaz, could you be a bit more specific about that trick ? Maybe i can try this and see if that work for me.

Hi Jan,

That trick I found on
[linux-cifs-client] cifs: mount error 20 = Not a directory, while it works with smbclient](

It works fine for mounting my Samba network disc but it has no effect on the problems I have with KDE and Samba.

I’ve the same problem.

I used openSUSE since version 10.1, 10.2 and then 10.3 for all my PC: on my working computer (x86), on my home computer (x86) and on my laptop (x86_64).
All these versions I have worked well.
At a working PC, I installed a new version of openSUSE 11.0, while the home computer made upgrade to version 11.0. I’ve can’t browse smb shares with konqueror, dolphin or krusader on both computers version (x86).
When I try access to smb://x.x.x.x box passwords request appeared. After fill password I go to root folder Windows domain without message about error. When I go to any daughters’ folders I have a message:
“The process protocol smb://x.x.x.x unexpectedly stopped.”

At laptop openSUSE 11.0 x86_64 continues to work after the upgrade from version 10.3 without error access to smb share.

IMHO problem is in the procedure of the request of the password. For example:
At the laptop passwords request box appear every time when I change smb://x.x.x.x folders within checked string ‘Remember password’.
On the both desktops computers passwords request box appear one time only when I go to root folder Windows of the domain without any error messages.
Error “The process protocol smb:…” appeared every time when I go to any daughters’ folders of the domain Windows.

I was wrong, sorry.
Now I check it.
I can go to any smb shares if it consist files and folders named English and can not if it consist files and folders in another coding, Russian for Example.

Guess what. On a old computer i’ve installed freenas and when i connect to this comp with smb://192.168.0.XXX it just work !!!
Connecting to my other nas on the same router don’t work. In the manual of freenas there’s something about when you want to connect to the freenas with a linux-machine you have to enable the SSHD deamon. Maybe this is doing the trick ? So i gues my nas just dont work with suse 11, yet i find this strange because it worked with suse 10.3 !

Ok, for me it proved to be a permission problem. Changing the group of the mount-point to “users” got rid of the KDE error message.

This issue is completely solved for me now. The trick:
modprobe cifs
echo 0 > /proc/fs/cifs/LinuxExtensionsEnabled
mount /mountPoint

is no longer necessary: I now mount the network disk with the option “nounix”.

SUSE11 + KDE4 the same problem. If there are a files whit non-english characters, then konqueror died with the message “The process for smb:// protocol died unexpectedly”. In smb.conf I add “dos charset 866” after that I can use console smbclient tool, but not a konqueror or dolphine.

Please, help someone!

Maxoid1, please try:

mount -t cifs //yourshare yourmountpoint -o nounix,noperm,gid=users,iocharset=utf8

or add an entry in /etc/fstab

yourshare yourmountpoint cifs noauto,rw,users,guest,nounix,noperm,gid=users,iocharset=utf8

Thank you very much!!! It’s work! Tha same as “smbclient” tool. But what to do with with Konquror? It was so cool: just type “smb://machineName” and so!

Is it a problem of ioslave and lisa? Or maybe of KDE4?