SMB Problem in OpenSuse 11 with KDE 3 or 4

I have a Linksys NSLU2 device with a USB drive on my network. I have always been able to connect to it with smb:. I just did a clean install of OpenSuse 11, and it will not connect to my smb share on the device. My previous installs have all been able to, and my Windows machine can connect to it. The share has “everyone” permissions, so there is no login required. The error that I get when trying to connect is “File does not exist: smb://”. It will continue, and sees all the files in the root of the share, except the last character of every file is missing. It does not see any folders. This happens in either KDE 3 or 4, and I’ve reinstalled to make sure it’s not a random error. This is a real showstopper for me, since all my backup files are on that drive. Any ideas would be appreciated. Thanks.

As a follow up, I tried mounting the share with the command line:

sudo mount -t cifs “// 2” “/home/louis/USB Drive”

…which returned the error:

mount error 111 = Connection refused

Again, any help or ideas are greatly appreciated. Thanks.

i know you said you have everyone permission on the share but just to exclude permission issues do you have a username/password you can try this with?

for me a cifs mount on OS11 KDE4 works fine like this:

mount -t cifs //192.168.1.X/{SHARENAME} /home/{USERNAME}/Shared/ -o username={USERNAME},password={PASSWORD}

it also works okay for me when I try to connect the system through dolphin as a SSH share but it will not keep my credentials that way


I need to correct my previous post. It does work with the mount command (I was typing the wrong IP address). Anyone know why this doesn’t work with smb: anymore? Did SUSE change the way this works?

Seems there’s sth wrong with the new samba-client and libsmbclient0.
try degrade them using package inIndex of /repositories/network:/samba:/STABLE/openSUSE_11.0/i586

I am running in to this exact same problem. smb:// syntax works great in openSuse 10.3/KDE3, fails in 11.0/KDE3, with the odd symptom of the missing final character of the filename. I found that mount.cifs and the newer smb4k command work fine, so I am not running back to 10.3. But, strange behavior; and a real time-waster to troubleshoot.

I Have the same problem when trying to reach a windows share using Dolphin on KDE4

I can also confirm this, using the Dolphin/Konqueror with KDE 4.x displays this error message when displaying a folder/file on a Samba share with an internation character/s in the name of that file/folder. It prevents viewing/copying of that file.

It seems to be an issue with either Konqueror/Dolphin or Samba (more likely the KDE4 apps since if it was Samba then using the mount would not work) not recognising the cifs characters. I have reported the bug to Novell’s Bugzilla so hopefully it will be fixed soon :stuck_out_tongue:

I have a very similar situation. In openSUSE 10.3 and previous, I had to use the smb4k to get my Buffalo NAS drive to mount in order to work with the files as if it was a local drive. This has always worked fine.

I switched to openSUSE 11, with KDE4. I have attempted all the processes as mentioned above. None appear to be working. In smb4k I can see the share folders via the search and browser, but they refuse to mount. I’ve tried configuring the mounts manually via smb4k, with no luck.

What’s even more strange, is that this only is a problem on my laptop - my desktop machine mounts the shares without any issues, and is using the 2.3.2-0 version (not the 2.3.2-1.1 that has been recommended as an degrade). All the setting in smk4k are the same except that the laptop doesn’t auto remount. I use the laptop for work as well, which has a different NAS drive set-up.

Any ideas? And any help would be great. Thanks.


I have the same nas device in the OP and I can connect.

Here is the relevant line from my /etc/fstab:

// /media/nas1 cifs username=guest,password=password 0 0

make sure you have cifs/samba etc etc installed

I seem to recall we could use “smb” not “cifs” in suse 10.3.

Good Luck

I recently installed openSUSE but experienced the same problem on last release of Ubuntu – i.e. could access password protected share through mnt command but not authenticate via file browser popup. It has since been corrected there. I believe the error was in a library module.

Arrgh. I have this same problem. Just upgaded from 10.3 to 11.0 and now my backup program (BackupPC) doesn’t work because it is unable to use smbclient to get files from other machine being backed up. The last character of every file name gets dropped.

There are no special characters or long names involved here. It is just broken.

I updated to the latest 3.2.4 in the hopes of a fix, but no luck. I did find one reference elsewhere to this being introduced in 3.0.28. Anyone know where I can get an rpm for a release older than that to try it out?

Or does anyone have a fix/workaround for this really annoying problem?


I have just solved this problem (ugly problem) with this workaround:

Go to YaST2 Control Center/Network Services/Windows domains (or something like that… I have the spanish version…)

I accepted the default configuration (no checks marked), inserted the domain name (default name WORKGROUP), clicked on Finish button and then, a 32bit library regarding with samba was installed (my architecture is x86_64 but…)

Now, smb client on Konkeror works fine! I can access to a smb device in the same way that in OpenSuse 10.3 (smb://host/shared-folder) !! Uffff!!!

Hope this helps!

Sorry, sorry, sorry… the problem is still here.
It was an initial impression… I apologize for the previous post.

I have the same problem, SAMBA worked fine in SUSE 10.3, but has problems in 11.x

Essentially I can see my Linux files from all of my Windows machines (5 of them), but cannot see any Windows files using SMB:// or dolphin “Samba shares”.

I have tried the troubleshooting steps (including the above suggestions), and all update releases have been applied.

I can access the Internet fine (obviously :slight_smile: ), but cannot ping the DHCP names of any Windows machine (e.g. “ping platinum”).

Ping works fine using the IP address (e.g. “ping”), and Internet domains (e.g. “ping”).

This is a showstopper for me since I need to integrate my Linux machine into the LAN to continue my Windows -> Linux migration.

BTW - SO FAR XP to SUSE Linux hassles have proven to be far less than XP to Vista hassles!

I am a Linux novice, but have an extensive computer/CAD/UNIX/Windows background.

I have a D-link DNS-323, not the NSLU2; but I experienced the same odd behavior wrt OpenSuSE 10.3 vs 11.0. Maybe my fix will help you too. The DNS-323 has a nice escape mechanism, whereby it will let you run anything via its “fun_plug” file. A small community has grown around this feature, but fonz of Index of /dns323/fun-plug/ is the acknowledged gatekeeper.

I had used fonz’s fun_plug stuff successfully. I was a bit lax in my software upgrades; I had fallen a year behind. So, I thought that an upgrade to my primary packages would upgrade the samba server code (was 2.2). It did not; nor did the extended “package” download–contrary to various posters’ claims.
But, with a bit of searching, a samba 3.2 package was available. Install went fine. All new files are treed off of a /ffp directory, so prior start and .conf file paths must be edited. But all changed are obvious. The suggested example samba.conf file was way overkill for my simple setup–even the pre-existing samba.conf worked fine when it was trimmed of excess stuff, like printer info, that I was not using on the NAS.

Restarting the samba server on the DNS-323, and waiting a few minutes, did the trick. From OpenSuSE 11.0 KDE3, I now browse to the smb files properly, and quite promptly, too.

The original problem probably stems from permissions inconsistencies (although the off-by-one filename detail implies a buffer size issue as well). Whatever, the new samba server on my NAS box is talking to SuSE just fine now.

The domain name resolution on your lan requires that you edit your /etc/hosts file. that is trivial compared to making samba happy. Try Samba and Suse Swerdna’s pages are extremely useful…

One small point in the grand scheme of things is never forget to use smbpasswd -a. Setting a samba password is somehow a necessary step.

mkather wrote:
> Hi, I have similar problems towards SuSE 7.0. There is a new Samba
> version in SuSE 11, it’s just not fully tested,
> alpa-version at most. Forget about it and go back to SuSE 10.2

10.2 is discontinued, do not use.