smb nautilus browsing problem in openSUSE 11.0

Problem 1.
Nautilus mounts some smb shares as WRITE ONLY.
ie it shows 0 files on the share but will let you copy files to the share (right after copy it disappears but windows client can see and read the copied file).

Problem 2.
Browsing windows networks only works with the firewall down, what services needs to be allowed through the firewall for windows browsing to work?


For Samba and SuSEfirewall2 I found it necessary to open TCP ports 135, 139 and 445 and also UDP ports 137 and 138, and I also needed to define a trusted network in terms of IP addresses. Try that.
FFI: Configure SuSEfirewall2 for Samba

Then try the write-only problem again – but also as a diagnostic aid turn off the windows firewall temporarily, including any third party firewalls like zone alarm etc.


Hi Jens,

That’s strange… I’ve not had these issues so far and been using openSUSE 11 for a couple of months now (starting with the betas).

My firewall is up and running without extra ports opened.
The only thing I have to do when browsing the network and attaching to a Windows server that does not offer shares, is add /C$ (or respective drive letter) to the servers address.

Could be you are getting write only access due to user name cached passwords or logging in with your current credentials?


Very interesting, so just out of interest, what do you have open in SuSEfirewall2 for the entries at FW_SERVICES_EXT_TCP and FW_SERVICES_EXT_UDP in Yast at:
Yast → System → /etc/sysconfig Editor → Network → firewall → SuSEfirewall2 → FW_SERVICES_EXT_TCP and FW_SERVICES_EXT_UDP. I’d like to know because there may be some new thing going on in version 11 compared to 10.3.


Hi Swerdna I’m not sure if it is me you are asking but here it is:

FW_SERVICES_EXT_TCP: domain microsoft-ds netbios-ssn 135 139 445
FW_SERVICES_EXT_UDP: domain netbios-dgm netbios-ns 137 138

I added the portnumbers as a result of your post and it did have a positive result on the browsing.

But no change on the WRITE ONLY share. The share is a global completely open share (no authentication) only used as a scratchpad on the network. Just tested again with Ubuntu Hardy and it has no problem seeing, reading or writing to the share, likewise for windows or openSUSE 10.3.
Also it cannot be a cache of authentication problem since on my first attempt to access the share I had never authenticated anything on the network (After I had authenticated on other machines it still does not work).


Hi Jens, my question was meant for Magic31, but thanks for the extra info in your reply.

Forgive me but I’m getting a bit confused. Please clarify: Talking about computers, you’ve got a LAn with a Ssue, a windows and a/an Ubuntu computer, is that right? This share that’s problematic for Suse, but not for Ubuntu or Windows, which computer is it on – Suse?


Hi Swerdna

Yes I got WIN-XP, WIN2K, Ubuntu Hardy, openSUSE 10.3 and 11.0.

only the openSUSE 11.0 has problems accessing the share.

the share is on a planex router (running I think BSD of some flavor but I may be wrong) without authentication.


On a planex router… Hmmm…I can’t see anything obvious in that.
Can you post Suse’s Samba configuration file, might be something there. It’s the file /etc/samba/smb.conf.


Hi Swerdna,

I’ve checked the settings you mentioned, and they are all blank.
To add I’m referring to accessing a Windows share from my Linux station, so I would think the firewall should not block that seeing I’m initiating it.

My wireless connection is set to ‘external zone’ and my LAN is set to ‘internal zone’ (as I already have two firewalls protecting me on my LAN). Using both interfaces give me no trouble accessing smb shares.

As an extra note, I’m the GNOME user :wink:

One thing I have noticed that has changed in regard to 10.3. When I ‘make’ a smb connection it gets mounted on my desktop (and in Nautilus) & stays there until I unmount it (even if I change networks). It is a nice feature but results in some brief ‘hangs’ when opening Nautilus when the smb share is not accessible.
Just something to keep in mind if you experience it too.

If there is additional configuration info you would like let me know.


Thanks for that. I understand why no problem from the openSUSE firewall – You get your protection as you say from a more global firewall around the whole lan, I think.

this is true for the LAN, but my Wifi connection does ‘enjoy’ the full SuSEfirewall benefits…

I’ll do some more tests tomorrow and let you know.

Hi Swerdna

Here comes:

smb.conf is the main Samba configuration file. You find a full commented

version at /usr/share/doc/packages/samba/examples/smb.conf.SUSE if the

samba-doc package is installed.

Date: 2008-06-06

workgroup = ICJACOBSEN
printing = cups
printcap name = cups
printcap cache time = 750
cups options = raw
map to guest = Bad User
include = /etc/samba/dhcp.conf
logon path = \%L\profiles.msprofile
logon home = \%L%U.9xprofile
logon drive = P:
usershare allow guests = Yes
add machine script = /usr/sbin/useradd -c Machine -d /var/lib/nobody -s /bin/false %m$
domain logons = No
domain master = No
netbios name = OPENSUSE11
passdb backend = smbpasswd
security = domain
usershare max shares = 100
wins support = Yes
idmap gid = 10000-20000
idmap uid = 10000-20000
comment = Home Directories
valid users = %S, %D%w%S
browseable = No
read only = No
inherit acls = Yes
comment = Network Profiles Service
path = %H
read only = No
store dos attributes = Yes
create mask = 0600
directory mask = 0700
comment = All users
path = /home
read only = No
inherit acls = Yes
veto files = /aquota.user/groups/shares/
comment = All groups
path = /home/groups
read only = No
inherit acls = Yes
comment = All Printers
path = /var/tmp
printable = Yes
create mask = 0600
browseable = No
comment = Printer Drivers
path = /var/lib/samba/drivers
write list = @ntadmin root
force group = ntadmin
create mask = 0664
directory mask = 0775

Share disabled by YaST


NB! I tried “wins support = Yes” and “wins support = No”
but I do not think it is samba that is making trouble since all other shares (on windows machines or other linux machines) can be accessed as always.
Also I do not think it is a security problem since it will let me write to the share without asking for any login.
Also I added GNOME::STABLE repo from the build service and updated and still the same “write only” behavior.


It’s probably worth editing out the lines
security = domain
wins support = yes

or put a hash mark # in front of them to turn them off

When finished restart samba with these commands issued as root:
rcnmb restart
rcsmb restart

Might help; in any event they’re wrong unless you have a domain server and a wins server operating somewhere in the LAN.

Hi Swerdna
Tried it but it had no effect (however I suspected that already before trying), I do actually have a domain controller and wins server but is is only active some of the time and it does not normally give any problems when they are not active.
So status is the same as before: a write only share.
I have a strong feeling that there is something murky in the networking of the system


Hi Jens,

To clarify: Are you talking about browsing to smb shares from your linux workstation, or setting up your Linux workstation as smb server?

If the last is the case have you tried doing the initial samba configuration through YaST > Samba Server?
This should set you basic configuration right including the firewall settings.
After configuring with YaST > Samba Server you could further configure manually where needed.

Just a thought…

Hi, I followed your howto instructions to set up my simple home networking in OS11 as I had success with your help to have it working in OS10.3.
Everything works fine in OS11. I have access from my 3 other work stations to shared resources on OS11. From this I can access others by issuing IP address. However, my dilema is that when I open up the network folder and click on samba shares, I get “could not connect to smb-network” message. Although I have my workgroup name properly assigned, firing up the samba shares folder never lists my work group name and always gives the mentioned error message in the status bar.
Could you help please?
Thanks in advance.

Could you please advise?

P. S. In os 10.3 opennig samba shares in network folder alwayes lists the work group name.

I didn’t expect it to work either – long shot. And I didn’t realise the domain aspect either. Don’t really have any more ideas for the planex share. :confused:

Be well

Sure, but could you make a new thread. This one already has 18 posts on a different issue. very confusing otherwise. And in that new thread, post your smb.conf, desktop environment and network browser type too. Cheers.

Hi Swerdna

FYI I have tried the following:

  • Down Firewall: No
  • Down AppArmor: No
  • Reinstall openSUSE 11.0 : No
  • Install sbm4K to see if it was Nautilus that had a problem: No
  • Use a samba config file that is known to work on a Ubuntu Hardy install: No

And the problem is more pervasive than first observed, there are a number of shares that show up as “WRITE ONLY”.

And just to reiterate: Above shares works completely normal with openSUSE 10.3 and Ubuntu Hardy.

I hope you can help me find a solution or that someone else can?


This is intriguing if other shares have that problem. Let’s press on for a bit.

Please describe one of the shares that has that problem in terms of it’s definition file in smb.conf in the machine it’s in, and maybe the whole smb.conf for that machine, and what’s the O/S so I can maybe simulate it (I’ve got Hardy running if it’s Hardy).

openSUSE 11.0: I can’t get Samba to work properly in KDE4. It works fine in KDE3.5 and I haven’t tried Gnome. I am installing it on a test machine now – so I’ll check Samba on Gnome – You menioned Nautilus so pls conform your using Gnome.

I won’t have Gnome ready until tomorrow, it’s getting late here now.