smb doesn't show workgroup

Starting yesterday, I assume after some update, smb, or maybe kio_smb, started misbehaving.

Perviously, when entering “smb:/” into the address bar of Dolphin, I would get an icon with the name of the workgroup, which I could then click on and see the other computers in the workgroup.

Now, when I enter “smb:/”, an empty window appears.

If I enter “smb://[computer name]”, the shared folders in [computer name] appear and I can access them normally.

But it would be nice to be able to see all the computers in the workgroup at once.

Is this a bug in an updated version of smb, or is there something I can fix?

If necessary, I can supply my “smb.conf” file, but nothing has changed between when it worked and now.

I suppose it would help to know what updates exactly you installed, and from what repo.

There was no official update at all for kio_smb in Leap 42.3 so far, and the last update to samba was end of November/beginning of December…

See the Extra->History menu item in YaST->Software Management, /var/log/zypp/history, or run “rpm -qa --last” (which will list all installed packages ordered by installation/update time).

Now, when I enter “smb:/”, an empty window appears.

If I enter “smb://[computer name]”, the shared folders in [computer name] appear and I can access them normally.

Might be a network “problem” too I suppose, or on (one of) the other hosts.
SMB is not really a reliable protocol IME, especially when it comes down to list all hosts in the network…

Maybe run smbtree and see if that lists the other hosts.
If not, it’s definitely unrelated to KDE/Dolphin/kio_smb, and the error message you might get may help to provide a clue what’s wrong too.

PS: the major recent updates were the security fixes for the SPECTRE and MELTDOWN vulnerabilities, and they did cause problems on some system (like applications crashing or even whole system freezes).

So maybe try to boot an older kernel (4.4.103 or lower) too, by choosing “Advanced Options” in the boot menu.
Although I doubt that they could cause a problem like you describe, but who knows… (it’s easy to try anyway)

I just tried this on my TW system and too get the blank window using SMB:/ (which incidentally changes to SMB://). I ran smbtree and it lists the workgroup and hosts OK. I wonder if this is related to the bug which causes SMB4K to fail to list the hosts? Bug is


A few easy checks:

Check that you have the lines in [GLOBAL] that define workgroup, netbios name, and (I suppose) server string.
Check that nmb and smb daemons are still running e.g. command line:

systemctl status nmb.service

and same for smb
And does this define text version for the three levels beginning with workgroup:

smbtree -N

From a quick look at the source code, kio_smb seems to only use functions from libsmbclient and not run “net rap” or similar, but it might still be related.

But, the OP uses 42.3 according to the subject. And it worked for him until 2 days ago.
And it does work fine here on my fully up-to-date 42.3 system (I’m using the latest kio-extras5 17.12.0 from additional repos though).

I had these sorts of bad behaviour in the early days of leap 42.3 but it sorted itself and behaved after a month or so. I haven’t had problems since. And just to be sure I ran a Yast-based upgrade of RPMs just to catch any immediate changes, no problems. So maybe your TW problem is a TW problem, perhaps different from evetsnameloc’s 42.3

PS, @broadstairs: Did you actually try the testing packages you were offered already?
That bugreport is in NEEDINFO state since October, they are waiting for a report about your results it seems… :wink:

Thanks for all the replies.

Trying to pin down the problem some more — I installed Leap 42.3 from the original installation files onto an unused partition. Before doing any updates I tried “smb:/” and it displayed the workgroup icon in the dolphin window as it did before.

I then went to yast and updated the smb files to their latest versions, and surprisingly “smb:/” still worked. So it appears that the problem is not with smb but with some other packages that have been updated as well.

Without going through and updating packages one-by-one, I have no idea how to trace the problem further.

Just to clarify things that I didn’t mention in the first post, this all involves Windows shares, some on a Windows 10 installation, some on Windows 7.

I don’t know if this helps any, but I also have a Windows 7 virtual machine (vmware) installed on Leap 42.3. When I open “Network” in the VM, all the computers in the workgroup appear normally.

No I only just noticed that when I went looking for the bug #, must have missed it somehow. I’ll take a look this week and see if I can try the fix out.


Well, I just finished a complete update of my test installation of Leap 42.3. And smb:/ still works properly in dolphin. But it doesn’t in my main Leap 42.3.

So I’m stumped…

(Scratching the floorboards now)

One of the things when I am stumped:

rpm -qa samba

to get the versions. Are they same in both “test installation” and "main Leap?

Another thought: are “test installation” and “main Leap” both fresh installations or is one of them an upgrade from leap 42.2?

And some final thoughts:

Did you test that nmd is running as suggested earlier. If it is not running or it is broken then “smb:/” will likely not work in Dolphin but “smb://some_server” will likely work in Dolphin

And this hasn’t been discussed yet: have you set the firewalls the same in both? Should have setting of network interface to be “external zone” and allowed services should be set to “Netbios Server”, “Samba Client” and “Samba Server”, I should think particularly the first is the one in focus here.

Yes, check

systemctl status nmb

I appreciate all the interest and replies here.

Instead of racking my brain any further, though, I just reinstalled Leap 42.3 and went through all the updates. Thankfully, with a separate /home partition, it ends up not being a big deal. And, having done that, “smb:/” works fine, as does everything else.

So life is good again.

I have the same problem running openSUSE Leap 15.0.
Dolphin doesn’t show the workgroup, but I’m able to navigate the net via the “smb://” command (it works with both the IP address or the name of the computer).
Any news?

It’s a well-known issue. Described well here…

There is an ‘ugly’ workaround available if you really want to get samba network discovery working in Dolphin again…

"Browsing" network lead to an empty folder

Despite a working and well configured samba, browsing network for Windows shares using a gvfs-based file manager (Nautilus, PCManFM, and others) it does only get an empty folder. With samba 4.7 are changed the default protocols and this seems to cause problems with browsers. For a temporary workaround you can add the following parameter in the smb.conf configuration file:
/etc/samba/smb.conf …

  client max protocol = NT1

Thanks deano! rotfl!
The issue has been solved!
Will this problem be resolved upstream?

It’s only a workaround. See this post where I linked to some bug reports concerning this.

Firewall settings?

Given that, you’re still running “SuSEfirewall2” on your Leap 42.3 system and haven’t moved to the Leap 15 “Firewalld” (with it’s default Profile of “Public”) …