smb and nmb start on opensuse 10.3

Is there any way to start both of them with a single script?
I don’t want to write my own custom script.

Starting smb (/etc/init.d/smb start), only starts smb (not nmb), althought the smb script says it should start nmb as well.

thanks.

Just enable nmb to start at boot. Use YaST or

chkconfig --set nmb on
 bash# chkconfig --set nmb on && /etc/init.d/smb stop && /etc/init.d/smb start && pgrep nmb 

shows nothing.

 bash# /etc/init.d/nmb start && pgrep nmb 

shows nmb started.

Yast is not an option. I am taking this cannot be from CLI on SUSE. Thanks.

The two services are separate. I only showed you how to enable nmb to start at boot. That’s all that is necessary. Starting smb at boot doesn’t start nmb. Either the comment is wrong, or it’s a bug you should report. But making nmb start at boot is all you really need, not to link the two services.