SmartControl error

Hey Malcolm, I installed your repo:

http://download.opensuse.org/repositories/home:/malcolmlewis:/Gnome/openSUSE_12.3/

And installed gsmartcontrol.

I get this error when I run the command gsmartcontrol:

Fontconfig warning: "/etc/fonts/conf.d/56-user.conf", line 9: reading configurations from ~/.fonts.conf is deprecated.
<error> [hz] Error: gspawn: Failed to execute child process "smartctl" (No such file or directory)
<error> [app] bool CmdexSync::execute(): cmdex_.execute() failed.

How shall I fix it?

Thanks
John

I think i saw many threads with this problem of “reading from” and deletion of

~/.fonts.conf
usually solved the issue.
There is not ~/.font.conf on my clean opeSUSE 12.3 installation.

I take out the cause of the warning, as you suggest, but still the error message about failure to locate smartctl binary persists

Ah… but if I run command:

su -c gsmartcontrol

it works just fine

i was thinking you were running it as “root” user because whenever i launch it from “Activities” in GNOME 3.x it asks me for password.
i use the package from “enzokiel”

On Sat 25 May 2013 07:36:02 AM CDT, swerdna wrote:

How shall I fix it?

Thanks
John

Hi
Yes you need to run either gsmartcontrol-root from the CLI or use the
menu icon :wink:

Smart doesn’t like running as non root, you could always add smartctl
to your sodoers?


Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 12.3 (x86_64) Kernel 3.7.10-1.4-desktop
up 23:32, 3 users, load average: 0.15, 0.17, 0.21
CPU AMD Athlon™ II P360@2.30GHz | GPU Mobility Radeon HD 4200

Thanks

(at first I couldn’t find the menu icon, so I ran the cli, and neglected the root. all good now)