smart upgrade conflict

I am trying to upgrade my suse 10.2 today through smart. I get the following files to download:
Upgrading packages (7):

Downgrading packages (1):
2.2MB of package files are needed. 41.9kB will be used.

Confirm changes? (Y/n): y

When I confirm I get the error:
error: file /usr/lib/ from install of conflicts with file from package

I tried to remove but I get the same error as smart tries to downgrade to

How can I correct this?

Try renaming that file and retry the update:

mv /usr/lib/ /usr/lib/

I stumbled over the same issue and solved it this way:

r50e-ms:~ # rpm --test --force --install ‘/var/lib/smart/packages/’
r50e-ms:~ #
r50e-ms:~ #
r50e-ms:~ # rpm --force --install ‘/var/lib/smart/packages/’
r50e-ms:~ #

Cryovac - I tried your suggestion but no luck. After reading the error again it looks like it’s telling me that is interfering with a file from the previous install of the package, but it doesn’t seem to tell me what file from that package is causing the conflict.

MonikaSchilling - I tried your suggestion and it seemed to work. I was thinking of forcing the install before I posted but didn’t want to --force the issue before getting some feedback first.

Thanks to both of you for getting back to me.