Sluggish kde after upgrade

Dear all,
I was using opensuse kde 11.3 for almost one year.
My system is a four-core system and so far was really fast.

After upgrading from 11.3 to 11.4 I have noticed that kde(?) is running slow. I can pinpoint exactly the source of the problem but just a few examples.

  1. Dolphin takes so much time to load (15 seconds)
  2. When I try to do something inside dolphin (like Edit->copy) can take up to 15 seconds to see the menu to appear.
  3. Double clicking inside a catalog can take up to 5 seconds

I have same kind of problems with Gwenview.

I can not say precisely blame kde, dolphin or gwenview.

-----> I would like to ask your help how can I find what’s the problem (any cli command, any log file to check?)

I have updates to latest opensuse 11.4 by using the documentation I found in official opensuse forumes. (Changed the repositories from 11.3 to 11.4)

I would like to thank you in advance for your help

Best Regards

look at ksysguard and are any processes spiking at these times?
also run iotop in konsole (may need to dl) to see if there’s something spiking i/o

my guess Nepomuk/Strigi or possibly some kind of thumbnail generation - try disabling Nepomuk & Strigi in systemsettings

Disabled the thumbnails. Did not help much (if not at all). I do not have iotop (I will have to download).
I made this post also to add that the file->save dialog box takes so much time to appear.


do you have lots of dbus calls in ksysguard? Slow startup with Dolphin, file chooser dialogs, gwenview • KDE Community Forums

does this behavior happen for a new user?

there is the commonality of places in both gwenview and dolphin, is there something unique in any of your places links?

Just to update this
I checked ksysguard and could not see any process spiking.

I installed iotop and
when I wrote dolphin in konsole the followint entry appeared
7571 be/4 apa 7.74 K/s 0.00 B/s 0.00 % 0.29 % kdeinit4: dolphin [kdeinit] -icon system-~nts/Documents-/measur

which was not always the highest top priority process.
I also disabled the services you told me but did not fix anything.
I will also try out what the other user suggested and I will post back again.


Just to update something:
After the upgrade even the shutdown button from kde works.
I found on the internet that one can from command line to ask the kde to turn off by using
usr/bin/qdbus org.kde.ksmserver /KSMServer logout 1 0-1 -1


qdbus org.kde.ksmserver /KSMServer org.kde.KSMServerInterface.logout 1 -1-1 -1

this command.
I tried both no error received and did not happen anything. (Write now I write this text after having issued the two commands above)!

What should I also do for that?

Some more updates:
when I tried to launch konqueror from konsole
received the following

ap@s:~/Documents/hiasCode> konqueror .
konqueror(7532)/kdeui (kdelibs): Attempt to use QAction “dolphin” with KXMLGUIFactory!
konqueror(7532)/kdeui (kdelibs): Attempt to use QAction “gwenview” with KXMLGUIFactory!
konqueror(7532)/kdeui (kdelibs): Attempt to use QAction “” with KXMLGUIFactory!
Advanced probing on /dev/sr0 failed while reading block size

Do not you think that this might be a good starting point?


Applications > System> Monitor> Process manager. Do you see any overly redundant processes?
I had like 47 “alonadi_contact” ones. After correcting this KDE is snappier, mostly in regards to the bootup.

Unfortunately not :frowning:
I was thinking that the problem might my kdelibs. Do not you think that I should try to upgrade or downgrade kde?
Right now I feel like having a poor performing system .

What other more drastic can I try out?


create and login as a new user, does the slowness persist?

since it only affects 2 apps you could move or remove your dolphin and gwenview config files and folders ~/.kde4/share/apps/dolphi* ~/.kde4/share/apps/gwenview ~/share/.kde4/config/dolphinrc ~/.kde4/share/config/gwenviewrc

I still wander about your places - is there anything funky there? that might be ~/.kde4/share/apps/kfileplaces/ possibly close dolphin and grenview and rename it

Tried this also. It is also slow for the new user.
In opensuse 11.4 when you create a new user and log in the first thing you see in the up left corner is the desktop view of a folder.
Even the contents of that folder take time to appear.
I have also noticed that also other ‘functionalities’ that take time to load at start-up.

For example alt+f2 dialog takes some time to appear. It takes also time to find the application (amarok) and time to respond after I press enter. This was once upon a time a really fast and steady process.

It also takes a lot of time to log out (if it does not stuck).

Thus I believe that there is something problem with the “core” of the kde. Might be some wrongly updated library version?
I would like to ask you to suggest me a more ‘drastic’ way to fix that. Can I downgrade my kde to the previous version . Is that safe to try it out , how I can do that?


you could upgrade to 4.6.2, it should be available soon - 4.6.1 is available now in the 46 repository (but it will change to 4.6.2 when it is ready). I’m not sure that anything less than 4.6.0 is available for 11.4

KDE repositories - openSUSE
SDB:Vendor change update - openSUSE

you could also reinstall all your current KDE rpm’s within Yast sw manager using in the repository tab: right click -> all in list -> update unconditionally if you think the problem is corruption in the core libraries

Hello again:)
Could you please explain me the process for updating to 4.6.1. Might be the best idea to get rid of this sluginess.

Best Regards

from SDB:KDE upgrade - openSUSE

Upgrade to Latest Release from Upstream KDE

Follow these steps to upgrade to the latest KDE.
Warning This is an unsupported upgrade involving the use of a moving and barely tested repository.

First add the KDE:Release:46 repository. Replace 11.4 with your openSUSE version:
zypper ar -f Index of /repositories/KDE:/Release:/46/openSUSE_11.4 KR46

Now upgrade the packages:
zypper dup --from KR46

note: if you use playground you would need to do that repo also

Extra Repository (optional)

If you use the KDE:Extra repository, remove the old instance of that: (replace 11.4 with your openSUSE version)
zypper rr Index of /repositories/KDE:/Extra/openSUSE_11.4

Now add the instance built for KDE:Release:46 instead:
zypper ar -f Index of /repositories/KDE:/Extra/KDE_Release_46_openSUSE_11.4 KR46-extra

Then upgrade the packages:
zypper dup --from KR46-extra

Just to give you feed back as it is really important
After upgrading problem is fixed. Can someone edit the title and add the [solved] word at the beginning?
Thank you very much all of you for your support!

Happy to have my kde back!