Slower internet in Leap 15

I have a brand new Ryzen 5 1600 with 32Gb DDR 4 running dual boot with OpenSUSE Leap 15 and Windows 10. I get 100Mbps consistently in Windows 10 but can’t get over 60MBps in OpenSUSE. It averages around 40MBps. Every other system also gets around 100MBps.

So far I have turned on auto negotiation. That was disabled for some reason. I have tried both tumbleweed and leap 15 with the same results. I’ve also connected another computer to the exact same switch so I know it’s not the network or the cabling. I can also boot into Windows 10 and get 100MBps on the same system. I’ve also tried disabling network manager and configuring the network through yast with exactly the same results. I would prefer to use network manager but at this point just want my network to run at the same speed as all my other computers.

All the speed tests are done in chrome on from all the computers.

Have you tried conducting a performance test within your LAN environment using iperf (or similar)?

Network hardware details?

/usr/sbin/hwinfo --netcard

Maybe share the ethtool output as well. Assuming eth0 do…

/usr/sbin/ethtool eth0

Are you using “wicked” or are you using “NetworkManager” to manage the network?

Whichever you are using, try switching to the other to see if that helps. Use Yast Network Settings for that change.

BTW, here’s how netcat can be used to test network speed…

Hardware details

 25: PCI 400.0: 0200 Ethernet controller                         
  [Created at pci.386]
  Unique ID: rBUF.eyqrN5GWcA7
  Parent ID: GA8e.8EPKPINKVS0
  SysFS ID: /devices/pci0000:00/0000:00:01.3/0000:01:00.2/0000:02:01.0/0000:04:00.0
  SysFS BusID: 0000:04:00.0
  Hardware Class: network
  Model: "Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller"
  Vendor: pci 0x10ec "Realtek Semiconductor Co., Ltd."
  Device: pci 0x8168 "RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller"
  SubVendor: pci 0x1043 "ASUSTeK Computer Inc."
  SubDevice: pci 0x8677 
  Revision: 0x15
  Driver: "r8169"
  Driver Modules: "r8169"
  Device File: eth0
  I/O Ports: 0xf000-0xffff (rw)
  Memory Range: 0xf6504000-0xf6504fff (rw,non-prefetchable)
  Memory Range: 0xf6500000-0xf6503fff (rw,non-prefetchable)
  IRQ: 318 (675873 events)
  HW Address: 04:92:26:d7:cc:f7
  Permanent HW Address: 04:92:26:d7:cc:f7
  Link detected: yes
  Module Alias: "pci:v000010ECd00008168sv00001043sd00008677bc02sc00i00"
  Driver Info #0:
    Driver Status: r8169 is active
    Driver Activation Cmd: "modprobe r8169"
  Config Status: cfg=no, avail=yes, need=no, active=unknown
  Attached to: #24 (PCI bridge)


Settings for eth0:
        Supported ports:  TP MII ]
        Supported link modes:   10baseT/Half 10baseT/Full 
                                100baseT/Half 100baseT/Full 
                                1000baseT/Half 1000baseT/Full 
        Supported pause frame use: No
        Supports auto-negotiation: Yes
        Advertised link modes:  10baseT/Half 10baseT/Full 
                                100baseT/Half 100baseT/Full 
        Advertised pause frame use: Symmetric Receive-only
        Advertised auto-negotiation: Yes
        Link partner advertised link modes:  10baseT/Half 10baseT/Full 
                                             100baseT/Half 100baseT/Full 
        Link partner advertised pause frame use: Symmetric
        Link partner advertised auto-negotiation: Yes
        Speed: 1000Mb/s
        Duplex: Full
        Port: MII
        PHYAD: 0
        Transceiver: internal
        Auto-negotiation: on
        Supports Wake-on: pumbg
        Wake-on: g
        Current message level: 0x00000033 (51)
                               drv probe ifdown ifup
        Link detected: yes

Just tried. No change.

Unfortunately I don’t have another system available at the moment. However I do know I can rsync to my Nas at over 100MB/s. However that’s going to be limited by the NASs ability to write to the drives.

Well that would eliminate the network interface as a cause of your issue. The trouble with internet-based testing is that the public network path and internet server load can impact and so make many tests rather subjective.

I can do a speed test from any other computer on the network and get 100MBps but this one can only do 40-60MBps. I can reboot this system into Windows 10 and also get 100MBps. I’m pretty confident it’s a software issue.

I agree with deano_ferrari. If you can rsync at 100Mb/sec locally, the issue is not the network interface, since it does do the 100Mb/sec.

There may well be other factors at play here, depending on the type of tests you’re conducting. When you’re next running an internet speed test, examine CPU and memory load via the ‘top’ command and perhaps run iostat as well eg ‘watch iostat’. You may need to install sysstat first.

I agree. It has something specific to do with internet traffic. I honestly can’t figure it out. That why I came here hopping someone else has experienced something similar.

The following guide is really aimed at those running servers (and not something that a general desktop user would normally need to investigate IMHO), but it may be of interest to you perhaps…

Memory during the text is about 13% used, plenty of free memory, and CPU is around 10-15%.

I just tried Firefox instead of chrome and I am getting better speeds. About 80MBps.

It looks like this might be a chrome issue.

If it’s a browser-based test you’re doing, try with another browser. More info could be useful here.

Our posts crossed - that is the kind of thing you need to be doing in order to prevent incorrect conclusions. :wink:

You might want to look at atop (and also netatop and it’s respective kmp), give much more detail…

It’s bizarre. All the other systems are using chrome to with the same configuration. I’m using Google sync on all of them.

Just disabled all my extensions in chrome and got the same results. No clue where to go from here. However, it does give me a better idea of what to search for. Maybe chrome for Linux has some bug that isn’t effecting windows.