Slow uploadrate

Hello there,

I’ve recently installed OpenSuse. I’m a *nix newbie but so far I like it a lot better than Ubuntu. I’m having several problems though and here’s one of them: I have cable and my upload rate is crawling here even though I have 512 kbps. I first realised when trying to upload a file and I saw it was not uploading. Then I tried to upload a video to YouTube and it produced an error. I was just trying to make a connection test but it was going really slow and eventually hanged.

I’m using the 64 bit OpenSuse version with a cable connection using a WiFi router. I would like to post more information about the wireless card but I’m afraid I’m not really sure how to do it.

Thanks for the hand.

Go to the following site and report back on your download and upload speeds. In fact, all information you are presented with, on this screen, would be good to know here. No need to include your location though. - The Global Broadband Speed Test

Thank You,

Ok, more info. This is the output for /sbin/ifconfig:

eth0      Link encap:Ethernet  HWaddr 88:AE:1D:CE:81:B5  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)

lo        Link encap:Local Loopback  
          inet addr:  Mask:
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:14 errors:0 dropped:0 overruns:0 frame:0
          TX packets:14 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:820 (820.0 b)  TX bytes:820 (820.0 b)

wlan0     Link encap:Ethernet  HWaddr C4:46:19:06:DF:18  
          inet addr:  Bcast:  Mask:
          inet6 addr: fe80::c646:19ff:fe06:df18/64 Scope:Link
          RX packets:153247 errors:0 dropped:0 overruns:0 frame:0
          TX packets:109487 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:127112285 (121.2 Mb)  TX bytes:16206329 (15.4 Mb)

Also, I’m using Gnome.

EDIT: Thanks jdmcdaniel3, I’ll do that in a minute and post the results.

Here are the results:](

Log into your modem and or router and get the following info.Upstream SNR, Upstream Transmit (TX), Upstream Receive (RX).
Also do a traceroute to a few servers.


I would suggest pathping, but there doesn’t seem to be a Linux equivalent to it.

This is weird, I logged on the modem and I can’t access that information. It says: “This feature has not been enabled in your cable modem. Please contact your data services provider for more information about this feature and its availability on the network.”

Here are a couple of results of traceroute:

traceroute to (, 30 hops max, 40 byte packets using UDP
 1 (  67.649 ms   78.408 ms   112.109 ms
 2  * * *
 3  * * *
 4  * * *
 5 (  448.139 ms (  473.718 ms   505.836 ms
 6  * * *
 7  * * *
 8 (  44.259 ms   75.367 ms   106.673 ms
 9 (  137.078 ms   167.742 ms   198.463 ms
10 (  239.964 ms   259.727 ms   291.439 ms
11 (  319.104 ms   349.232 ms   379.232 ms

traceroute to (, 30 hops max, 40 byte packets using UDP
 1 (  40.037 ms   68.001 ms   97.074 ms
 2  * * *
 3  * * *
 4  * * *
 5 (  387.191 ms (  417.164 ms   445.165 ms
 6  * * *
 7  * * *
 8 (  40.192 ms   70.185 ms   97.042 ms
 9 (  124.589 ms   152.981 ms   181.486 ms
10 (  209.015 ms   236.969 ms   265.801 ms
11 (  457.537 ms (  459.983 ms   487.285 ms
12 (  204.778 ms (  232.867 ms   259.948 ms
13 (  287.624 ms   302.486 ms   341.422 ms
14 (  368.444 ms   383.563 ms   410.453 ms
15 (  455.917 ms   498.724 ms   523.276 ms
16 (  549.659 ms   578.800 ms   602.107 ms
17  * * *
18  * * *
19  * * *
20  * * *
21  * * *
22  * * *
23  * * *
24  * * *
25  * * *
26  * * *
27  * * *
28  * * *
29  * * *
30  * * *

traceroute to (, 30 hops max, 40 byte packets using UDP
 1 (  44.693 ms   75.178 ms   106.759 ms
 2  * * *
 3  * * *
 4  * * *
 5 (  407.407 ms   435.803 ms   465.558 ms
 6 (  495.183 ms   524.227 ms   553.554 ms
 7 (  38.475 ms   75.505 ms   101.758 ms
 8 (  42.048 ms   71.136 ms   99.258 ms
 9 (  128.268 ms   156.124 ms   195.122 ms
10 (  350.546 ms (  369.053 ms   396.589 ms
11 (  434.335 ms   452.213 ms   478.927 ms
12 (  516.691 ms   536.194 ms   563.736 ms
13 (  591.353 ms   621.217 ms   644.349 ms
14  * * *
15  * * *
16 (  334.776 ms   363.836 ms   387.403 ms
17 (  431.046 ms   444.009 ms   466.751 ms
18 (  491.542 ms   1475.065 ms   1504.714 ms

Yes you do have an upload problem. IMO its your DNS server that’s causing the delay. You get to your gateway and then it dies when it should be less the 20 ms to the next hop.
Define your DNS nameservers on your router and not on your NICs.
Try OpenDNS or some other fast DNS Server.
Free Fast Public DNS Servers List

Hopefully, your ISP has not throttled your upload bandwidth but if you’re sure you are supposed to get 512 vs 384 upload then you should also call your ISP.

Thanks for your suggestions, I changed the DNS servers and the problem persists. I do not believe it’s the ISP’s fault because I’m getting normal rates at my Windows partition.

I’m starting to think it’s a firmware issue. I have a broadcom card and I’ve been reading about the broadcom-wl drivers that supposedly work good, yet I’m haven’t been able to make them work. They’re at packman repositories, I choose the one that’s right for my kernel (default) and then I reboot and I can’t connect to my router via wifi, in fact NetworkManager doesn’t appear to be detecting any networks. So I had to go back to the legacy drivers, so perhaps this is the cause.

So I don’t remember seeing your wireless hardware listed here, but here is popular link for bcm4312: - 802.11 Linux STA driver

Thank You,

I have seen that before but I’m not sure how to build it. If I write “make install” I get this:

install -D -m 755 wl.ko /lib/modules/uname -r/kernel/drivers/net/wireless/wl.ko
install: no se puede efectuar `stat’ sobre «wl.ko»: No existe el fichero o el directorio
make: *** [install] Error 1

It’s in Spanish, it means that it can’t find the wl.ko directory.

First off I did install this on my Dell Laptop and it worked like a champ. Second, you must READ and FOLLOW the instructions as given. If there is a portion of the ACTUAL installation procedure that does not work then ask about it and refer to the README document on that page. Since the term MAKE INSTALL is not in the readme file as something to do, perhaps that is why it does not work. Please read through the document one more time.

Readme file is here:

Thank You,

Ok, that was my bad, I was looking for instructions inside the tarball, not on the site. I managed to build and install the drivers and it didn’t worked. I uninstalled the ssb ones and I even follow the instructions to blacklist them (even though after I rebooted they were still there, but that’s another subject). I unloaded the drivers and loaded the wl ones, I could see them when using the command lsmod | grep “b43|ssb|wl”. Regardless NetworkManager didn’t scan for networks.

I should mention that this driver appears to be the same on the Packman repository which I have available to install via the “add/remove software” option, because that one didn’t works for me either. I don’t know what I’m doing wrong, I’m removing the legacy drivers and installing the correct one for my kernel (which is default), yet something is not working properly.

I have a script file called netinfo you might want to run. Here is where it is located. Read message #11 as it contains the most recent version.

netinfo - Read Network & PC Information into a Local Text File

You can run this script file and it will create a text file that includes a lot of information about your setup. Why not copy from it any network info you see about your wireless hardware and post it online for us to see.

Thank You,

Here is the log, I had to create a folder called “Documents” in order to make it work because I’m using OpenSUSE in Spanish:

This is the very same chipset that is in my Laptop that worked. So, I am going to suggest there is a missing step or something else that you are missing. So, I know that no one wants to look silly, but we are trying to help here. What I ask is that you open up a terminal session, do the steps one at a time and capture the output and post it online for us to see. You can blank anything personnel, as we don’t need to see it, but I want to see the system response to your commands. I never say never, but I feel certain that we can get you up and running AND it only takes one missed step, one error message you do not understand and it does not work.

Thank You,

Ok so here’s what I’m doing:

radiobuzz-pc:/home/radiobuzz/Downloads/hybrid-portsrc_x86_64-v5_100_82_38 # make clean
KBUILD_NOPEDANTIC=1 make -C /lib/modules/`uname -r`/build M=`pwd` clean
make[1]: se ingresa al directorio `/usr/src/linux-'
make -C ../../../linux- O=/usr/src/linux- clean
  CLEAN   /home/radiobuzz/Downloads/hybrid-portsrc_x86_64-v5_100_82_38/.tmp_versions
  CLEAN   /home/radiobuzz/Downloads/hybrid-portsrc_x86_64-v5_100_82_38/Module.symvers /home/radiobuzz/Downloads/hybrid-portsrc_x86_64-v5_100_82_38/modules.order
make[1]: se sale del directorio `/usr/src/linux-'
radiobuzz-pc:/home/radiobuzz/Downloads/hybrid-portsrc_x86_64-v5_100_82_38 # makeKBUILD_NOPEDANTIC=1 make -C /lib/modules/`uname -r`/build M=`pwd`
make[1]: se ingresa al directorio `/usr/src/linux-'
make -C ../../../linux- O=/usr/src/linux- 
  LD      /home/radiobuzz/Downloads/hybrid-portsrc_x86_64-v5_100_82_38/built-in.o
  CC [M]  /home/radiobuzz/Downloads/hybrid-portsrc_x86_64-v5_100_82_38/src/shared/linux_osl.o
  CC [M]  /home/radiobuzz/Downloads/hybrid-portsrc_x86_64-v5_100_82_38/src/wl/sys/wl_linux.o
  CC [M]  /home/radiobuzz/Downloads/hybrid-portsrc_x86_64-v5_100_82_38/src/wl/sys/wl_iw.o
  LD [M]  /home/radiobuzz/Downloads/hybrid-portsrc_x86_64-v5_100_82_38/wl.o
  Building modules, stage 2.
  MODPOST 1 modules
WARNING: modpost: missing MODULE_LICENSE() in /home/radiobuzz/Downloads/hybrid-portsrc_x86_64-v5_100_82_38/wl.o
see include/linux/module.h for more information
  CC      /home/radiobuzz/Downloads/hybrid-portsrc_x86_64-v5_100_82_38/wl.mod.o
  LD [M]  /home/radiobuzz/Downloads/hybrid-portsrc_x86_64-v5_100_82_38/wl.ko
make[1]: se sale del directorio `/usr/src/linux-'
radiobuzz-pc:/home/radiobuzz/Downloads/hybrid-portsrc_x86_64-v5_100_82_38 # lsmod  | grep "b43\|ssb\|wl"
b43                   205037  0 
mac80211              283974  1 b43
cfg80211              182051  2 b43,mac80211
ssb                    64697  1 b43
mmc_core               83419  2 b43,ssb
pcmcia                 66829  2 b43,ssb
radiobuzz-pc:/home/radiobuzz/Downloads/hybrid-portsrc_x86_64-v5_100_82_38 # rmmod b43
radiobuzz-pc:/home/radiobuzz/Downloads/hybrid-portsrc_x86_64-v5_100_82_38 # rmmod ssb
radiobuzz-pc:/home/radiobuzz/Downloads/hybrid-portsrc_x86_64-v5_100_82_38 # echo "blacklist ssb" >> /etc/modprobe.d/blacklist.conf
radiobuzz-pc:/home/radiobuzz/Downloads/hybrid-portsrc_x86_64-v5_100_82_38 # echo "blacklist b43" >> /etc/modprobe.d/blacklist.conf
radiobuzz-pc:/home/radiobuzz/Downloads/hybrid-portsrc_x86_64-v5_100_82_38 # modprobe lib80211
radiobuzz-pc:/home/radiobuzz/Downloads/hybrid-portsrc_x86_64-v5_100_82_38 # insmod wl.ko
radiobuzz-pc:/home/radiobuzz/Downloads/hybrid-portsrc_x86_64-v5_100_82_38 # lsmod  | grep "b43\|ssb\|wl"
wl                   2565141  0 
radiobuzz-pc:/home/radiobuzz/Downloads/hybrid-portsrc_x86_64-v5_100_82_38 # iwconfig
lo        no wireless extensions.

eth0      no wireless extensions.

eth1      IEEE 802.11bg  ESSID:""  
          Mode:Managed  Frequency:2.412 GHz  Access Point: Not-Associated   
          Bit Rate:54 Mb/s   Tx-Power:24 dBm   
          Retry min limit:7   RTS thr:off   Fragment thr:off
          Power Managementmode:All packets received
          Link Quality=5/5  Signal level=0 dBm  Noise level=0 dBm
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0
radiobuzz-pc:/home/radiobuzz/Downloads/hybrid-portsrc_x86_64-v5_100_82_38 # iwlist scanning
lo        Interface doesn't support scanning.

eth0      Interface doesn't support scanning.

eth1      No scan results

I did not see these commands in your script:

cp wl.ko /lib/modules/`uname -r`/kernel/drivers/net/wireless 
depmod -a
echo modeprobe wl >> /etc/rc.local  (Fedora/SUSE)

I would run YaST / Network Devices / Network Services and make sure you are set for ifup. You can do a scan while in this editor as well as enter your ssid and password.

Thank You,

Well, after changing to ifup I could choose wl from the drivers’ list but no network was detected. I entered my SSID manually with no results. NetworkManager didn’t show any networks either.

I was thinking in using ndiswrapper on the windows driver but first, I can’t seem to find it on Broadcom’s site, and also I have a question: should I remove the b43 driver before trying the Windows one? Is b43-fwcutter a necessary package?

Ok, I followed a tutorial to use the 64 bit XP version of the driver and that didn’t worked neither with NetworkManager nor ifup. The problem is the same, wlan0 is not present and the other interfaces are not wireless. Perhaps I should reinstall the system and see what happens.

EDIT: Reading the previous log I realise that I do get a wireless interface with broadcom-wl (eth1), the problem appears to be merely that it’s not scanning.