Slow transfers for external hard drive

I have SUSE 11.2 and one the things that I notice is that my 160GB WD My Book will not transfer any faster than about a 100kb/s. This is incredibly slow in comparison to when I use this same drive to transfer files on windows. With windows I could transfer several MB/s. My question is what configuration is causing it to slow down this much and how can it be fixed.

Someone else had this to say about the problem.

I have an external USB 2.0 hard drive (buslink) that seems to not be running at its fastest possible speed in Suse 9.1. When copying large files from the drive, I get a maximum throughput of only about 1 MB/s. I had the same problem in Suse 9.0, and I had apparently fixed it by adding the async option to the entry in my fstab file. With that option, I was then able to acheive transfer speeds of up to about 7 MB/s. This seems to be true of any USB hard drive I use. The problem is that since there is no entry in the fstab file for the usb hard drive because of the new subfs system, I can no longer easily add the async option. I tried editing the hotplug.subfs.functions file to add the async option manually in there, but when I do so, it seems to not
have the same effect as before (transfer speed is still slow).

So, I have a couple of questions. First, why are usb drives so slow by the default settings in suse, and is there another way of achieving trues USB 2.0 speeds without adding the async option. I have not seen another way of doing it. Second, if async is the only way to go, why is it that this option no longer seems to have an effect within the new subfs system? Is there something else that I am missing here? I would think this would be a major problem, but I seem to see very little
(nothing) posted about slow usb drives, so I kind of figure I am
doing something wrong here, but I can’t figure out what it is.

To me this seems like a wide spread and I am sure a lot of people other than myself could use help with this issue.

                       Thanks

Running 11.2 32bit with usb external 320GB Proforce USB 2.0 works at 3.4MB/s on files bigger than 1MB and 7.6MB/s on files smaller that 1MB these are readback speeds. Writing speeds to the external are 4.2MB/s and 7.9MB/s respectively.

So there is an apparent speed difference based on file size and direction.

I retested same drive under windows Vista and Read speeds varied 1MB/s to 2MB/s with no bearing on actual file size of transfer. Writing was a defierent story. Write file larger than 1 MB was 3.4MB/s steady, files smaller than 1MB varied widely from 100KB/s to 8MB/s .

dhcppc1:/home/gabriel # hdparm -t /dev/sda

/dev/sda:
 Timing buffered disk reads:  344 MB in  3.00 seconds = 114.51 MB/sec

This is from a Seagate 7200.11, internal though.

I read it in some post on these forums that you could try manually mounting the USB drive instead of using the auto-mount feature. i.e. try using something like: “mount -t ntfs /dev/usb0 /mnt/usb”

Use the manual (man command) if you are not familiar about mount command.

I never tried/used myself but it might work. Can comment more only after I reach home.

Try a different USB port, and remove any other USB devices just in case there is a conflict.

If you are running USB wireless that might be a problem too.

I’m guessing the drive has an NTFS partition on it?

My 1tb MyBook works fine too, no speed demon though -

laptop: Timing buffered disk reads: 94 MB in 3.06 seconds = 30.75 MB/sec

desktop: Timing buffered disk reads: 74 MB in 3.08 seconds = 24.06 MB/sec

My drive has one single encrypted ReiserFS partition, so I can’t give you windows figures.

Odd how my faster desktop has a slower transfer rate though!