Slow startup after login

What can I do to speed up the start-up after login?

I am running OpenSuse 11.3 with Gnome on my laptop (Acer Travelmate 2490) and I need about two and a half minutes from login until the hard disk lamp ‘settles down’. This is much longer than I have been used to expect from earlier OpenSus versions. Are there some default applications/processes I could ditch?

hnimmo wrote:

>
> What can I do to speed up the start-up after login?
>
> I am running OpenSuse 11.3 with Gnome on my laptop (Acer Travelmate
> 2490) and I need about -two and a half minutes- from login until the
> hard disk lamp ‘settles down’. This is much longer than I have been used
> to expect from earlier OpenSus versions. Are there some default
> applications/processes I could ditch?
>
>
This does not really sound like starting too many processes but some other
problems.
While your machine starts can you simply press [esc] to see the verbose
output on the screen which tells you what happens while your system starts?
Are there error messages (red colored “fail”).
Do you see something strange in /var/log/boot.msg?


openSUSE 11.3 64 bit | Intel Core2 Quad Q8300@2.50GHz | KDE 4.5 | GeForce
9600 GT | 4GB Ram
openSUSE 11.3 64 bit | Intel Core2 Duo T9300@2.50GHz | KDE 4.5 | Quadro FX
3600M | 4GB Ram

Does your Acer Travelmate 2490 have Mobile Intel® 940GML graphics ?

Out of curiousity, what is you boot speed if you select the Safe Settings? Or what is your boot speed if you apply the boot code ‘nomodeset’. Is there any difference?

It has Intel® Graphics Media Accelerator 950. Does that make sense?

Yes, the GMA 950 has been around for a while.

Typically the “think wiki” has great information on graphics, … and even though the thinkwiki is intended for IBM/Lenovo, often the information there is applicable to other platforms …

The thinkwiki has this on the GMA 950: Intel Graphics Media Accelerator 950 - ThinkWiki

… some selected quotes:

Disabling KMS

If KMS causes you problems, you can disable it and return to user mode setting (UMS) by booting with the nomodeset kernel boot option. Note that this is no longer an option starting with version 2.10 of the Intel Xorg driver as UMS support has been dropped.

Recall I recommended you try the boot code “nomodeset”.

Out of curiousity, what do you get from:

su -c 'lspci -nnk | grep VGA' 

and enter root password when prompted. … I’m curious to see your vendor-id/device-id of your graphic card. Is it a 8086:27a2 ?

… Note I am assuming in this and in the above poss that you have no hardware failure/problem.

Any feedback on this question?

After a rather lengthy break, I can now turn my attention to these problems again. My apologies to all who have been waiting and a heartfelt thanks for your patience.

I am now running OpenSuSE 11.4/KDE4/32bit and getting similar behaviour. There is no obvious difference if I boot with ‘nomodeset’. (I have recorded the next paragraph in another thread)

I am noticing that for about 20 minutes (or more) after first login every time there is a process which takes 100% CPU for most of the time and, of course, slows everything down. (In fact, while I have been writing this the CPU has been running at 100% for about 40 minutes). The system monitor suggests it is the ‘tracker-miner’ process (whatever that is). Do I need the tracker-miner? What good does it do? Is there any way to stop it (not to start it)?

Would it make any difference if I switched to gnome?

With

 su -c 'lspci -nnk | grep VGA'

I get

00:02.0 VGA compatible controller [0300]: Intel Corporation Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller [8086:27a2] (rev 03)

At boot-up I have error messages (also with the previous OpenSuse 11.3 configuration) some of which are difficult to get hold of down because they appear before the log start to record them. The ones in the bootmsg log are:

ERROR: Unable to canonicalize path "/lib/modules/2.6.37.1-1.2-desktop/systemtap/preloadtrace.ko": No such file or directory
Error, 'preloadtrace' is not a zombie systemtap module.
Retrying, after attempted removal of module preloadtrace (rc -5)
ERROR: Unable to canonicalize path "/lib/modules/2.6.37.1-1.2-desktop/systemtap/preloadtrace.ko": No such file or directory

Before the above there are also ‘FATAL’ errors related to ata-pix (or something like that) during boot-up which do not appear in the bootmsg log.

Does anyone have any ideas?

I don’t know if that is relevant. I think this is the preload package trying to load the preload kmp but it’s not there.

Thanks for the tip. Obviously, there must have been some kind of legacy problem between my updates, However, it was not relevant for the slow boot-up problem :(. I have installed the preload modules and the errors are no longer there. What is the difference between preload-default and kernel-desktop?

The fatal errors ahead of the bootmsg log are to do with ata-piix and pci-generic.

Although I don’t have such as problem as the OP has with startup, I do get annoyed by “preload” taking way too many resources on my harddrive upon startup - does anyone know how to turn off preload altogether? I looked on the Wiki for any documentation, but it all appears to have been pulled from there. It’s been a thorn for me since 10.3…

On 2011-04-03 22:06, hnimmo wrote:

> The
> system monitor suggests it is the ‘tracker-miner’ process (whatever that
> is). Do I need the tracker-miner? What good does it do? Is there any way
> to stop it (not to start it)?

Search indexer.


Cheers / Saludos,

Carlos E. R.
(from 11.2 x86_64 “Emerald” at Telcontar)

… ahh … one is the kernel. One is not …

More detail:

preload-kmp-default is a package that works with preload hand in hand to make sure no unnecessary files are preload.

Preload lists files to load into the system cache. This shortens system boot time if used correctly.

kernel-desktop is a Kernel optimized for the desktop. It is configured for lower latency and has many of the features that aren’t usually used on desktop machines disabled.

Sorry, oldcpu. I put my question wrongly. I’ll try again: what is the difference between preload-kmp-default and preload-kmp-desktop? I have installed them both, and a kernel version was installed at the same time.

My view is one should only require the preload-kmp-version that corresponds to one’s kernel. ie each is optimised for either the default or the desktop kernel.

So if one has the kernel-default installed, then the preload-kmp-default is installed with that kernel. If one has the kernel-desktop installed, then the preload-kmp-desktop is installed with that kernel.

Desktop as opposed to server? Desktop as opposed to mobile device? But we are getting distracted!

I still have my CPU load problem after login!

I see you started another thread on same topic ! : Kdeinit4/tracker-miner hogs CPU for ages after login

Please - one thread only please per problem.

You could take a read here to see if there is anything that might help you: [opensuse] where do I turn tracker off at?](http://linux.derkeiler.com/Mailing-Lists/SuSE/2010-05/msg01125.html)

It appears you inadvertently installed something extra that was not appropriate.

On 2011-04-03 23:06, hnimmo wrote:

> What is the difference between preload-default and
> kernel-desktop?

preload-default is intended for kernel-default.


Cheers / Saludos,

Carlos E. R.
(from 11.2 x86_64 “Emerald” at Telcontar)

You are right. I started the other thread after installing OpenSuse 11.4, not being sure it was the same problem as I had with Opensuse 11.3 and Gnome (still not sure). I do try to stick to the ‘one thread per problem’ rule, though.

I concluded from the link (for which, many thanks!) that 1) I can delete tracker without much penalty, 2) it is probably a legacy from my previous gnome installation and 3) it may well hog the cpu. I will try that and see what happens.

Now I have remove ‘tracker’ and the period of 100% CPU is down from 40 minutes to about 5 minutes. But 5 minutes is still too long. What else shall I look for? The system monitor is now showing that the kmp preload is running for a while after login.

How about checking out what is running during a boot ? Install bootchart and check to see what process is consuming the CPU !

Look at post#19 here in this thread:
OpenSuSE 11.4 review

Here is the bootchart.png of my sandbox PC, which is a truely ancient 32-bit athlon-1100 (running 11.4) with no optimisation (immediately after the install) and a rather slow and ancient nVidia FX5200 graphic card:
http://thumbnails38.imagebam.com/12247/83627c122466758.jpg](http://www.imagebam.com/image/83627c122466758)

boot chart identified some areas that could be tuned …

Here is the same ancient athlon-1100 with the same openSUSE-11.4 install but with apparmor removed and the number of VT (terminal) sessions reduced. Much faster to boot (from 120 seconds to 85 seconds):
http://thumbnails38.imagebam.com/12248/019cec122475663.jpg](http://www.imagebam.com/image/019cec122475663)

I assume that dependent on when the terminal is opened after rebooting will dictate when the data collection for the chart is stopped (I’m not sure - as I am no expert).