Slow scrolling in FF after update.

I noticed this past week (Tue or Wed?) that after a auto system update scrolling in FF became very jerky and the only way to fix it was to disable Desktop Effects. I know others are having the same problem see here:

Became slow… - openSUSE Forums

Has anyone figured out what the problem is and how to correct it?


That is my thread.
Still searching and waiting for a solution.

If it helps Opera seems to be OK.

Just tried with others.
Same thing as was b4.

I’ve noticed this too and reverted one of the updates (the latest xorg video that came somewhere around mid July). That did the trick for me.

Are you also using an Intel video card? There are some settings you could try adding in the xorg.conf.

yes, video card is Intel.

You could try adding this to the device section in xorg.conf

  Option       "AddARGBGLXVisuals" "True"
  Option       "XAANoOffscreenPixmaps" "true"
  Option       "DRI"        	"true"	
  Option       "AccelMethod"	"Xaa"	# Xaa old stable, EXA is new and better.

it would then look something like this;

Section "Device"
  BoardName    "945 GM"
  BusID        "0:2:0"
  Driver       "intel"
  Identifier   "Device[0]"
  Option       "AddARGBGLXVisuals" "True"
  Option       "XAANoOffscreenPixmaps" "true"
  Option       "DRI"        	"true"	
  Option       "AccelMethod"	"Xaa"	# Xaa old stable, EXA is new and better.
  Option       "monitor-LVDS" "Monitor[0]"



> Just tried with others.
> Same thing as was b4.
Try disabling desktop effects. Not a permanent solution,
but solved a lot of sluggishness and general performance
problems with the video for me.

Thankyou so much Magic31,
Its works perfectly.
Any body have Intel graphics, can use this if your graphics not working properly.

Erm, as a n00b in the cradle, could I request that someone elaborate a bit on Magic31’s answer? I’ve just made the switch from Windows and I’ve been having the same problem

You have Intel graphic accelerator,rite.
If Yes.
Just simply go to etc folder then X11 and then xorg.conf file to edit.You need root access to modify that file.

So better to use terminal.
open terminal and type

su -
and enter your root password.
After typing password, type:

gedit /etc/X11/xorg.conf

It will open a file for u to edit.put the above post data by Magic there, and save and restart PC.

Is this what you want…

I posted the 1st or 2nd original post on this issue.

I have now re-installed SuSE 11. These are my results:

My system is a 3.2 Intel pent. with 2 gigs of memory. The video card is an on board Intel chip which shares memory with the system.

On a standard install without update, desktop effects are not enabled as default. Speed is fine. Switching on desktop effects has a very very slight effect on performance of the desktop.

I then added all updates apart from Kernel and Xorg11 7.3-110.7 and 7.3-138.3 (some Xorg font and utility updates were added nevertheless). There did not seem to be any change in desktop performance.

I then had to chose - so I chose to install the kernel update. The desktop response was noticeably slower with desktop effects, however, the difference was not significant but it was noticeable.

Adding the Xorg.11 update killed the system. The desktop and internet browser performance fell through the floor. I would rather run Windows XP than SuSE 11 with all updates. (For a former OS/2 user, that is saying a lot)

Hope this helps.


Did you try Magic31 post, as you mention you have on board Intel hardware.
That solve the problem for me.

Magic31 pointed it out in a short way. SInce I got the same problem with a Intel i965 G chipset, here is an according bug tracker entry I made for the Intel hardware acceleration
Bug 16773 - Broken systray when using “MigrationHeuristic” “greedy”, bad performance using “always”+“smart”

Even easier saying: If you use automatic updates from OpenSUSE, especially for the X.Org packages: There were changed some compiled-in defaults on OpenSUSE for hardware acceleration modules on Intel graphic chips in X Server. The default xorg.conf (X server configuration file) left those defaults and did not explicitely overwrite them:
The key option for this is:
which changed with the last updates implicitely from value
because XAA is no longer supported by Intel and will be removed in the nearer future from the code.
So far so good, but EXA still has problems (it is not ready, see my bug tracker entry above), which means, that on some Intel chipsets still work optimally only with “XAA”, or “EXA” with some extra options, which you have to try in your special case.