Slow online updates definitely due to IPv6

I recently posted in the Application section about my problems installing and updating software. It was titled “Incessant Software Repository issues”. This problem actually began immediately during all my installations of openSUSE 10.3, 11.1 and 11.2, so I should have posted it here in Install/Boot/Login.

Global Moderator oldcpu replied:

I also wonder if this is country and/or ISP dependent. I do not see such issues here in Germany.

One thing you could try, during your install, is to DISABLE ipv6 when given that selection offering. That “might” reduce the number of interactions/retries.

So I tested two installations of openSUSE 11.1. I performed one installation leaving IPv6 enabled by default. The 2nd installation was performed by disabling IPv6 during installation. My tests performed in St. Louis, MO, clearly indicated that IPv6 was a serious problem for software installation and updates via the software repositories.

Since then, I have considered selecting mirrors of repositories that are close to me. However, I am wondering if I do this, will software installations fail if that repository is unavailable?

I also wonder if using ftp is practical and if redirection is used with ftp.

Changing and modifying repositories was painful for me using yast because each time the repository section is modified, yast attempts to download the metadata. If there is poor network connectivity to the repository, there are time outs and the retry, abort, skip choices don’t necessarily stop yast from trying to connect again and again.

I tried using zypper with success to add repositories. During my tests I had removed all the repositories except for the update repository. I added back the default repositories and additional repositories with the following commands:

zypper ar updates
zypper ar oss
zypper ar non-oss
zypper ar debug
zypper ar src-oss
zypper ar src-non-oss
zypper ar contrib
zypper ar java
zypper ar packman
zypper ar vlc

You can view the results with

zypper lr -u

-u shows the url of the repositories. That switch does not appear in “zypper help”, or I didn’t see it. However the help for the lr command below shows it.

# zypper lr -h
repos (lr) [options]

List all defined repositories.

  Command options:
-e, --export <FILE.repo>  Export all defined repositories as a single local .repo file.
-u, --uri                 Show also base URI of repositories.
-p, --priority            Show also repository priority.
-d, --details             Show more information like URI, priority, type.
-U, --sort-by-uri         Sort the list by URI.
-P, --sort-by-priority    Sort the list by repository priority.
-A, --sort-by-alias       Sort the list by alias.
-N, --sort-by-name        Sort the list by name.
-s, --service             Show also alias of parent service.

During the first software install, metadata from all those repositories had to be downloaded, and I had approve two or three GNUpnp keys.

I hope anyone trying to install openSUSE learns of the IPv6 issue before beginning their first installation and remembers to disable it with each subsequent installation.


I suggest this is a local problem. I have never ever disabled IPv6 and I have never had any of the problems you have described. Updates are normally over in a few seconds and I have never had any problems with the repositories (other than the occasional certificate problem which is nothing to do with IPv6).

People may need to be aware that it may be a problem in some parts of the world in much the same way as they need to be aware about codecs.

I likewise add the same problem. My windos box was fast on the internet and my SUSE box was about 1/3 the speed opening websites. Problem was solved by disabling the IPV6 stuff.